summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-dicts/steak/Manifest1
-rw-r--r--app-dicts/steak/files/steak-1.7.3.patch18
-rw-r--r--app-dicts/steak/metadata.xml4
-rw-r--r--app-dicts/steak/steak-1.7.3-r2.ebuild53
4 files changed, 76 insertions, 0 deletions
diff --git a/app-dicts/steak/Manifest b/app-dicts/steak/Manifest
new file mode 100644
index 00000000..883926f3
--- /dev/null
+++ b/app-dicts/steak/Manifest
@@ -0,0 +1 @@
+DIST Steak.1.7.3.tar.bz2 982350 SHA256 fc3a9ad762bb89afea1ec1ed5ea5abccebcb11182f93332bdc84b1191b92fbcb
diff --git a/app-dicts/steak/files/steak-1.7.3.patch b/app-dicts/steak/files/steak-1.7.3.patch
new file mode 100644
index 00000000..8c1b6a07
--- /dev/null
+++ b/app-dicts/steak/files/steak-1.7.3.patch
@@ -0,0 +1,18 @@
+--- woerterbuch.alt 2004-12-04 23:34:28.115707552 +0100
++++ woerterbuch 2004-12-04 23:41:19.259204240 +0100
+@@ -6,13 +6,13 @@
+ ################################################################
+ #
+ # Unter diesem Verzeichnis ist die Woerterbuch-Datei zu finden
+-SteakDIR=$HOME/bin/Steak/Datensatz
++SteakDIR=/usr/share/Steak/Datensatz
+ #SteakDIR=$HOME/bin/Steak/Datensatz
+ # Der Name der Woerterbuch-Datei
+ SteakFILE=ger-eng.txt
+ #SteakFILE=Datenbank.txt
+ # Unter diesem Verzeichnis ist die ausfuehrbaren Dateien zu finden
+-BINDIR=$HOME/bin/Steak
++BINDIR=/usr/bin
+ #BINDIR=$HOME/bin/Steak
+ # Temp-Dir
+ TMPDIR=/tmp
diff --git a/app-dicts/steak/metadata.xml b/app-dicts/steak/metadata.xml
new file mode 100644
index 00000000..097975e3
--- /dev/null
+++ b/app-dicts/steak/metadata.xml
@@ -0,0 +1,4 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+</pkgmetadata>
diff --git a/app-dicts/steak/steak-1.7.3-r2.ebuild b/app-dicts/steak/steak-1.7.3-r2.ebuild
new file mode 100644
index 00000000..5d8119d1
--- /dev/null
+++ b/app-dicts/steak/steak-1.7.3-r2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+RESTRICT="mirror"
+
+DESCRIPTION="EN => DE Dictionary"
+HOMEPAGE="http://www.tm.informatik.uni-frankfurt.de/~razi/steak/steak.html"
+HOMEPAGE="http://www.tm.informatik.uni-frankfurt.de/~razi/steak"
+#SRC_URI="http://www.tm.informatik.uni-frankfurt.de/~razi/steak/program/Steak.${PV}.tar.gz"
+SRC_URI="http://www-stud.rbi.informatik.uni-frankfurt.de/~razi/steak/program/Steak.${PV}.tar.bz2"
+use_rpm=false
+if $use_rpm
+then SRC_URI="ftp://84.41.185.108/suse/9.1/suse/src/${P}-251.src.rpm"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE=""
+
+DEPEND="app-text/recode"
+! ${use_rpm} || DEPEND=${DEPEND}" app-arch/rpm2targz"
+RDEPEND=""
+
+S=${WORKDIR}/Steak
+
+PATCHES=("${FILESDIR}/${P}.patch")
+
+! ${use_rpm} || src_unpack() {
+ cd "${WORKDIR}"
+ rpm2targz "${DISTDIR}/${A}"
+ tar -xzf "${P}-251.src.tar.gz"
+ tar -xjpf "Steak.${PV}.tar.bz2"
+}
+
+src_prepare() {
+ eapply_user
+ recode latin1..utf8 "${S}"/Datensatz/ger-eng.txt || die
+}
+
+src_install() {
+ insinto /usr/share/Steak/Datensatz
+ doins Datensatz/ger-eng.txt
+
+ insinto /usr/share/Steak
+ doins mini_steak_icon.xpm pinguin_steak_icon.xpm .Steakconfig
+
+ dobin woerterbuch printbuffer iso2txt spacefilter poll
+ dosym /usr/bin/woerterbuch /usr/bin/steak
+
+ dodoc copyrights.txt help.txt version.txt README README.eng
+}