summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-shells/termcolors-mv/ChangeLog7
-rw-r--r--app-shells/termcolors-mv/Manifest2
-rw-r--r--app-shells/termcolors-mv/metadata.xml3
-rw-r--r--app-shells/termcolors-mv/termcolors-mv-2.0.ebuild (renamed from app-shells/termcolors-mv/termcolors-mv-1.1.ebuild)25
-rw-r--r--app-shells/zshrc-mv/ChangeLog5
-rw-r--r--app-shells/zshrc-mv/Manifest2
-rw-r--r--app-shells/zshrc-mv/zshrc-mv-2.0.ebuild (renamed from app-shells/zshrc-mv/zshrc-mv-1.7.ebuild)0
-rw-r--r--profiles/use.local.desc2
8 files changed, 34 insertions, 12 deletions
diff --git a/app-shells/termcolors-mv/ChangeLog b/app-shells/termcolors-mv/ChangeLog
index cbe20bce..d1ff4a0a 100644
--- a/app-shells/termcolors-mv/ChangeLog
+++ b/app-shells/termcolors-mv/ChangeLog
@@ -2,6 +2,13 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*termcolors-2.0 (23 Mar 2013)
+
+ 23 Mar 2013; Martin Väth <martin@mvath.de>
+ Version bump, remove old ebuild.
+ Support solarized if SOLARIZED is set for the new dircolors wrapper.
+ No file collisions anymore. Make 256colors perl script optional.
+
*termcolors-1.1 (06 Jan 2013)
06 Jan 2013; Martin Väth <martin@mvath.de>
diff --git a/app-shells/termcolors-mv/Manifest b/app-shells/termcolors-mv/Manifest
index ce0fcbe8..67e95f75 100644
--- a/app-shells/termcolors-mv/Manifest
+++ b/app-shells/termcolors-mv/Manifest
@@ -1 +1 @@
-DIST termcolors-mv-1.1.tar.gz 7823 SHA256 800a9a88f8752d11ae9f38a6b83558868719157855773d43378b05b9718ccc25 SHA512 7688ef3c2b496c0ff37b44525f456004e6d2afa55ea0ce8f215673e1d77aec8058dbcdf37649208b2bd5acdc5d0404978fd40391056df2dbe3a75af2eaeb00c2 WHIRLPOOL 7fa592e10bb80c9ac950f7fa47ea7d4e1bee78cb87b542e80b671a64dd90aa96107b784281960ef2ec07f2186d50d86bd7fcadb26d689f130be612e5218c181e
+DIST termcolors-mv-2.0.tar.gz 9253 SHA256 7905858f44af975ab84e2011bc5ff1170b7f48e4ec20e97f7f224d9b3323173b SHA512 c39648c38a49710fb64593da07c344ed09ff16689b896bfe822f9245600c8ce5a8b326ed2ba192a1868c358434306df70a9589fafc681110425694a4ff53f67b WHIRLPOOL 128d8f386c8e8f081d9a53bd970075ca79f41297bbd6fb44ee6a0697719b31be52f124f4298f12d069446d0413129df5952ed3e4870c01a6359e10141f031e5e
diff --git a/app-shells/termcolors-mv/metadata.xml b/app-shells/termcolors-mv/metadata.xml
index e8c87211..e72e7dfe 100644
--- a/app-shells/termcolors-mv/metadata.xml
+++ b/app-shells/termcolors-mv/metadata.xml
@@ -13,4 +13,7 @@
<bugs-to>mailto:martin@mvath.de</bugs-to>
<remote-id type="github">vaeth/termcolors-mv</remote-id>
</upstream>
+ <use>
+ <flag name="perl">Install 256colors perl script</flag>
+ </use>
</pkgmetadata>
diff --git a/app-shells/termcolors-mv/termcolors-mv-1.1.ebuild b/app-shells/termcolors-mv/termcolors-mv-2.0.ebuild
index ef43b3dd..d8ceba91 100644
--- a/app-shells/termcolors-mv/termcolors-mv-1.1.ebuild
+++ b/app-shells/termcolors-mv/termcolors-mv-2.0.ebuild
@@ -13,23 +13,30 @@ SRC_URI="http://github.com/vaeth/${PN}/tarball/release-${PV} -> ${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="perl"
+REDEPEND="perl? ( dev-lang/perl )"
src_prepare() {
epatch_user
}
src_install() {
- dobin bin/*
+ dodoc README
+ dobin bin/dircolors-mv
+ use perl && dobin bin/256colors
insinto /etc
- doins etc/*
+ doins -r etc/*
}
pkg_postinst() {
- elog "To use ${PN} with 256 colors, you have to call"
- elog " eval \"\`dircolors /etc/DIR_COLORS-256\`\""
- elog "e.g. in your bashrc."
- if ! has_version app-shells/zshrc-mv
- then elog "For zsh, this happens if you use zshrc-mv"
- fi
+ case "${REPLACING_VERSIONS:-1.1}" in
+ 1.1)
+ elog "To use the colorschemes of ${PN} call"
+ elog " eval \"\`dircolors-mv\`\""
+ elog "e.g. in your bashrc; make sure that SOLARIZED (if desired)"
+ elog "and DEFAULTS is set appropriately, see the documentation."
+ if ! has_version app-shells/zshrc-mv
+ then elog "For zsh, this happens if you use zshrc-mv"
+ fi;;
+ esac
}
diff --git a/app-shells/zshrc-mv/ChangeLog b/app-shells/zshrc-mv/ChangeLog
index 26031408..f8fb3273 100644
--- a/app-shells/zshrc-mv/ChangeLog
+++ b/app-shells/zshrc-mv/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*zshrc-2.0 (23 Mar 2013)
+
+ 23 Mar 2013; Martin Väth <martin@mvath.de>
+ Version bump, remove old ebuild. Support solarized if SOLARIZED is set.
+
*zshrc-1.7 (21 Feb 2013)
21 Feb 2013; Martin Väth <martin@mvath.de>
diff --git a/app-shells/zshrc-mv/Manifest b/app-shells/zshrc-mv/Manifest
index bb5f1b7c..6e068369 100644
--- a/app-shells/zshrc-mv/Manifest
+++ b/app-shells/zshrc-mv/Manifest
@@ -1 +1 @@
-DIST zshrc-mv-1.7.tar.gz 7648 SHA256 53e16e76b41be2352a2b8a9869107d8c6daef3e857351515bf0e29516ef057d8 SHA512 b1694a9ab071ea780a370a870b33da7f0881676b540aa688d1264e918614f75c9d2e10f538547dead20a1dc5b858aead58e16bb93d80be2d21004991f14e39a6 WHIRLPOOL e0d254fd58b1cdce24f7f26ca3d460fd96173827f22f801588490256a65aa63fe6bf4698e271f204e7b31f201dc7416c0b94ed19d20708d97c38a77cbe4def74
+DIST zshrc-mv-2.0.tar.gz 8112 SHA256 e911bcebb8d117d7d8c486453667d08cf5667680a996fe640c6d1127b09c92cc SHA512 e4d28f678e44ac67d9ee4842bbaf6940dbcff9f99ac2f2068a1d92177b32b227fa3607c096bb02f985c67c352e222f92a48e369e95ea315f2c081483e9ee31fa WHIRLPOOL 2088a0964664799e06bfbc00e3d5b2a5d17a4018fc5e423ddd8e7663df86a5904c0982e40f666cce6684169c37785d8ce6441054083ae881f541e97571894270
diff --git a/app-shells/zshrc-mv/zshrc-mv-1.7.ebuild b/app-shells/zshrc-mv/zshrc-mv-2.0.ebuild
index 49f92186..49f92186 100644
--- a/app-shells/zshrc-mv/zshrc-mv-1.7.ebuild
+++ b/app-shells/zshrc-mv/zshrc-mv-2.0.ebuild
diff --git a/profiles/use.local.desc b/profiles/use.local.desc
index 73cdbc42..55b9a8fe 100644
--- a/profiles/use.local.desc
+++ b/profiles/use.local.desc
@@ -6,7 +6,6 @@ app-portage/eix:clang - Use sys-devel/clang for building
app-portage/eix:debug - Build with upstream's CXXFLAGS/LDFLAGS for debugging support; not recommended for normal use.
app-portage/eix:dep - Make DEP=true the default which enables support for {,R,P}DEPEND but requires roughly double disk and memory.
app-portage/eix:doc - Create description of the eix cache file additionally in html format
-app-portage/eix:nls - Support foreign language messages (experimental; currently only de)
app-portage/eix:optimization - Accept upstream's choices for CXXFLAGS/LDFLAGS for optimization. Absense of this USE flag does not strip user's *FLAGS
app-portage/eix:security - This adds some checks which can prevent certain exploits if e.g. the eix code has a bug. If you use the hardened toolchain, using this flag does not increase security and can even lead to problems.
app-portage/eix:sqlite - Compile in support for portage's sqlite backend; to actually use it you need additional configuration of portage and eix
@@ -15,6 +14,7 @@ app-portage/eix:strong-security - Add many checks to prevent exploits if eix cod
app-portage/eix:swap-remote - Swap role of remote addresses in eix-remote, making the data from gpo.zugaina.org the first choice.
app-portage/eix:tools - Create separate binary for script helper tools; useful if they are called extremely often
app-shells/auto-fu-zsh:compile - Byte-compile to speed up
+app-shells/termcolors-mv:perl - Install 256colors perl script
app-shells/zsh:completion_AIX - install completions for AIX
app-shells/zsh:completion_BSD - install completions for BSD
app-shells/zsh:completion_Cygwin - install completions for Cygwin