summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-cdr/xcdroast/Manifest1
-rw-r--r--app-cdr/xcdroast/files/cdda2wav_version.patch54
-rw-r--r--app-cdr/xcdroast/files/fix_cddb_hidden_tracks.patch45
-rw-r--r--app-cdr/xcdroast/files/io_compile.patch21
-rw-r--r--app-cdr/xcdroast/files/io_progressbar_fix.patch39
-rw-r--r--app-cdr/xcdroast/files/suid-perms.patch36
-rw-r--r--app-cdr/xcdroast/metadata.xml12
-rw-r--r--app-cdr/xcdroast/xcdroast-0.98_alpha16-r2.ebuild77
8 files changed, 0 insertions, 285 deletions
diff --git a/app-cdr/xcdroast/Manifest b/app-cdr/xcdroast/Manifest
deleted file mode 100644
index 6451eb36..00000000
--- a/app-cdr/xcdroast/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST xcdroast-0.98alpha16.tar.gz 3563666 SHA256 a2b96bb9799b5880befe2d01c5e6a0b63110dd61f59384935b750e72bc73984d
diff --git a/app-cdr/xcdroast/files/cdda2wav_version.patch b/app-cdr/xcdroast/files/cdda2wav_version.patch
deleted file mode 100644
index cd001e0e..00000000
--- a/app-cdr/xcdroast/files/cdda2wav_version.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-diff -urNad xcdroast-0.98+0alpha16~/src/io.c xcdroast-0.98+0alpha16/src/io.c
---- xcdroast-0.98+0alpha16~/src/io.c 2008-08-21 15:11:40.000000000 +0200
-+++ xcdroast-0.98+0alpha16/src/io.c 2009-12-29 22:54:08.571188849 +0100
-@@ -10062,6 +10062,7 @@
-
- gint check_version_cdda2wav(gchar *match, gchar *found) {
- gchar line[MAXLINE];
-+gchar vline[MAXLINE];
- gchar ver[MAXLINE];
- FILE *fpin;
- gchar *p;
-@@ -10076,32 +10077,38 @@
- }
-
- strcpy(line,"");
-+ strcpy(vline,"");
- for (;;) {
- if (fgets(line,MAXLINE,fpin) == NULL)
- break;
- dodebug(10,"got: %s",line);
-+
-+ /* only get first line */
-+ if (strcmp(vline,"") == 0) {
-+ strncpy(vline, line, MAXLINE);
-+ }
- }
-
- if (pclose(fpin) == -1) {
- g_error("pclose error\n");
- }
-
-- if (strcmp(line,"") == 0 || strstr(line,"sh:") != NULL) {
-+ if (strcmp(vline,"") == 0 || strstr(vline,"sh:") != NULL) {
- /* failed to open - permission denied */
- return 2;
- }
-
-- /* now line contains the version string of cdda2wav */
-+ /* now vline contains the version string of cdda2wav */
- /* try to extract the version number */
-
-- p = strstr(line,"version");
-+ p = strstr(vline,"version");
- if (p != NULL) {
- p = strtok(p+8, " _");
- if (p != NULL) {
- strcpy(ver,p);
- }
- } else {
-- p = strstr(line,"cdda2wav");
-+ p = strstr(vline,"cdda2wav");
- if (p != NULL) {
- p = strtok(p+9, " ");
- if (p != NULL) {
diff --git a/app-cdr/xcdroast/files/fix_cddb_hidden_tracks.patch b/app-cdr/xcdroast/files/fix_cddb_hidden_tracks.patch
deleted file mode 100644
index ca532f20..00000000
--- a/app-cdr/xcdroast/files/fix_cddb_hidden_tracks.patch
+++ /dev/null
@@ -1,45 +0,0 @@
---- a/src/io.c
-+++ b/src/io.c
-@@ -2665,6 +2665,8 @@
- g_error("Unexpected output in cdda2wav toc-output\n");
- }
- trackinfo[tocnr]->track_nr = atoi(p1);
-+ if (trackinfo[tocnr]->track_nr == 0)
-+ cdinfo.nr_tracks++;
- trackinfo[tocnr]->isosize = -1;
-
- /* reststring into tmp2 - strip to remove leading spaces */
-@@ -8401,6 +8403,9 @@
- if (extract_quoted(tmp) != 0)
- return;
-
-+ if (matchnr == 0 && trackinfo[matchnr]->track_nr == 0)
-+ matchnr++;
-+
- if (mode == 0) {
- if (matchnr >= cdinfo.nr_tracks) {
- g_warning("invalid track count from cddb-server\n");
-@@ -8482,14 +8487,20 @@
-
- /* build of command line */
- if (mode == 0 || mode == 2) {
-+ gint ntr = cdinfo.nr_tracks;
-+
-+ if (ntr > 0 && trackinfo[0]->track_nr == 0)
-+ ntr--;
- g_snprintf(tmp,MAXLINE,"cddb query %s %d ",
-- cdinfo.cddb_discid, cdinfo.nr_tracks);
-+ cdinfo.cddb_discid, ntr);
- for (i = 0; i < cdinfo.nr_tracks; i++) {
-+ if (trackinfo[i]->track_nr == 0)
-+ continue;
- g_snprintf(tmp2,MAXLINE,"%d ",
- trackinfo[i]->start_sec + 150);
- strcat(tmp,tmp2);
- }
-- g_snprintf(tmp2,MAXLINE,"%d",cdinfo.total_size / 75);
-+ g_snprintf(tmp2,MAXLINE,"%d",(cdinfo.leadout + 150) / 75);
- strcat(tmp,tmp2);
- } else {
- /* get data from toc file */
-
diff --git a/app-cdr/xcdroast/files/io_compile.patch b/app-cdr/xcdroast/files/io_compile.patch
deleted file mode 100644
index 339523d4..00000000
--- a/app-cdr/xcdroast/files/io_compile.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- a/src/io.c.org 2009-02-24 09:38:27.000000000 +0100
-+++ b/src/io.c 2009-02-24 09:45:18.000000000 +0100
-@@ -1903,7 +1903,8 @@
- }
-
- strcpy(str,"");
-- fgets(str,MAXLINE,fpin);
-+ if (fgets(str,MAXLINE,fpin) == NULL)
-+ g_error("fgets error\n");
-
- if (pclose(fpin) == -1) {
- g_error("pclose error\n");
-@@ -4720,7 +4721,7 @@
- dolog(3, "Saving extended output to %s\n", fname);
-
- /* write to file */
-- fd = open(fname,O_WRONLY | O_CREAT);
-+ fd = open(fname, O_WRONLY | O_CREAT, S_IRUSR | S_IWUSR);
- if (fd < 0) {
- g_warning("Can't open file %s for writing\n",fname);
- return 1;
diff --git a/app-cdr/xcdroast/files/io_progressbar_fix.patch b/app-cdr/xcdroast/files/io_progressbar_fix.patch
deleted file mode 100644
index 745af45d..00000000
--- a/app-cdr/xcdroast/files/io_progressbar_fix.patch
+++ /dev/null
@@ -1,39 +0,0 @@
---- a/src/io.c.last So. Jan 24 19:18:45 2010
-+++ b/src/io.c Fr. Jul 16 10:59:32 2010
-@@ -3202,6 +3202,8 @@
- close(fd2[1]);
- }
-
-+ g_setenv("LC_ALL", "C", TRUE);
-+
- /* startup child */
- if (execl("/bin/sh", "sh", "-c", cmd ,(void *)NULL) < 0) {
- g_error("execl error\n");
-@@ -3402,6 +3404,8 @@
- close(fd3[1]);
- }
-
-+ g_setenv("LC_ALL", "C", TRUE);
-+
- /* startup child */
- if (execv(callpath,arglist) < 0) {
- g_error("execv error\n");
-@@ -3506,6 +3510,8 @@
- close(pipefd[1]);
- }
-
-+ g_setenv("LC_ALL", "C", TRUE);
-+
- /* startup first child */
- if (execv(callpath,arglist) < 0) {
- g_error("execv error\n");
-@@ -3568,6 +3574,8 @@
- close(fd3[1]);
- }
-
-+ g_setenv("LC_ALL", "C", TRUE);
-+
- /* startup second child */
- if (execv(callpath2,arglist2) < 0) {
- g_error("execv error\n");
-
diff --git a/app-cdr/xcdroast/files/suid-perms.patch b/app-cdr/xcdroast/files/suid-perms.patch
deleted file mode 100644
index 1c804bc1..00000000
--- a/app-cdr/xcdroast/files/suid-perms.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-diff -Naurd xcdroast-0.98alpha16.orig/doc/README.nonroot xcdroast-0.98alpha16/doc/README.nonroot
---- xcdroast-0.98alpha16.orig/doc/README.nonroot 2003-10-27 23:37:40.000000000 +0300
-+++ xcdroast-0.98alpha16/doc/README.nonroot 2016-07-07 21:32:35.006587826 +0300
-@@ -72,7 +72,7 @@
- Please change now to the corresponding directory and enter:
-
- chown root xcdrwrap
-- chmod 4755 xcdrwrap
-+ chmod 4711 xcdrwrap
-
-
- Usage of the non-root-mode
-diff -Naurd xcdroast-0.98alpha16.orig/src/init.c xcdroast-0.98alpha16/src/init.c
---- xcdroast-0.98alpha16.orig/src/init.c 2008-08-20 20:20:23.000000000 +0400
-+++ xcdroast-0.98alpha16/src/init.c 2016-07-07 21:32:35.006587826 +0300
-@@ -670,7 +670,7 @@
-
- /* check file mode of wrapper */
- if (stat(tmp,&buf) == 0) {
-- if (buf.st_mode != 0104755) {
-+ if (buf.st_mode != 0104711) {
- dodebug(3,"Note: %s wrong modes set (0%o)\n", tmp, buf.st_mode);
- nofail = 0;
- }
-diff -Naurd xcdroast-0.98alpha16.orig/src/io.c xcdroast-0.98alpha16/src/io.c
---- xcdroast-0.98alpha16.orig/src/io.c 2008-08-21 17:11:40.000000000 +0400
-+++ xcdroast-0.98alpha16/src/io.c 2016-07-07 21:32:35.003587931 +0300
-@@ -10380,7 +10380,7 @@
- strcat(ret,tmp);
- #endif
- /* old nonroot mode - 2755 */
-- g_snprintf(tmp,MAXLINE,"%s 4755 %s\n", cmd_chmod, bin);
-+ g_snprintf(tmp,MAXLINE,"%s 4711 %s\n", cmd_chmod, bin);
- strcat(ret,tmp);
-
-
diff --git a/app-cdr/xcdroast/metadata.xml b/app-cdr/xcdroast/metadata.xml
deleted file mode 100644
index d282c2e1..00000000
--- a/app-cdr/xcdroast/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>martin@mvath.de</email>
- <name>Martin Väth</name>
- </maintainer>
- <upstream>
- <remote-id type="sourceforge">xcdroast</remote-id>
- </upstream>
- <longdescription>Menu based front-end to mkisofs and cdrecord</longdescription>
-</pkgmetadata>
diff --git a/app-cdr/xcdroast/xcdroast-0.98_alpha16-r2.ebuild b/app-cdr/xcdroast/xcdroast-0.98_alpha16-r2.ebuild
deleted file mode 100644
index f7bab07d..00000000
--- a/app-cdr/xcdroast/xcdroast-0.98_alpha16-r2.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-inherit gnome2-utils
-
-DESCRIPTION="Lightweight cdrtools front-end for CD and DVD writing"
-HOMEPAGE="http://www.xcdroast.org/"
-SRC_URI="mirror://sourceforge/xcdroast/${P/_/}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="nls suid"
-
-RDEPEND=">=x11-libs/gtk+-2:2
- app-cdr/cdrtools"
-DEPEND="${RDEPEND}
- sys-devel/gettext
- virtual/pkgconfig"
-
-S=${WORKDIR}/${P/_/}
-
-PATCHES=(
- "${FILESDIR}"/cdda2wav_version.patch
- "${FILESDIR}"/fix_cddb_hidden_tracks.patch
- "${FILESDIR}"/io_compile.patch
- "${FILESDIR}"/io_progressbar_fix.patch
- "${FILESDIR}"/suid-perms.patch
-)
-
-src_prepare() {
- # fix Norwegian locales
- mv po/{no,nb}.po || die
- mv po/{no,nb}.gmo || die
- sed -i -e 's/no/nb/' po/LINGUAS || die
- # eapply_user should be _after_ the above...
- default
-}
-
-src_configure() {
- econf \
- $(use_enable nls) \
- $(use_enable suid nonrootmode) \
- --enable-gtk2 \
- --disable-dependency-tracking \
- --mandir=/usr/share/man \
- --sysconfdir=/etc
-}
-
-src_compile() {
- emake PREFIX="${EPREFIX}"/usr
-}
-
-src_install() {
- emake PREFIX="${EPREFIX}"/usr DESTDIR="${ED}" install
-
- dodoc -r AUTHORS ChangeLog README doc/*
-
- insinto /usr/share/icons/hicolor/48x48/apps
- newins xpms/xcdricon.xpm xcdroast.xpm
-
- make_desktop_entry xcdroast "X-CD-Roast" xcdroast "AudioVideo;DiscBurning"
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}