summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-shells/zsh/ChangeLog5
-rw-r--r--app-shells/zsh/files/zsh-5.0.7-pid-ns.patch39
-rw-r--r--app-shells/zsh/zsh-5.0.7-r2.ebuild (renamed from app-shells/zsh/zsh-5.0.7-r1.ebuild)8
-rw-r--r--app-shells/zsh/zsh-99999999.ebuild4
-rw-r--r--games-rpg/m5figur-mv/ChangeLog9
-rw-r--r--games-rpg/m5figur-mv/Manifest2
-rw-r--r--games-rpg/m5figur-mv/m5figur-mv-2.1.ebuild (renamed from games-rpg/m5figur-mv/m5figur-mv-2.0.ebuild)0
-rw-r--r--games-rpg/magus/ChangeLog3
-rw-r--r--games-rpg/magus/magus-99999999.ebuild2
-rw-r--r--www-plugins/classic-theme-restorer/Manifest2
-rw-r--r--www-plugins/classic-theme-restorer/classic-theme-restorer-1.2.8.2.ebuild (renamed from www-plugins/classic-theme-restorer/classic-theme-restorer-1.2.6.1.ebuild)0
11 files changed, 64 insertions, 10 deletions
diff --git a/app-shells/zsh/ChangeLog b/app-shells/zsh/ChangeLog
index 81093b2d..53ede34c 100644
--- a/app-shells/zsh/ChangeLog
+++ b/app-shells/zsh/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*zsh-5.0.7-r2 (02 Jan 2015)
+
+ 02 Jan 2015; Martin Väth <martin@mvath.de>:
+ Add zsh-5.0.7-pid-ns.patch from gentoo main tree
+
*zsh-5.0.7-r1 (09 Oct 2014)
09 Oct 2014; Martin Väth <martin@mvath.de>:
diff --git a/app-shells/zsh/files/zsh-5.0.7-pid-ns.patch b/app-shells/zsh/files/zsh-5.0.7-pid-ns.patch
new file mode 100644
index 00000000..928ce48b
--- /dev/null
+++ b/app-shells/zsh/files/zsh-5.0.7-pid-ns.patch
@@ -0,0 +1,39 @@
+zsh and pid namespaces don't play very well together. Specifically, when zsh is
+launched inside a new pid namespace, it doesn't take ownership of the process
+group, causing things like SIGINT to be sent to the parent process. Upstream
+bug report here: http://www.zsh.org/mla/workers/2014/msg01769.html.
+
+The first chunk of this diff fixes this problem and has already been applied
+upstream:
+http://sourceforge.net/p/zsh/code/ci/0c4cb0cc1b527f4341f1a39a10f4120aa7c7d594/.
+
+The second chunk is a suggested fix for the warning that zsh prints when
+exiting: http://www.zsh.org/mla/workers/2014/msg01779.html.
+
+diff --git a/Src/jobs.c b/Src/jobs.c
+index a668b07..c6e1bce 100644
+--- a/Src/jobs.c
++++ b/Src/jobs.c
+@@ -2734,7 +2734,7 @@ acquire_pgrp(void)
+ long ttpgrp;
+ sigset_t blockset, oldset;
+
+- if ((mypgrp = GETPGRP()) > 0) {
++ if ((mypgrp = GETPGRP()) >= 0) {
+ long lastpgrp = mypgrp;
+ sigemptyset(&blockset);
+ sigaddset(&blockset, SIGTTIN);
+@@ -2779,8 +2779,11 @@ void
+ release_pgrp(void)
+ {
+ if (origpgrp != mypgrp) {
+- attachtty(origpgrp);
+- setpgrp(0, origpgrp);
++ /* in linux pid namespaces, origpgrp may never have been set */
++ if (origpgrp) {
++ attachtty(origpgrp);
++ setpgrp(0, origpgrp);
++ }
+ mypgrp = origpgrp;
+ }
+ }
diff --git a/app-shells/zsh/zsh-5.0.7-r1.ebuild b/app-shells/zsh/zsh-5.0.7-r2.ebuild
index 45524b6a..d1f584e8 100644
--- a/app-shells/zsh/zsh-5.0.7-r1.ebuild
+++ b/app-shells/zsh/zsh-5.0.7-r2.ebuild
@@ -54,8 +54,8 @@ case ${PV} in
*)
SRC_URI="${ZSH_URI}
doc? ( ${ZSH_DOC_URI} )"
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
- #KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ #KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
DEPEND=""
LIVE=false;;
esac
@@ -125,6 +125,7 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-init.d-gentoo-r1.diff
epatch "${FILESDIR}"/${P}-fix-cvs-completion.patch
+ epatch "${FILESDIR}"/${P}-pid-ns.patch
cp "${FILESDIR}"/zprofile-1 "${T}"/zprofile || die
eprefixify "${T}"/zprofile || die
@@ -277,7 +278,8 @@ src_install() {
if use doc ; then
pushd "${WORKDIR}/${PN}-${PV%_*}" >/dev/null
dohtml -r Doc/*
- dodoc Doc/zsh.{dvi,pdf}
+ insinto /usr/share/doc/${PF}
+ doins Doc/zsh.{dvi,pdf}
popd >/dev/null
fi
diff --git a/app-shells/zsh/zsh-99999999.ebuild b/app-shells/zsh/zsh-99999999.ebuild
index c91279f7..9753ffb5 100644
--- a/app-shells/zsh/zsh-99999999.ebuild
+++ b/app-shells/zsh/zsh-99999999.ebuild
@@ -54,8 +54,8 @@ case ${PV} in
*)
SRC_URI="${ZSH_URI}
doc? ( ${ZSH_DOC_URI} )"
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
- #KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ #KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
DEPEND=""
LIVE=false;;
esac
diff --git a/games-rpg/m5figur-mv/ChangeLog b/games-rpg/m5figur-mv/ChangeLog
index 9d7288e5..7b9e05e6 100644
--- a/games-rpg/m5figur-mv/ChangeLog
+++ b/games-rpg/m5figur-mv/ChangeLog
@@ -2,9 +2,14 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
-*m5figur-mv-2.0 (01 Dec 2015)
+*m5figur-mv-2.0 (02 Jan 2015)
- 31 Dec 2014; Martin Väth <martin@mvath.de>:
+ 02 Jan 2014; Martin Väth <martin@mvath.de>:
+ Version bump, remove old ebuild
+
+*m5figur-mv-2.0 (01 Jan 2015)
+
+ 01 Jan 2014; Martin Väth <martin@mvath.de>:
Version bump, remove old ebuild
*m5figur-mv-1.3 (31 Dec 2014)
diff --git a/games-rpg/m5figur-mv/Manifest b/games-rpg/m5figur-mv/Manifest
index 835ee4f5..f96d28d2 100644
--- a/games-rpg/m5figur-mv/Manifest
+++ b/games-rpg/m5figur-mv/Manifest
@@ -1 +1 @@
-DIST m5figur-mv-2.0.tar.gz 17718 SHA256 7bc1123e1ed04c2c2227190eaeaa2e27d15a9b464a4bb74ce979357eeb6468f2 SHA512 2a06aebbddd20eaf5d65accf5808aff22bd704e74bd3358871496fc6d8930ec5a5b0df394323057582db2dd48081aa63e93512ecfe0392321d4490e07caa1390 WHIRLPOOL fd9b54d1d2dbbb0bb79d57f2a0a5107df4edfe82b998ea7af2102c438bdad69d16006fd33582401885a464c7052fdbd952973d95a598d4857a92f123e3993f4e
+DIST m5figur-mv-2.1.tar.gz 17958 SHA256 29896acd839c54d22111726b2c198901bd2b4c2bd516d749bec37c0b27f07542 SHA512 c264a4df7aa9cf607247449c7fb33a998609780c469d67e2b6f879914c72314daa98c42f64d9ecf76dafc5a1a038a5db102e353d3d8ff7f40b4a7449720dffb1 WHIRLPOOL c357721303ab7465232fce90886df53905ca8a8d0fdb865b3cc5b9c41f78e4421ee954d8a2f4ca65f73882948400ef7f393e06823ec87dad4ffb2797e594e470
diff --git a/games-rpg/m5figur-mv/m5figur-mv-2.0.ebuild b/games-rpg/m5figur-mv/m5figur-mv-2.1.ebuild
index 5b77ce32..5b77ce32 100644
--- a/games-rpg/m5figur-mv/m5figur-mv-2.0.ebuild
+++ b/games-rpg/m5figur-mv/m5figur-mv-2.1.ebuild
diff --git a/games-rpg/magus/ChangeLog b/games-rpg/magus/ChangeLog
index b68bbfaa..ed83e83b 100644
--- a/games-rpg/magus/ChangeLog
+++ b/games-rpg/magus/ChangeLog
@@ -4,6 +4,9 @@
*magus-1.3.1 (28 Dec 2014)
+ 02 Jan 2015; Martin Väth <martin@mvath.de>:
+ Update postgresql dependency
+
28 Dec 2014; Martin Väth <martin@mvath.de>:
Downgrade to now only public version from sourceforge.
Rename configure.in -> configure.ac for compatibility with current automake.
diff --git a/games-rpg/magus/magus-99999999.ebuild b/games-rpg/magus/magus-99999999.ebuild
index 7bccc19c..f9d48240 100644
--- a/games-rpg/magus/magus-99999999.ebuild
+++ b/games-rpg/magus/magus-99999999.ebuild
@@ -40,7 +40,7 @@ IUSE="+acroread imagemagick konqueror postgres pngcrush seamonkey"
DEPENDCOMMON="dev-libs/libsigc++:2
dev-cpp/gtkmm:2.4
virtual/latex-base
- postgres? ( dev-db/postgresql-server )
+ postgres? ( dev-db/postgresql )
!postgres? ( dev-db/sqlite:3 )
|| ( media-libs/netpbm media-gfx/graphicsmagick media-gfx/imagemagick )"
diff --git a/www-plugins/classic-theme-restorer/Manifest b/www-plugins/classic-theme-restorer/Manifest
index 9c727df2..8fece205 100644
--- a/www-plugins/classic-theme-restorer/Manifest
+++ b/www-plugins/classic-theme-restorer/Manifest
@@ -1 +1 @@
-DIST classic_theme_restorer_customize_ui-1.2.6.1-fx.xpi 407630 SHA256 7975acc569644b904103046f032a8b2863be2ffe21afff4d276ae24764d6876e SHA512 8f7984201418c0708221dcb1da5bf640465e5ce694b6899868d378daf6304f2b26f5e1133e0122609b37886d8dba5fd6087e331279eeaf92d436bc40631a1bc9 WHIRLPOOL d8c073d0f041249976421e53e5b6f17411a8e1a7f79fe73c59ff59942c3d5ffc4a22c483b80396779458012b62656c5363bf09a193b6f64ab1a6aec0a810e8b9
+DIST classic_theme_restorer_customize_ui-1.2.8.2-fx.xpi 433727 SHA256 b0f2f78279c243df9446a505ecd14be66add58eb161168d9567c788b37a5894e SHA512 39dd51b56942693dadbd79ba821a761948ea01a31f4ad2f84d6b4c94eeabb4e8a0c3a60c960466329681f2eb4e9dbf7fb4344f34613744f19a2b115244aa10e3 WHIRLPOOL 7003220a7afa9be1f8ee3726c57e6a21154f60f2d48e98a1fb241ef61cd2c49da053da760ca645a9cca7e11f9aaf4a60e2a45435c3fe1d129071819444fcb43e
diff --git a/www-plugins/classic-theme-restorer/classic-theme-restorer-1.2.6.1.ebuild b/www-plugins/classic-theme-restorer/classic-theme-restorer-1.2.8.2.ebuild
index 6bb4d8de..6bb4d8de 100644
--- a/www-plugins/classic-theme-restorer/classic-theme-restorer-1.2.6.1.ebuild
+++ b/www-plugins/classic-theme-restorer/classic-theme-restorer-1.2.8.2.ebuild