summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--eclass/mv_mozextension.eclass152
-rw-r--r--www-plugins/better-privacy/ChangeLog9
-rw-r--r--www-plugins/better-privacy/Manifest6
-rw-r--r--www-plugins/better-privacy/better-privacy-1.48.3.ebuild (renamed from www-plugins/better-privacy/better-privacy-1.47.4-r1.ebuild)0
-rw-r--r--www-plugins/fillform/ChangeLog3
-rw-r--r--www-plugins/fillform/Manifest4
-rw-r--r--www-plugins/fillform/fillform-1.1.8-r1.ebuild (renamed from www-plugins/fillform/fillform-1.1.8.ebuild)4
-rw-r--r--www-plugins/flashgot/ChangeLog3
-rw-r--r--www-plugins/flashgot/Manifest4
-rw-r--r--www-plugins/flashgot/flashgot-1.2.1.28-r1.ebuild (renamed from www-plugins/flashgot/flashgot-1.2.1.28.ebuild)0
-rw-r--r--www-plugins/form-history-control/ChangeLog3
-rw-r--r--www-plugins/form-history-control/Manifest4
-rw-r--r--www-plugins/form-history-control/form-history-control-1.2.6-r1.ebuild (renamed from www-plugins/form-history-control/form-history-control-1.2.6.ebuild)0
-rw-r--r--www-plugins/noscript/ChangeLog5
-rw-r--r--www-plugins/noscript/Manifest6
-rw-r--r--www-plugins/noscript/noscript-2.0.ebuild (renamed from www-plugins/noscript/noscript-1.10.ebuild)0
-rw-r--r--www-plugins/stylish/ChangeLog8
-rw-r--r--www-plugins/stylish/Manifest4
-rw-r--r--www-plugins/stylish/stylish-1.0.9-r1.ebuild (renamed from www-plugins/stylish/stylish-1.0.9.ebuild)0
-rw-r--r--www-plugins/video-downloadhelper/ChangeLog5
-rw-r--r--www-plugins/video-downloadhelper/Manifest6
-rw-r--r--www-plugins/video-downloadhelper/video-downloadhelper-4.8.ebuild (renamed from www-plugins/video-downloadhelper/video-downloadhelper-4.7.4.ebuild)0
-rw-r--r--www-plugins/xclear/ChangeLog3
-rw-r--r--www-plugins/xclear/Manifest4
-rw-r--r--www-plugins/xclear/xclear-1.3-r1.ebuild (renamed from www-plugins/xclear/xclear-1.3.ebuild)0
25 files changed, 145 insertions, 88 deletions
diff --git a/eclass/mv_mozextension.eclass b/eclass/mv_mozextension.eclass
index 59990626..edf4d912 100644
--- a/eclass/mv_mozextension.eclass
+++ b/eclass/mv_mozextension.eclass
@@ -1,24 +1,41 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header $
-#
-# mv_mozextention.eclass: installing firefox extensions and language packs
-#
-# This is mozextension.eclass from the portage tree with the following changes:
-#
-# 1. Some compatibility fixes in xpi_install/xpi_unpack.
+
+# @ECLASS: mv_mozextension.eclass
+# @MAINTAINER:
+# Martin Väth <martin@mvath.de>
+# @BLURB: This eclass provides functions to install mozilla extensions
+# @DESCRIPTION:
+# The eclass is based on mozextension.eclass with many extensions.
+# 1. It has some compatibility fixes in xpi_install/xpi_unpack.
# 2. A default src_unpack function is defined; set FILENAME to the archive name.
# If FILENAME is unset or empty, the last part of the last SRC_URI is used.
-# 3. Default functions for installation for all browsers.
-# If you want only installation for some browser, define
-# MOZILLAS="firefox seamonkey icecat" (or to a subset thereof)
-# before inheriting the eclass.
-# If you define MOZILLA="" before inheriting the eclass,
-# no default functions get defined.
-
-: ${MOZILLAS="firefox seamonkey icecat"}
-
-[ -n "${MOZILLAS}" ] && inherit multilib
+# 3. Default functions for installation for all mozilla type browsers.
+
+# @ECLASS-VARIABLE: MOZILLAS
+# @DESCRIPTION:
+# If this variables is set to the empty value, no default install functions
+# are defined. Otherwise, the value of this variable should be
+# "firefox icecat seamonkey" (default)
+# or a subset of these.
+# The eclass will then install the extension for all these mozillas,
+# set corresponding dependencies and print corresponding messages.
+: ${MOZILLAS="firefox icecat seamonkey"}
+
+# @ECLASS-VARIABLE: MOZILLA_COMMON_EXTENSIONS
+# @DESCRIPTION:
+# If this variable has the special value "*", the extension is copied directly
+# into the extension directory of the installed MOZILLA's.
+# Otherwise, only symlinks are made in that directory, and the extension is
+# installed only once into MOZILLA_COMMON_EXTENSIONS (a default directory is
+# chosen if MOZILLA_COMMON_EXTENSIONS is empty).
+# If this variable has the special value "?" (default), it acts like "*" or
+# "" depending on whether MOZILLAS applies to more than 1 installed mozilla
+# or not.
+: ${MOZILLA_COMMON_EXTENSIONS="?"}
+
+inherit multilib
case "${MOZILLAS}" in
''|icecat)
@@ -64,52 +81,65 @@ mv_mozextension_src_unpack () {
EXPORT_FUNCTIONS src_unpack
-if [ -n "${MOZILLAS}" ]
-then
+declare -a INST_EXTENSIONS INST_MOZILLAS LINK_MOZILLAS
-mv_mozextension_src_install () {
- local MOZILLA_FIVE_HOME
- INST_MOZILLAS=""
+mv_mozextension_install () {
+ local MOZILLA_EXTENSIONS_DIRECTORY
+ MOZILLA_EXTENSIONS_DIRECTORY="${1}"
+ INST_EXTENSIONS=()
+ xpi_install_dirs
+}
+
+mv_mozextension_calc () {
+ local i
case "${MOZILLAS}" in
- *fire*)
- if has_version '>=www-client/firefox-3.6'
- then MOZILLA_FIVE_HOME="/usr/$(get_libdir)/mozilla-firefox"
- xpi_install_dirs
- INST_MOZILLAS="${INST_MOZILLAS} $(best_version www-client/firefox)"
+ ${1}) false;;
+ esac && return
+ i="$(best_version "${2}")" && [ -n "${i}" ] || return
+ INST_MOZILLAS+=("${i}")
+ LINK_MOZILLAS+=("${3}")
+}
+
+mv_mozextension_src_install () {
+ local MOZILLA_FIVE_HOME b d i j
+ INST_MOZILLAS=()
+ LINK_MOZILLAS=()
+ b="/usr/$(get_libdir)/"
+ mv_mozextension_calc "*fire*" "www-client/firefox" "${b}mozilla-firefox"
+ mv_mozextension_calc "*fire*" "www-client/firefox-bin" "/opt/firefox"
+ mv_mozextension_calc "*ice*" "www-client/icecat" "${b}icecat"
+ mv_mozextension_calc "*sea*" "www-client/seamonkey" "${b}seamonkey"
+ mv_mozextension_calc "*sea*" "www-client/seamonkey-bin" "/opt/seamonkey"
+ [ ${#LINK_MOZILLAS[@]} -ne 0 ] || die "no supported mozilla is installed"
+ d="${MOZILLA_COMMON_EXTENSIONS}"
+ if [ "${d}" = "?" ]
+ then if [ ${#INST_MOZILLAS[@]} -gt 1 ]
+ then d=""
+ else d="*"
fi
- if has_version '>=www-client/firefox-bin-3.6'
- then MOZILLA_FIVE_HOME="/opt/firefox"
- xpi_install_dirs
- INST_MOZILLAS="${INST_MOZILLAS} $(best_version www-client/firefox-bin)"
- fi;;
- esac
- case "${MOZILLAS}" in
- *sea*)
- if has_version '>=www-client/seamonkey-2'
- then MOZILLA_FIVE_HOME="/usr/$(get_libdir)/seamonkey"
- xpi_install_dirs
- INST_MOZILLAS="${INST_MOZILLAS} $(best_version www-client/seamonkey)"
+ fi
+ if [ "${d}" != "*" ]
+ then if [ -n "${d}" ]
+ then mv_mozextension_install "${d}"
+ else mv_mozextension_install "${b}mozilla/extensions"
fi
- if has_version '>=www-client/seamonkey-bin-2'
- then MOZILLA_FIVE_HOME="/opt/seamonkey"
- xpi_install_dirs
- INST_MOZILLAS="${INST_MOZILLAS} $(best_version www-client/seamonkey-bin)"
- fi;;
- esac
- case "${MOZILLAS}" in
- *ice*)
- if has_version '>=www-client/icecat-3.6'
- then MOZILLA_FIVE_HOME="/usr/$(get_libdir)/icecat"
+ for i in "${LINK_MOZILLAS[@]}"
+ do for j in "${INST_EXTENSIONS[@]}"
+ do dosym "${EROOT%/}${j}" "${i}/extensions/${j##*/}"
+ done
+ done
+ else for i in "${LINK_MOZILLAS[@]}"
+ do MOZILLA_FIVE_HOME="${i}"
xpi_install_dirs
- INST_MOZILLAS="${INST_MOZILLAS} $(best_version www-client/icecat)"
- fi;;
- esac
+ done
+ fi
}
mv_mozextension_pkg_postinst () {
local i
+ [ "${#INST_MOZILLAS[@]}" -ge 1 ] || die "no supported mozilla is installed"
elog "${CATEGORY}/${PN} has been installed for the following packages:"
- for i in ${INST_MOZILLAS}
+ for i in ${INST_MOZILLAS[@]}
do elog " ${i}"
done
elog
@@ -117,8 +147,8 @@ mv_mozextension_pkg_postinst () {
elog "you might need to reemerge ${CATEGORY}/${PN}"
}
-EXPORT_FUNCTIONS src_install pkg_postinst
-
+if [ -n "${MOZILLAS}" ]
+then EXPORT_FUNCTIONS src_install pkg_postinst
fi
xpi_unpack () {
@@ -160,17 +190,21 @@ xpi_unpack () {
}
xpi_install () {
- local emid x
+ local d x
# You must tell xpi_install which dir to use
[ ${#} -ne 1 ] && die "${FUNCNAME} takes exactly one argument. Please specify the directory"
x="${1}"
- cd -- "${x}"
# determine id for extension
- emid="$(sed -n -e '/install-manifest/,$ { /em:id/!d; s/.*[\">]\([^\"<>]*\)[\"<].*/\1/; p; q }' "${x}"/install.rdf)" \
- && [ -n "${emid}" ] || die "failed to determine extension id"
- insinto "${MOZILLA_FIVE_HOME}/extensions/${emid}"
+ d="$(sed -n -e '/install-manifest/,$ { /em:id/!d; s/.*[\">]\([^\"<>]*\)[\"<].*/\1/; p; q }' "${x}"/install.rdf)" \
+ && [ -n "${d}" ] || die "failed to determine extension id"
+ if [ -n "${MOZILLA_EXTENSIONS_DIRECTORY}" ]
+ then d="${MOZILLA_EXTENSIONS_DIRECTORY}/${d}"
+ INST_EXTENSIONS+=("${d}")
+ else d="${MOZILLA_FIVE_HOME}/extensions/${d}"
+ fi
+ insinto "${d}"
doins -r "${x}"/* || die "failed to copy extension"
}
diff --git a/www-plugins/better-privacy/ChangeLog b/www-plugins/better-privacy/ChangeLog
index 6945ee73..40c6a38d 100644
--- a/www-plugins/better-privacy/ChangeLog
+++ b/www-plugins/better-privacy/ChangeLog
@@ -2,25 +2,26 @@
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
# $Header $
+*better-privacy-1.48.3 (31 Jul 2010)
+
+ 31 Jul 2010; Martin Väth <martin@mvath.de>
+ Version bump, remove old ebuild.
+
06 Jun 2010; Martin Väth <martin@mvath.de>
- +better-privacy-1.47.4-r1.ebuild -better-privacy-1.47.4.ebuild:
Switch to new mv_mozextension.eclass:
Installs also for other mozilla variants like seamonkey.
*better-privacy-1.47.4 (22 Apr 2010)
22 Apr 2010; Martin Väth <martin@mvath.de>
- +better-privacy-1.47.4.ebuild -better-privacy-1.47.ebuild:
Version bump, remove old ebuild.
*better-privacy-1.47 (02 Apr 2010)
02 Apr 2010; Martin Väth <martin@mvath.de>
- +better-privacy-1.47.ebuild -better-privacy-1.45.ebuild:
Version bump, remove old ebuild.
*better-privacy-1.45 (28 Mar 2010)
28 Mar 2010; Martin Väth <martin@mvath.de>
- better-privacy-1.45.ebuild:
import with minor changes from a personal overlay.
diff --git a/www-plugins/better-privacy/Manifest b/www-plugins/better-privacy/Manifest
index ead4f645..6167194a 100644
--- a/www-plugins/better-privacy/Manifest
+++ b/www-plugins/better-privacy/Manifest
@@ -1,4 +1,4 @@
-DIST betterprivacy-1.47.4-sm+fx.xpi 110021 RMD160 8bae58a544312460d416c759f425780d92191bac SHA1 dae915b9337880aefc335947d5a37a3d0750a1e1 SHA256 e1f1e83ac608f0fdc33f66f60db4f47863e605eb8d8b52b1b99ca0b62ede1ba1
-EBUILD better-privacy-1.47.4-r1.ebuild 817 RMD160 31ee154943535ec9e903ce32f1623370b95b48b0 SHA1 35f1bbced1952fd9a095a4187ab1cac8afc10a91 SHA256 cc7dcf1f0961c8838732606c3b72b972793d36583d4b81be6fb70ce0a353014f
-MISC ChangeLog 933 RMD160 3d5b2fd7b551ff570749f45fcc778810bd3fc854 SHA1 eec55368896c4035747119ad14aa9881339a4a3e SHA256 9f23bfb6af3504ccd07624b240d782f9ee3574e4a0353eb8589d5ceca06c0289
+DIST betterprivacy-1.48.3-sm+fx.xpi 114408 RMD160 c9f9dad1a3f64d26410eab74f5688dea1280f3ec SHA1 92019966f4e0d36fff5ada6e6ea369e561c93793 SHA256 16ebb58e2b8442233491a6a42e1d7280a44a5daf77250bfcd49de36df4525d46
+EBUILD better-privacy-1.48.3.ebuild 817 RMD160 31ee154943535ec9e903ce32f1623370b95b48b0 SHA1 35f1bbced1952fd9a095a4187ab1cac8afc10a91 SHA256 cc7dcf1f0961c8838732606c3b72b972793d36583d4b81be6fb70ce0a353014f
+MISC ChangeLog 855 RMD160 e9f281ab0bc2110deaddb2d244dc115edd94a606 SHA1 62b37d46f10df1a4dac1f4432e308b58161485cb SHA256 b968637d52dfa73da89ed382acb80c38af97a7b9cf8875f70d633b3d1cb946bb
MISC metadata.xml 264 RMD160 4c10b5dfc6857fcb2e9cdc91ff64bb5d4a5c2204 SHA1 69886f7e401bdf99a78d428ff4361991607e86c6 SHA256 dd28333300fc1ec2dbd96450bddbdd9e1061c1eff809e687442c53c91c05d86d
diff --git a/www-plugins/better-privacy/better-privacy-1.47.4-r1.ebuild b/www-plugins/better-privacy/better-privacy-1.48.3.ebuild
index 7b8bbcda..7b8bbcda 100644
--- a/www-plugins/better-privacy/better-privacy-1.47.4-r1.ebuild
+++ b/www-plugins/better-privacy/better-privacy-1.48.3.ebuild
diff --git a/www-plugins/fillform/ChangeLog b/www-plugins/fillform/ChangeLog
index 5c359359..ad7bb6c9 100644
--- a/www-plugins/fillform/ChangeLog
+++ b/www-plugins/fillform/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
# $Header $
+ 31 Jul 2010; Martin Väth <martin@mvath.de>
+ Fix homepage. Bump revision to force eclass upgrade.
+
*fillform-1.1.8 (16 Jul 2010)
16 Jun 2010; Martin Väth <martin@mvath.de>
diff --git a/www-plugins/fillform/Manifest b/www-plugins/fillform/Manifest
index 697737fe..41fc48ec 100644
--- a/www-plugins/fillform/Manifest
+++ b/www-plugins/fillform/Manifest
@@ -1,4 +1,4 @@
DIST fillform-1.1.8-fx.xpi 22722 RMD160 b8d8d837425ca700f25d4a7e24f653a5912be742 SHA1 115c2a98bb7f33640005e6ed280cf0c66f893683 SHA256 45b64a1db48fa2e67f73d6f11bd8531f1bff0ce106b932cc0443067e1449295f
-EBUILD fillform-1.1.8.ebuild 456 RMD160 be1965384b9046a5bba1a1f40ae39d4c4ac75fde SHA1 3eda2c241f0d7ee8b6da83f30ddfec641a371c7c SHA256 8e4a985353f450b22a02e489b5193d70f8e65997d37bd92d270505d5ae4bd03a
-MISC ChangeLog 461 RMD160 52d990dee0f28789bcaa0e9237e2566a384d90ef SHA1 e6c07aa8bf2e118b7d9c6489049662f854bc4ac4 SHA256 e3e7d3d6889ddded05627698a3b673f4d0e9ef3cb741902f87a1133b04c91c2a
+EBUILD fillform-1.1.8-r1.ebuild 487 RMD160 70cee589bf3a426fc1f4a7ac8280acfbc279c819 SHA1 294eddc1890af019f100cdb670275cddd9399eaf SHA256 964a8e8e0a115151f2091cdeef5c5dea24c54ec7821ce474e7b0089b4b3b8846
+MISC ChangeLog 581 RMD160 e0ed9700f6e4056715aad144dac5df25e584a3db SHA1 74e58abefb16f55caaa3ca8036a23838c436c6f4 SHA256 8ee8ea0e07d92873662a6e4fe01915c0d220f7ff47227a0b593b1b95ba047705
MISC metadata.xml 264 RMD160 4c10b5dfc6857fcb2e9cdc91ff64bb5d4a5c2204 SHA1 69886f7e401bdf99a78d428ff4361991607e86c6 SHA256 dd28333300fc1ec2dbd96450bddbdd9e1061c1eff809e687442c53c91c05d86d
diff --git a/www-plugins/fillform/fillform-1.1.8.ebuild b/www-plugins/fillform/fillform-1.1.8-r1.ebuild
index 48f35f03..61f3f685 100644
--- a/www-plugins/fillform/fillform-1.1.8.ebuild
+++ b/www-plugins/fillform/fillform-1.1.8-r1.ebuild
@@ -7,8 +7,8 @@ MOZILLAS="firefox icecat"
inherit mv_mozextension
RESTRICT="mirror"
-DESCRIPTION="Save/restore forms in firefox with Alt-Q/Alt-W"
-HOMEPAGE="https://addons.mozilla.org/firefox/addon/160849/"
+DESCRIPTION="Save/restore forms in firefox with Alt-W/Alt-Q"
+HOMEPAGE="http://linux.softpedia.com/get/Internet/Firefox-Extensions/FillForm-57638.shtml"
SRC_URI="http://releases.mozilla.org/pub/mozilla.org/addons/160849/${P}-fx.xpi"
LICENSE="GPL-2"
diff --git a/www-plugins/flashgot/ChangeLog b/www-plugins/flashgot/ChangeLog
index 9f15e955..f1c5cdb8 100644
--- a/www-plugins/flashgot/ChangeLog
+++ b/www-plugins/flashgot/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
# $Header $
+ 31 Jul 2010; Martin Väth <martin@mvath.de>
+ Bump revision to force eclass upgrade.
+
*flashgot-1.2.1.28 (25 Jul 2010)
06 Jun 2010; Martin Väth <martin@mvath.de>
diff --git a/www-plugins/flashgot/Manifest b/www-plugins/flashgot/Manifest
index 617d116a..187adb70 100644
--- a/www-plugins/flashgot/Manifest
+++ b/www-plugins/flashgot/Manifest
@@ -1,4 +1,4 @@
DIST flashgot-1.2.1.28.xpi 335354 RMD160 fcb107f415cdef14fe98408f07579b1a3ac24969 SHA1 e149b5f32f3e05eb5e322c87a28870abf830b440 SHA256 da11b32d694dcfd26aff8b12281985a3221d1301edae5a4ad925a06a530adc60
-EBUILD flashgot-1.2.1.28.ebuild 394 RMD160 45ed08a08bee26e6f0132e98d8db39ec327f4516 SHA1 809c7cd563ed96037be3a2e8c22a5e504a966f9c SHA256 0cb562996c509d1dde7e4ffd48ae9ab558b9ef001351cdfd4a00d7539dd53a3b
-MISC ChangeLog 1037 RMD160 07a644f0b9ff5427d4e19ff6db1b67fd87a315d8 SHA1 6609c7393768a8e128fd769167dcfc1be8bbffa7 SHA256 1a38b1499d546266320c8bd3fcb316cd2200bb755572f91260912d5cc3da1c52
+EBUILD flashgot-1.2.1.28-r1.ebuild 394 RMD160 45ed08a08bee26e6f0132e98d8db39ec327f4516 SHA1 809c7cd563ed96037be3a2e8c22a5e504a966f9c SHA256 0cb562996c509d1dde7e4ffd48ae9ab558b9ef001351cdfd4a00d7539dd53a3b
+MISC ChangeLog 1143 RMD160 a4c7ac85fe22b507fabe4b4561687635d721dc3a SHA1 f3199293612d8cd1bcf8fee0dabccb06acfc807a SHA256 a00ab58592cdeb5a6698e00ca8144314e4ebd2bebb2e67f602b0cabb3c4242e6
MISC metadata.xml 264 RMD160 4c10b5dfc6857fcb2e9cdc91ff64bb5d4a5c2204 SHA1 69886f7e401bdf99a78d428ff4361991607e86c6 SHA256 dd28333300fc1ec2dbd96450bddbdd9e1061c1eff809e687442c53c91c05d86d
diff --git a/www-plugins/flashgot/flashgot-1.2.1.28.ebuild b/www-plugins/flashgot/flashgot-1.2.1.28-r1.ebuild
index 1ba99390..1ba99390 100644
--- a/www-plugins/flashgot/flashgot-1.2.1.28.ebuild
+++ b/www-plugins/flashgot/flashgot-1.2.1.28-r1.ebuild
diff --git a/www-plugins/form-history-control/ChangeLog b/www-plugins/form-history-control/ChangeLog
index 0c07879c..5bd518a1 100644
--- a/www-plugins/form-history-control/ChangeLog
+++ b/www-plugins/form-history-control/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
# $Header $
+ 31 Jul 2010; Martin Väth <martin@mvath.de>
+ Bump revision to force eclass upgrade.
+
*form-history-control-1.2.6 (03 Jul 2010)
03 Jul 2010; Martin Väth <martin@mvath.de>
diff --git a/www-plugins/form-history-control/Manifest b/www-plugins/form-history-control/Manifest
index 93623450..63bd165a 100644
--- a/www-plugins/form-history-control/Manifest
+++ b/www-plugins/form-history-control/Manifest
@@ -1,4 +1,4 @@
DIST form_history_control-1.2.6-fx+sm.xpi 194395 RMD160 861f8757cc06b1ab363fb796a976ef83b2ee4976 SHA1 7e9b5fd6e950d775c06f3de3bc72b6801dad234b SHA256 6b1d7a48ae7fba66de94161cebaa3078d153f2986bfa1e4aa103f4882bbcd8f8
-EBUILD form-history-control-1.2.6.ebuild 454 RMD160 ee50758919f2914b41f41dd558f6db72a0057008 SHA1 f3fb3347047e4a0613c3b4bbf2e4bf71c76b2e1b SHA256 a809469f49e2b2c4e206ecc3d34351c3e1a5793fc5e631d75819d04be594937c
-MISC ChangeLog 396 RMD160 d2ec74ee0b152e4d13387868d2edc5afe7993681 SHA1 a45bf1071b48d56e41d0914e47835fc3c02fd782 SHA256 0a73bdd26172cec9e9f3b71d9fc4c8ca5e3f0bac167b047095f3f1ff1b52095c
+EBUILD form-history-control-1.2.6-r1.ebuild 454 RMD160 ee50758919f2914b41f41dd558f6db72a0057008 SHA1 f3fb3347047e4a0613c3b4bbf2e4bf71c76b2e1b SHA256 a809469f49e2b2c4e206ecc3d34351c3e1a5793fc5e631d75819d04be594937c
+MISC ChangeLog 502 RMD160 eae2316b29dbaa485738fa8ac809ddc05b2e2b79 SHA1 1bfbc584dd5dacd7f66e0f8a2bbb7d8312f81816 SHA256 1cb2449ec8168e93b4f198894f81688fb04e5dcbfe170ebd13d7f33c9ea7cf89
MISC metadata.xml 264 RMD160 4c10b5dfc6857fcb2e9cdc91ff64bb5d4a5c2204 SHA1 69886f7e401bdf99a78d428ff4361991607e86c6 SHA256 dd28333300fc1ec2dbd96450bddbdd9e1061c1eff809e687442c53c91c05d86d
diff --git a/www-plugins/form-history-control/form-history-control-1.2.6.ebuild b/www-plugins/form-history-control/form-history-control-1.2.6-r1.ebuild
index 8763d7bd..8763d7bd 100644
--- a/www-plugins/form-history-control/form-history-control-1.2.6.ebuild
+++ b/www-plugins/form-history-control/form-history-control-1.2.6-r1.ebuild
diff --git a/www-plugins/noscript/ChangeLog b/www-plugins/noscript/ChangeLog
index 60e3830d..659fa61a 100644
--- a/www-plugins/noscript/ChangeLog
+++ b/www-plugins/noscript/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
# $Header $
+*noscript-2.0 (31 Jul 2010)
+
+ 31 Jul 2010; Martin Väth <martin@mvath.de>
+ Version bump, remove old ebuild.
+
*noscript-1.10 (16 Jul 2010)
16 Jul 2010; Martin Väth <martin@mvath.de>
diff --git a/www-plugins/noscript/Manifest b/www-plugins/noscript/Manifest
index 68ce83b2..22c6df91 100644
--- a/www-plugins/noscript/Manifest
+++ b/www-plugins/noscript/Manifest
@@ -1,4 +1,4 @@
-DIST noscript-1.10.xpi 489523 RMD160 7491156ab2329e0f14622896236b334f1d896d84 SHA1 2dc88f39c0b20625cf3ec051c832660aec97ad57 SHA256 c104c2f28bd4036a4fc07a794b685393df85e1d33bd50db382e0e57dbb3ec80b
-EBUILD noscript-1.10.ebuild 495 RMD160 4d989c6a74642d2d964c91b8810d9d3501708e05 SHA1 04acd4e4e7a0625358fbbcf82610fbb04a2a2231 SHA256 a7d4cc1f195484bd328ca572e24695fdc47df107ced37bbe4d6bab68aef3636d
-MISC ChangeLog 1077 RMD160 50376f50fa9ccfbce6f126efdd8468e82adf63b2 SHA1 c120e19d7d4050e4e4d1c8efb4fec61daf064c87 SHA256 eb0b3f7bb15b598f5b078cadcf09448128d4a1a2ea7c37ecd3f2aac4a9ea753d
+DIST noscript-2.0.xpi 492085 RMD160 20e7698e5c444e4bcb94547d45d89864820b58bc SHA1 e7597f4f90b2357c9aaef67082c53c28f850cab1 SHA256 6f153374888e66030fc9b26fa08d579aea6b53b3b95851785f7e03353c49f741
+EBUILD noscript-2.0.ebuild 495 RMD160 4d989c6a74642d2d964c91b8810d9d3501708e05 SHA1 04acd4e4e7a0625358fbbcf82610fbb04a2a2231 SHA256 a7d4cc1f195484bd328ca572e24695fdc47df107ced37bbe4d6bab68aef3636d
+MISC ChangeLog 1206 RMD160 4b7b19e955bef90abe7805d2bef2f10e483ae519 SHA1 5c8ba706009ef20660475bc6550d5eeeb697b087 SHA256 55283185aa7c08159e215a21b9cb85c6e465d4ab1a47a91c42641acb96b4b125
MISC metadata.xml 447 RMD160 4ec5ea6b99ff64f433b133a9347f0a57039b73b7 SHA1 a6af7ca7a606d2ddc4afbb9ba31ac694f22e9abd SHA256 927431d432628bf04ca3f6e6cd0fc9b5e40ac0f2d2ea70e4a795e0df527cba67
diff --git a/www-plugins/noscript/noscript-1.10.ebuild b/www-plugins/noscript/noscript-2.0.ebuild
index 1ee6d1e6..1ee6d1e6 100644
--- a/www-plugins/noscript/noscript-1.10.ebuild
+++ b/www-plugins/noscript/noscript-2.0.ebuild
diff --git a/www-plugins/stylish/ChangeLog b/www-plugins/stylish/ChangeLog
index 2cdb26cc..0dfe032a 100644
--- a/www-plugins/stylish/ChangeLog
+++ b/www-plugins/stylish/ChangeLog
@@ -2,21 +2,21 @@
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
# $Header $
-*stylish-1.0.9 (06 Jun 2010)
+ 31 Jul 2010; Martin Väth <martin@mvath.de>
+ Bump revision to force eclass upgrade.
+
+*stylish-1.0.9 (31 Jul 2010)
06 Jun 2010; Martin Väth <martin@mvath.de>
- +stylish-1.0.9.ebuild -stylish-1.0.8.ebuild:
Version bump, remove old ebuild. Switch to new mv_mozextension.eclass:
Installs also for other mozilla variants like seamonkey.
*stylish-1.0.8 (02 Apr 2010)
02 Apr 2010; Martin Väth <martin@mvath.de>
- +stylish-1.0.8.ebuild -stylish-1.0.7.ebuild:
Version bump, remove old ebuild.
*stylish-1.0.7 (28 Mar 2010)
28 Mar 2010; Martin Väth <martin@mvath.de>
- stylish-1.0.7.ebuild:
import with minor changes from a personal overlay.
diff --git a/www-plugins/stylish/Manifest b/www-plugins/stylish/Manifest
index 76e12ca0..d3f5ebab 100644
--- a/www-plugins/stylish/Manifest
+++ b/www-plugins/stylish/Manifest
@@ -1,4 +1,4 @@
DIST stylish-1.0.9-fx+tb+sm.xpi 172082 RMD160 6588c38c2cebcaea9514c05e1e0c1bbe12c9dd6c SHA1 e74ad59f2866d8002ce7efc27969344d60a247d6 SHA256 85c231b6a0f64fdad9bdd9d3d8d80005f8a1fe77c0e19e480c30a8827c88a128
-EBUILD stylish-1.0.9.ebuild 877 RMD160 08c6321aa488fe189080c3d7a175f3508f8fce4c SHA1 4e0a6fa877771a1c88dbfd810154c08efc893449 SHA256 587f907edb4c3e6bcc9b6555478bc3e4f94a606b7c5cc9ec6a2675f45c7293fb
-MISC ChangeLog 741 RMD160 c3a1bc566b5b460d18ef9bbb8d886633dd22804d SHA1 b6e28686e3c91377283abf079392de79dc090af7 SHA256 c01fc4f5ff9a82dc70cb8060cf09b04108ac7f12633b3e86ebfdccaec68b3d3f
+EBUILD stylish-1.0.9-r1.ebuild 877 RMD160 08c6321aa488fe189080c3d7a175f3508f8fce4c SHA1 4e0a6fa877771a1c88dbfd810154c08efc893449 SHA256 587f907edb4c3e6bcc9b6555478bc3e4f94a606b7c5cc9ec6a2675f45c7293fb
+MISC ChangeLog 729 RMD160 6f9056bcab7f3fbee2a9f8b14a0ecf25140572e9 SHA1 b38c60f224e8737531e53899391d2e3bc6158fdf SHA256 b65537d1f352736a62882c6f2932ae4116ca0e9e5412dc67e2c244f8a987a137
MISC metadata.xml 264 RMD160 4c10b5dfc6857fcb2e9cdc91ff64bb5d4a5c2204 SHA1 69886f7e401bdf99a78d428ff4361991607e86c6 SHA256 dd28333300fc1ec2dbd96450bddbdd9e1061c1eff809e687442c53c91c05d86d
diff --git a/www-plugins/stylish/stylish-1.0.9.ebuild b/www-plugins/stylish/stylish-1.0.9-r1.ebuild
index 25419b37..25419b37 100644
--- a/www-plugins/stylish/stylish-1.0.9.ebuild
+++ b/www-plugins/stylish/stylish-1.0.9-r1.ebuild
diff --git a/www-plugins/video-downloadhelper/ChangeLog b/www-plugins/video-downloadhelper/ChangeLog
index 4ab067fb..aa846d64 100644
--- a/www-plugins/video-downloadhelper/ChangeLog
+++ b/www-plugins/video-downloadhelper/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
# $Header $
+*video-downloadhelper-4.8 (31 Jul 2010)
+
+ 31 Jul 2010; Martin Väth <martin@mvath.de>
+ Version bump, remove old ebuild.
+
*video-downloadhelper-4.7.4 (16 Jul 2010)
16 Jul 2010; Martin Väth <martin@mvath.de>
diff --git a/www-plugins/video-downloadhelper/Manifest b/www-plugins/video-downloadhelper/Manifest
index 52742a5d..1782fc23 100644
--- a/www-plugins/video-downloadhelper/Manifest
+++ b/www-plugins/video-downloadhelper/Manifest
@@ -1,4 +1,4 @@
-DIST downloadhelper-4.7.4-fx+sm.xpi 597571 RMD160 e54298ec7057d512a981d7fa6a0c067ef5189711 SHA1 ad71e42b88b59741dd99f162fcb8e301fd0b15b9 SHA256 dff4f393c6d41efa4811fd24a1672db0aca23aff333009639714f943bc5a9feb
-EBUILD video-downloadhelper-4.7.4.ebuild 424 RMD160 803ed6c8d701c1f5727b2fd79e3d443c6f7ea466 SHA1 9ce138ebad449959f05450ce32deca7ef019b53c SHA256 8cb26f39513978c24720cb2a76802307dbc19b442958445bba614490c35d72d8
-MISC ChangeLog 883 RMD160 47d5595959aa7ab9b22b645f46624ed4021f28c9 SHA1 ed7f636ee4f2aeca2b18cf4d57189065fe1259d7 SHA256 b16c88ade0b5a369f81963c766ca56ab1a100e173e3b9466e7d3206fb2a031f6
+DIST downloadhelper-4.8-fx+sm.xpi 597503 RMD160 5f226e82065616f30079e564e83e7bc9aa101f4d SHA1 ff1c3531d50c5a9a5fdfac6a1d10f4078c615aee SHA256 b1f57537c6cd2c18d6aa23fa39f3122687eca2a0f55d84cb96d69f2cc3ca180b
+EBUILD video-downloadhelper-4.8.ebuild 424 RMD160 803ed6c8d701c1f5727b2fd79e3d443c6f7ea466 SHA1 9ce138ebad449959f05450ce32deca7ef019b53c SHA256 8cb26f39513978c24720cb2a76802307dbc19b442958445bba614490c35d72d8
+MISC ChangeLog 1024 RMD160 5ee54fd38671ff1757569d4fcb28972319d40eb9 SHA1 49ebff978b7f0446907dc656b895749c779140c8 SHA256 9d7654c6837925b772a6436164f685d0fa452ab8fddf79c3b7203b52a83d622c
MISC metadata.xml 264 RMD160 4c10b5dfc6857fcb2e9cdc91ff64bb5d4a5c2204 SHA1 69886f7e401bdf99a78d428ff4361991607e86c6 SHA256 dd28333300fc1ec2dbd96450bddbdd9e1061c1eff809e687442c53c91c05d86d
diff --git a/www-plugins/video-downloadhelper/video-downloadhelper-4.7.4.ebuild b/www-plugins/video-downloadhelper/video-downloadhelper-4.8.ebuild
index 0911e817..0911e817 100644
--- a/www-plugins/video-downloadhelper/video-downloadhelper-4.7.4.ebuild
+++ b/www-plugins/video-downloadhelper/video-downloadhelper-4.8.ebuild
diff --git a/www-plugins/xclear/ChangeLog b/www-plugins/xclear/ChangeLog
index 7e76fe89..d84da3fb 100644
--- a/www-plugins/xclear/ChangeLog
+++ b/www-plugins/xclear/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
# $Header $
+ 31 Jul 2010; Martin Väth <martin@mvath.de>
+ Bump revision to force eclass upgrade.
+
*xclear-1.3 (13 Jun 2010)
13 Jun 2010; Martin Väth <martin@mvath.de>
diff --git a/www-plugins/xclear/Manifest b/www-plugins/xclear/Manifest
index 7eb62ffe..af2411f8 100644
--- a/www-plugins/xclear/Manifest
+++ b/www-plugins/xclear/Manifest
@@ -1,4 +1,4 @@
DIST xclear-1.3-fx.xpi 3659 RMD160 c0ef5324dae310d9b0a9cf258ecc9234b8ac107f SHA1 50d7caeadf104d8f4a51ab376f0adf7b1b88d9d3 SHA256 73f5e7527fe803f7ef66e76b94d224d0b0cf4db045d307e2282f49479eb6b8bd
-EBUILD xclear-1.3.ebuild 443 RMD160 3413e3c0b4dc499ae95d46c20a2fd61e52e22d4b SHA1 8109bf51113e19b3bfc46aa3abe3e05b2c2c9dd3 SHA256 d15920f56e205c2077ff731fa73a773396aa12d75a1852bebb5b4d00ebd9da25
-MISC ChangeLog 223 RMD160 2fcecf4cfb476e770fe1d9c41695882fcf764c05 SHA1 a355bb162b5ca2bed3af9dca3f9df1625d7f3aef SHA256 beaf7d8f2affb178427c548a78f519a9c8dcc563ae5d16d7f766b917e412666a
+EBUILD xclear-1.3-r1.ebuild 443 RMD160 3413e3c0b4dc499ae95d46c20a2fd61e52e22d4b SHA1 8109bf51113e19b3bfc46aa3abe3e05b2c2c9dd3 SHA256 d15920f56e205c2077ff731fa73a773396aa12d75a1852bebb5b4d00ebd9da25
+MISC ChangeLog 329 RMD160 eca7c3ee339d896036fc0d245a462c771d86042e SHA1 62093eb982bb7d0c4ba612fcf72d56cd767fbae7 SHA256 4aa6c68538f7d48532fb1e03256a9430a1b23764b0aafd1d37a8857435f9e7a0
MISC metadata.xml 264 RMD160 4c10b5dfc6857fcb2e9cdc91ff64bb5d4a5c2204 SHA1 69886f7e401bdf99a78d428ff4361991607e86c6 SHA256 dd28333300fc1ec2dbd96450bddbdd9e1061c1eff809e687442c53c91c05d86d
diff --git a/www-plugins/xclear/xclear-1.3.ebuild b/www-plugins/xclear/xclear-1.3-r1.ebuild
index 554136a4..554136a4 100644
--- a/www-plugins/xclear/xclear-1.3.ebuild
+++ b/www-plugins/xclear/xclear-1.3-r1.ebuild