summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/flexlm/Manifest5
-rw-r--r--app-admin/flexlm/files/90flexlm3
-rw-r--r--app-admin/flexlm/files/flexlm-conf13
-rw-r--r--app-admin/flexlm/files/flexlm-init19
-rw-r--r--app-admin/flexlm/flexlm-9.5-r2.ebuild77
-rw-r--r--app-admin/flexlm/metadata.xml5
6 files changed, 122 insertions, 0 deletions
diff --git a/app-admin/flexlm/Manifest b/app-admin/flexlm/Manifest
new file mode 100644
index 00000000..165b169c
--- /dev/null
+++ b/app-admin/flexlm/Manifest
@@ -0,0 +1,5 @@
+DIST flexusr.pdf 763798 SHA256 a1576599d45405f091702e951ab840172db19eefbe8f157f2fad7c965d0f9ba4
+DIST lmgrd-amd64.Z 327568 SHA256 49a5e24757502231295ec2c7ea23a770fe39642f0405fae3ba9715deee2ebfab
+DIST lmgrd-x86.Z 318617 SHA256 d79e1cc24ab8216c2d8252b90ac18ef771f0e89629f2f482a39fc77dd8f31523
+DIST lmutil-amd64.Z 331103 SHA256 2af1934b02d4499324389fa4491bdcfd8d72cca431e804d05848827abfc85413
+DIST lmutil-x86.Z 324583 SHA256 8b3da0d810fd8071ab968c74c74cff2ba90ae7d1a38dbfce0fbd802253eac0e5
diff --git a/app-admin/flexlm/files/90flexlm b/app-admin/flexlm/files/90flexlm
new file mode 100644
index 00000000..a60cf322
--- /dev/null
+++ b/app-admin/flexlm/files/90flexlm
@@ -0,0 +1,3 @@
+PATH=/opt/flexlm/bin
+ROOTPATH=/opt/flexlm/bin
+MANPATH=/opt/flexlm/man
diff --git a/app-admin/flexlm/files/flexlm-conf b/app-admin/flexlm/files/flexlm-conf
new file mode 100644
index 00000000..8d6f6941
--- /dev/null
+++ b/app-admin/flexlm/files/flexlm-conf
@@ -0,0 +1,13 @@
+# Copyright 2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# Logfile path: (NOTE: This must be uid/gid owned by the value of $LMUSER!)
+LMLOG="/var/log/flexlm/flexlm.log"
+
+# Run the lmgrd user as:
+LMUSER="flexlm"
+
+# List all license files delimeted by a colon
+LMLICENSE="/etc/flexlm/license.dat"
+#LMLICENSE="${LMLICENSE}:/var/flexlm/aw.dat"
+#LMLICENSE="${LMLICENSE}:/opt/shake/keys/license.dat"
diff --git a/app-admin/flexlm/files/flexlm-init b/app-admin/flexlm/files/flexlm-init
new file mode 100644
index 00000000..586878dd
--- /dev/null
+++ b/app-admin/flexlm/files/flexlm-init
@@ -0,0 +1,19 @@
+#!/sbin/openrc-run
+# Copyright 2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting lmgrd"
+ su - ${LMUSER} -c "umask 022; /opt/flexlm/bin/lmgrd -c '${LMLICENSE}' -l '${LMLOG}'"
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping lmgrd"
+ /opt/flexlm/bin/lmdown -q -all -force -c "${LMLICENSE}" >& /dev/null
+ eend $?
+}
diff --git a/app-admin/flexlm/flexlm-9.5-r2.ebuild b/app-admin/flexlm/flexlm-9.5-r2.ebuild
new file mode 100644
index 00000000..d1fc45c9
--- /dev/null
+++ b/app-admin/flexlm/flexlm-9.5-r2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+RESTRICT="fetch"
+inherit user
+
+DESCRIPTION="Macrovision FLEXlm license manager and utils"
+HOMEPAGE="http://www.macrovision.com/services/support/flexlm/lmgrd.shtml"
+# doc ? ( http://www.macrovision.com/services/support/flexlm/enduser.pdf -> flexusr.pdf )
+SRC_URI="doc? ( http://www.ni.com/pdf/manuals/flexusr.pdf )
+ x86? (
+ mirror://gentoo/lmgrd-x86.Z
+ mirror://gentoo/lmutil-x86.Z
+ )
+ amd64? (
+ mirror://gentoo/lmgrd-amd64.Z
+ mirror://gentoo/lmutil-amd64.Z
+ )"
+
+LICENSE="all-rights-reserved GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="doc"
+
+QA_PREBUILT="
+ opt/flexlm/bin/lmgrd
+ opt/flexlm/bin/lmutil"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ mv lmutil-* lmutil || die
+ mv lmgrd-* lmgrd || die
+}
+
+src_install () {
+ # executables
+ exeinto /opt/flexlm/bin
+ doexe lmgrd lmutil
+
+ dosym lmutil /opt/flexlm/bin/lmcksum
+ dosym lmutil /opt/flexlm/bin/lmdiag
+ dosym lmutil /opt/flexlm/bin/lmdown
+ dosym lmutil /opt/flexlm/bin/lmhostid
+ dosym lmutil /opt/flexlm/bin/lmremove
+ dosym lmutil /opt/flexlm/bin/lmreread
+ dosym lmutil /opt/flexlm/bin/lmstat
+ dosym lmutil /opt/flexlm/bin/lmver
+
+ # documentation
+ use doc && dodoc "${DISTDIR}"/enduser.pdf
+
+ # init files
+ newinitd "${FILESDIR}"/flexlm-init flexlm
+ newconfd "${FILESDIR}"/flexlm-conf flexlm
+
+ # environment
+ doenvd "${FILESDIR}"/90flexlm
+
+ # empty dir for licenses
+ keepdir /etc/flexlm
+
+ # log dir
+ dodir /var/log/flexlm
+}
+
+pkg_postinst() {
+ enewgroup flexlm
+ enewuser flexlm -1 /bin/bash /opt/flexlm flexlm
+
+ # See bug 383787
+ chown flexlm /var/log/flexlm || eerror "'chown flexlm /var/log/flexlm' failed!"
+
+ elog "FlexLM installed. Config is in /etc/conf.d/flexlm"
+ elog "Default location for license file is /etc/flexlm/license.dat"
+}
diff --git a/app-admin/flexlm/metadata.xml b/app-admin/flexlm/metadata.xml
new file mode 100644
index 00000000..0b92062f
--- /dev/null
+++ b/app-admin/flexlm/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription>Macrovision FLEXlm license manager and utils</longdescription>
+</pkgmetadata>