summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-fs/squashfs-tools/Manifest2
-rw-r--r--sys-fs/squashfs-tools/files/squashfs-tools-4.3-2gb.patch30
-rw-r--r--sys-fs/squashfs-tools/files/squashfs-tools-4.3-mem-overflow.patch35
-rw-r--r--sys-fs/squashfs-tools/files/squashfs-tools-4.3-quiet.patch56
-rw-r--r--sys-fs/squashfs-tools/files/squashfs-tools-4.3-xattrs.patch34
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-4.3.1_alpha0.ebuild (renamed from sys-fs/squashfs-tools/squashfs-tools-4.3-r2.ebuild)41
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-99999999.ebuild41
7 files changed, 47 insertions, 192 deletions
diff --git a/sys-fs/squashfs-tools/Manifest b/sys-fs/squashfs-tools/Manifest
index fadd2c0e..2501de33 100644
--- a/sys-fs/squashfs-tools/Manifest
+++ b/sys-fs/squashfs-tools/Manifest
@@ -1,2 +1,2 @@
+DIST squashfs-tools-4.3.1_alpha0.tar.gz 228918 SHA256 13ad0ec32cb16c259f8411a81d10344085ab5b6c03f1d6d1f5f64f2d4cf23d51
DIST squashfs-tools_4.3-3.debian.tar.xz 15252 SHA256 1c296cc147e322e7124bf23a3c242ac83f6a986e6d6f64829ad2424b33914fc4
-DIST squashfs4.3.tar.gz 182550 SHA256 0d605512437b1eb800b4736791559295ee5f60177e102e4d4ccd0ee241a5f3f6
diff --git a/sys-fs/squashfs-tools/files/squashfs-tools-4.3-2gb.patch b/sys-fs/squashfs-tools/files/squashfs-tools-4.3-2gb.patch
deleted file mode 100644
index 467448f6..00000000
--- a/sys-fs/squashfs-tools/files/squashfs-tools-4.3-2gb.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 9c1db6d13a51a2e009f0027ef336ce03624eac0d Mon Sep 17 00:00:00 2001
-From: "Guan, Xin" <guanx.bac@gmail.com>
-Date: Sat, 13 Sep 2014 13:15:26 +0200
-Subject: [PATCH] Fix 2GB-limit of the is_fragment(...) function.
-
-Applies to squashfs-tools 4.3.
-
-Reported-by: Bruno Wolff III <bruno@wolff.to>
-Signed-off-by: Guan, Xin <guanx.bac@gmail.com>
-Signed-off-by: Phillip Lougher <phillip@squashfs.org.uk>
----
- squashfs-tools/mksquashfs.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/squashfs-tools/mksquashfs.c b/squashfs-tools/mksquashfs.c
-index f1fcff1cc284..d221c35865a0 100644
---- a/squashfs-tools/mksquashfs.c
-+++ b/squashfs-tools/mksquashfs.c
-@@ -2029,7 +2029,7 @@ struct file_info *duplicate(long long file_size, long long bytes,
-
- inline int is_fragment(struct inode_info *inode)
- {
-- int file_size = inode->buf.st_size;
-+ off_t file_size = inode->buf.st_size;
-
- /*
- * If this block is to be compressed differently to the
---
-2.8.2
-
diff --git a/sys-fs/squashfs-tools/files/squashfs-tools-4.3-mem-overflow.patch b/sys-fs/squashfs-tools/files/squashfs-tools-4.3-mem-overflow.patch
deleted file mode 100644
index a9b00014..00000000
--- a/sys-fs/squashfs-tools/files/squashfs-tools-4.3-mem-overflow.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-taken from Fedora
-
-From 604b607d8ac91eb8afc0b6e3d917d5c073096103 Mon Sep 17 00:00:00 2001
-From: Phillip Lougher <phillip@squashfs.org.uk>
-Date: Wed, 11 Jun 2014 04:51:37 +0100
-Subject: mksquashfs: ensure value does not overflow a signed int in -mem
- option
-
-Signed-off-by: Phillip Lougher <phillip@squashfs.org.uk>
-
-diff --git a/squashfs-tools/mksquashfs.c b/squashfs-tools/mksquashfs.c
-index 5370ecf..9676dc8 100644
---- a/squashfs-tools/mksquashfs.c
-+++ b/squashfs-tools/mksquashfs.c
-@@ -5193,7 +5193,16 @@ print_compressor_options:
- argv[0]);
- exit(1);
- }
-- /* convert from bytes to Mbytes */
-+
-+ /*
-+ * convert from bytes to Mbytes, ensuring the value
-+ * does not overflow a signed int
-+ */
-+ if(number >= (1LL << 51)) {
-+ ERROR("%s: -mem invalid mem size\n", argv[0]);
-+ exit(1);
-+ }
-+
- total_mem = number / 1048576;
- if(total_mem < (SQUASHFS_LOWMEM / SQUASHFS_TAKE)) {
- ERROR("%s: -mem should be %d Mbytes or "
---
-cgit v0.10.1
-
diff --git a/sys-fs/squashfs-tools/files/squashfs-tools-4.3-quiet.patch b/sys-fs/squashfs-tools/files/squashfs-tools-4.3-quiet.patch
deleted file mode 100644
index e0e9854c..00000000
--- a/sys-fs/squashfs-tools/files/squashfs-tools-4.3-quiet.patch
+++ /dev/null
@@ -1,56 +0,0 @@
---- 1/mksquashfs.c
-+++ 1/mksquashfs.c
-@@ -78,6 +78,7 @@
- #include "process_fragments.h"
-
- int delete = FALSE;
-+int quiet = FALSE;
- int fd;
- struct squashfs_super_block sBlk;
-
-@@ -4169,7 +4170,7 @@
-
- main_thread = pthread_self();
-
-- printf("Parallel mksquashfs: Using %d processor%s\n", processors,
-+ quiet || printf("Parallel mksquashfs: Using %d processor%s\n", processors,
- processors == 1 ? "" : "s");
-
- /* Restore the signal mask for the main thread */
-@@ -4687,6 +4688,9 @@
- total_bytes += total_inode_bytes + total_directory_bytes +
- sizeof(struct squashfs_super_block) + total_xattr_bytes;
-
-+ if(quiet)
-+ return;
-+
- printf("\n%sSquashfs %d.%d filesystem, %s compressed, data block size"
- " %d\n", exportable ? "Exportable " : "", SQUASHFS_MAJOR,
- SQUASHFS_MINOR, comp->name, block_size);
-@@ -5259,6 +5263,9 @@
- else if(strcmp(argv[i], "-noappend") == 0)
- delete = TRUE;
-
-+ else if(strcmp(argv[i], "-quiet") == 0)
-+ quiet = TRUE;
-+
- else if(strcmp(argv[i], "-keep-as-directory") == 0)
- keep_as_directory = TRUE;
-
-@@ -5351,6 +5358,7 @@
- "using recovery file <name>\n");
- ERROR("-no-recovery\t\tdon't generate a recovery "
- "file\n");
-+ ERROR("-quiet\t\t\tno verbose output\n");
- ERROR("-info\t\t\tprint files written to filesystem\n");
- ERROR("-no-progress\t\tdon't display the progress "
- "bar\n");
-@@ -5541,7 +5549,7 @@
- void *comp_data = compressor_dump_options(comp, block_size,
- &size);
-
-- printf("Creating %d.%d filesystem on %s, block size %d.\n",
-+ quiet || printf("Creating %d.%d filesystem on %s, block size %d.\n",
- SQUASHFS_MAJOR, SQUASHFS_MINOR, argv[source + 1], block_size);
-
- /*
diff --git a/sys-fs/squashfs-tools/files/squashfs-tools-4.3-xattrs.patch b/sys-fs/squashfs-tools/files/squashfs-tools-4.3-xattrs.patch
deleted file mode 100644
index 47b0ea5c..00000000
--- a/sys-fs/squashfs-tools/files/squashfs-tools-4.3-xattrs.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From ffe9e55c4993422ce36213fa86d4fc29c22646ea Mon Sep 17 00:00:00 2001
-From: Wessel Dankers <wsl-debian-804194@fruit.je>
-Date: Fri, 17 Jun 2016 09:46:42 +0800
-Subject: [PATCH] unsquashfs: Correctly set file capabilities
-
-As posted on https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=804194.
----
- squashfs-tools/unsquashfs.c | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/squashfs-tools/unsquashfs.c b/squashfs-tools/unsquashfs.c
-index 1323dd6..a5f0117 100644
---- a/squashfs-tools/unsquashfs.c
-+++ b/squashfs-tools/unsquashfs.c
-@@ -821,8 +821,6 @@ int set_attributes(char *pathname, int mode, uid_t uid, gid_t guid, time_t time,
- {
- struct utimbuf times = { time, time };
-
-- write_xattr(pathname, xattr);
--
- if(utime(pathname, &times) == -1) {
- ERROR("set_attributes: failed to set time on %s, because %s\n",
- pathname, strerror(errno));
-@@ -845,6 +843,8 @@ int set_attributes(char *pathname, int mode, uid_t uid, gid_t guid, time_t time,
- return FALSE;
- }
-
-+ write_xattr(pathname, xattr);
-+
- return TRUE;
- }
-
---
-2.8.0.rc3.226.g39d4020
diff --git a/sys-fs/squashfs-tools/squashfs-tools-4.3-r2.ebuild b/sys-fs/squashfs-tools/squashfs-tools-4.3.1_alpha0.ebuild
index 2b6af3dd..9238ce6f 100644
--- a/sys-fs/squashfs-tools/squashfs-tools-4.3-r2.ebuild
+++ b/sys-fs/squashfs-tools/squashfs-tools-4.3.1_alpha0.ebuild
@@ -5,20 +5,17 @@ EAPI=6
inherit flag-o-matic toolchain-funcs
LIVE=false
-PVm=${PV}
+PVm=4.3
case ${PV} in
*9999)
- LIVE=:
- PVm=4.3;;
+ LIVE=:;;
esac
Pm=${PN}-${PVm}
DEB_VER="3"
-DESCRIPTION="Tool for creating compressed filesystem type squashfs. Patched to support -quiet"
-HOMEPAGE="http://squashfs.sourceforge.net"
+DESCRIPTION="Tool for creating compressed filesystem type squashfs"
+HOMEPAGE="https://github.com/plougher/squashfs-tools/ https://git.kernel.org/pub/scm/fs/squashfs/squashfs-tools.git http://squashfs.sourceforge.net"
EXTRA_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PVm}-${DEB_VER}.debian.tar.xz"
-SRC_URI="mirror://sourceforge/squashfs/squashfs${PV}.tar.gz
- ${EXTRA_URI}"
LICENSE="GPL-2"
SLOT="0"
@@ -38,8 +35,8 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/squashfs${PV}/${PN}"
-if ${LIVE}
-then PROPERTIES="live"
+if ${LIVE}; then
+ PROPERTIES="live"
EGIT_REPO_URI="git://github.com/plougher/${PN}"
inherit git-r3
SRC_URI=${EXTRA_URI}
@@ -49,12 +46,23 @@ src_unpack() {
default
git-r3_src_unpack
}
+else
+ RESTRICT="mirror"
+ EGIT_COMMIT="94f557524a2a08bc48a13ffff1a3c8d7f6170f09"
+ SRC_URI="https://github.com/plougher/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz
+${EXTRA_URI}"
+ S="${WORKDIR}/${P}/${PN}"
+src_unpack() {
+ default
+ mv -- "${WORKDIR}/${PN}-${EGIT_COMMIT}" "${WORKDIR}/${P}"
+}
fi
src_prepare() {
local i j
- for i in "${WORKDIR}"/debian/patches/*.patch
- do ${LIVE} && j=${i##*/} && case ${j%.*} in
+ for i in "${WORKDIR}"/debian/patches/*.patch; do
+ j=${i##*/}
+ case ${j%.*} in
0002-fix_phys_mem_calculation)
continue;;
esac
@@ -62,16 +70,14 @@ src_prepare() {
done
eapply -p2 "${FILESDIR}"/${Pm}-sysmacros.patch
eapply -p2 "${FILESDIR}"/${Pm}-aligned-data.patch
- ${LIVE} || eapply -p2 "${FILESDIR}"/${Pm}-2gb.patch
eapply "${FILESDIR}"/${Pm}-local-cve-fix.patch
- ${LIVE} || eapply -p2 "${FILESDIR}"/${Pm}-mem-overflow.patch
- eapply -p2 "${FILESDIR}"/${Pm}-xattrs.patch
eapply "${FILESDIR}"/${Pm}-static-inline.patch
- eapply "${FILESDIR}"/${Pm}-quiet.patch
eapply_user
}
-use10() { usex $1 1 0 ; }
+use10() {
+ usex $1 1 0
+}
src_configure() {
# set up make command line variables in EMAKE_SQUASHFS_CONF
@@ -96,7 +102,6 @@ src_compile() {
src_install() {
dobin mksquashfs unsquashfs
cd ..
- dodoc CHANGES README*
- ${LIVE} || dodoc PERFORMANCE.README pseudo-file.example OLD-READMEs/*
+ dodoc CHANGES README RELEASE-README ACKNOWLEDGEMENTS RELEASE-READMEs/*
doman "${WORKDIR}"/debian/manpages/*.[0-9]
}
diff --git a/sys-fs/squashfs-tools/squashfs-tools-99999999.ebuild b/sys-fs/squashfs-tools/squashfs-tools-99999999.ebuild
index 2b6af3dd..9238ce6f 100644
--- a/sys-fs/squashfs-tools/squashfs-tools-99999999.ebuild
+++ b/sys-fs/squashfs-tools/squashfs-tools-99999999.ebuild
@@ -5,20 +5,17 @@ EAPI=6
inherit flag-o-matic toolchain-funcs
LIVE=false
-PVm=${PV}
+PVm=4.3
case ${PV} in
*9999)
- LIVE=:
- PVm=4.3;;
+ LIVE=:;;
esac
Pm=${PN}-${PVm}
DEB_VER="3"
-DESCRIPTION="Tool for creating compressed filesystem type squashfs. Patched to support -quiet"
-HOMEPAGE="http://squashfs.sourceforge.net"
+DESCRIPTION="Tool for creating compressed filesystem type squashfs"
+HOMEPAGE="https://github.com/plougher/squashfs-tools/ https://git.kernel.org/pub/scm/fs/squashfs/squashfs-tools.git http://squashfs.sourceforge.net"
EXTRA_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PVm}-${DEB_VER}.debian.tar.xz"
-SRC_URI="mirror://sourceforge/squashfs/squashfs${PV}.tar.gz
- ${EXTRA_URI}"
LICENSE="GPL-2"
SLOT="0"
@@ -38,8 +35,8 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/squashfs${PV}/${PN}"
-if ${LIVE}
-then PROPERTIES="live"
+if ${LIVE}; then
+ PROPERTIES="live"
EGIT_REPO_URI="git://github.com/plougher/${PN}"
inherit git-r3
SRC_URI=${EXTRA_URI}
@@ -49,12 +46,23 @@ src_unpack() {
default
git-r3_src_unpack
}
+else
+ RESTRICT="mirror"
+ EGIT_COMMIT="94f557524a2a08bc48a13ffff1a3c8d7f6170f09"
+ SRC_URI="https://github.com/plougher/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz
+${EXTRA_URI}"
+ S="${WORKDIR}/${P}/${PN}"
+src_unpack() {
+ default
+ mv -- "${WORKDIR}/${PN}-${EGIT_COMMIT}" "${WORKDIR}/${P}"
+}
fi
src_prepare() {
local i j
- for i in "${WORKDIR}"/debian/patches/*.patch
- do ${LIVE} && j=${i##*/} && case ${j%.*} in
+ for i in "${WORKDIR}"/debian/patches/*.patch; do
+ j=${i##*/}
+ case ${j%.*} in
0002-fix_phys_mem_calculation)
continue;;
esac
@@ -62,16 +70,14 @@ src_prepare() {
done
eapply -p2 "${FILESDIR}"/${Pm}-sysmacros.patch
eapply -p2 "${FILESDIR}"/${Pm}-aligned-data.patch
- ${LIVE} || eapply -p2 "${FILESDIR}"/${Pm}-2gb.patch
eapply "${FILESDIR}"/${Pm}-local-cve-fix.patch
- ${LIVE} || eapply -p2 "${FILESDIR}"/${Pm}-mem-overflow.patch
- eapply -p2 "${FILESDIR}"/${Pm}-xattrs.patch
eapply "${FILESDIR}"/${Pm}-static-inline.patch
- eapply "${FILESDIR}"/${Pm}-quiet.patch
eapply_user
}
-use10() { usex $1 1 0 ; }
+use10() {
+ usex $1 1 0
+}
src_configure() {
# set up make command line variables in EMAKE_SQUASHFS_CONF
@@ -96,7 +102,6 @@ src_compile() {
src_install() {
dobin mksquashfs unsquashfs
cd ..
- dodoc CHANGES README*
- ${LIVE} || dodoc PERFORMANCE.README pseudo-file.example OLD-READMEs/*
+ dodoc CHANGES README RELEASE-README ACKNOWLEDGEMENTS RELEASE-READMEs/*
doman "${WORKDIR}"/debian/manpages/*.[0-9]
}