summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lang/python/files/test.support.unlink-ignore-PermissionError.patch28
-rw-r--r--dev-lang/python/python-3.6.10-r1.ebuild (renamed from dev-lang/python/python-3.6.10.ebuild)8
-rw-r--r--dev-lang/python/python-3.7.7-r1.ebuild (renamed from dev-lang/python/python-3.7.7.ebuild)8
-rw-r--r--metadata/pkg_desc_index4
-rw-r--r--x11-libs/gtk+/Manifest2
-rw-r--r--x11-libs/gtk+/gtk+-3.24.16.ebuild (renamed from x11-libs/gtk+/gtk+-3.24.14.ebuild)2
6 files changed, 46 insertions, 6 deletions
diff --git a/dev-lang/python/files/test.support.unlink-ignore-PermissionError.patch b/dev-lang/python/files/test.support.unlink-ignore-PermissionError.patch
new file mode 100644
index 00000000..6cae17b5
--- /dev/null
+++ b/dev-lang/python/files/test.support.unlink-ignore-PermissionError.patch
@@ -0,0 +1,28 @@
+From 6e6402caa7962a9c9f7c5327f3c802545824f7f9 Mon Sep 17 00:00:00 2001
+From: Mike Gilbert <floppym@gentoo.org>
+Date: Fri, 3 Apr 2020 10:37:56 -0400
+Subject: [PATCH] test.support.unlink: ignore PermissionError
+
+Resolves test errors when running in the Gentoo sandbox environment.
+
+Bug: https://bugs.gentoo.org/679628
+---
+ Lib/test/support/__init__.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Lib/test/support/__init__.py b/Lib/test/support/__init__.py
+index 1f792d8514d..a0772480eb4 100644
+--- a/Lib/test/support/__init__.py
++++ b/Lib/test/support/__init__.py
+@@ -488,7 +488,7 @@ else:
+ def unlink(filename):
+ try:
+ _unlink(filename)
+- except (FileNotFoundError, NotADirectoryError):
++ except (FileNotFoundError, NotADirectoryError, PermissionError):
+ pass
+
+ def rmdir(dirname):
+--
+2.26.0
+
diff --git a/dev-lang/python/python-3.6.10.ebuild b/dev-lang/python/python-3.6.10-r1.ebuild
index e354187f..d0e1ccac 100644
--- a/dev-lang/python/python-3.6.10.ebuild
+++ b/dev-lang/python/python-3.6.10-r1.ebuild
@@ -18,7 +18,7 @@ S="${WORKDIR}/${MY_P}"
LICENSE="PSF-2"
SLOT="${PYVER}/${PYVER}m"
-KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86"
IUSE="bluetooth build examples gdbm hardened ipv6 libressl +ncurses +readline sqlite +ssl test +threads tinfo tk wininst +xml"
RESTRICT="!test? ( test )"
@@ -65,6 +65,7 @@ src_prepare() {
local PATCHES=(
"${WORKDIR}/${PATCHSET}"
+ "${FILESDIR}/test.support.unlink-ignore-PermissionError.patch"
)
! use tinfo || PATCHES+=("${FILESDIR}/curses_tinfo.patch")
@@ -135,6 +136,11 @@ src_configure() {
fi
local myeconfargs=(
+ # glibc-2.30 removes it; since we can't cleanly force-rebuild
+ # Python on glibc upgrade, remove it proactively to give
+ # a chance for users rebuilding python before glibc
+ ac_cv_header_stropts_h=no
+
--with-fpectl
--enable-shared
$(use_enable ipv6)
diff --git a/dev-lang/python/python-3.7.7.ebuild b/dev-lang/python/python-3.7.7-r1.ebuild
index 3bfc9622..916fe921 100644
--- a/dev-lang/python/python-3.7.7.ebuild
+++ b/dev-lang/python/python-3.7.7-r1.ebuild
@@ -18,7 +18,7 @@ S="${WORKDIR}/${MY_P}"
LICENSE="PSF-2"
SLOT="${PYVER}/${PYVER}m"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ~ppc ppc64 ~riscv ~s390 sparc ~x86"
IUSE="bluetooth build examples gdbm hardened ipv6 libressl +ncurses +readline sqlite +ssl test tinfo tk wininst +xml"
RESTRICT="!test? ( test )"
@@ -66,6 +66,7 @@ src_prepare() {
local PATCHES=(
"${WORKDIR}/${PATCHSET}"
+ "${FILESDIR}/test.support.unlink-ignore-PermissionError.patch"
)
! use tinfo || PATCHES+=("${FILESDIR}/curses_tinfo.patch")
@@ -130,6 +131,11 @@ src_configure() {
fi
local myeconfargs=(
+ # glibc-2.30 removes it; since we can't cleanly force-rebuild
+ # Python on glibc upgrade, remove it proactively to give
+ # a chance for users rebuilding python before glibc
+ ac_cv_header_stropts_h=no
+
--enable-shared
$(use_enable ipv6)
--infodir='${prefix}/share/info'
diff --git a/metadata/pkg_desc_index b/metadata/pkg_desc_index
index b1d407df..f30b267a 100644
--- a/metadata/pkg_desc_index
+++ b/metadata/pkg_desc_index
@@ -53,7 +53,7 @@ app-text/podofo 0.9.6_p20180715-r1: PoDoFo is a C++ library to work with the PDF
app-text/psjoin 0.3: concatenate postscript files. From new PostScript Utilities
app-text/stardict 3.0.6-r4 4.0.0_pre20170304: A international dictionary supporting fuzzy and glob style matching
dev-cpp/cpplint 99999999: The google styleguide together with cpplint and an emacs file
-dev-lang/python 3.6.10 3.7.7: An interpreted, interactive, object-oriented programming language
+dev-lang/python 3.6.10-r1 3.7.7-r1: An interpreted, interactive, object-oriented programming language
dev-libs/osformat 1.0.5 999999999: C++ library for a typesafe printf/sprintf based on << conversion
dev-libs/weston 5.0.0-r1 8.0.0: Wayland reference compositor
dev-perl/File-lchown 0.20-r1: Use the lchown(2) and lutimes(2) system call from Perl
@@ -132,6 +132,6 @@ www-plugins/noscript 10.6.3: Firefox webextension: restrict active contents like
www-plugins/skip-redirect 2.2.1: Firefox webextension: skip intermediary pages before redirecting
www-plugins/translate-to-me 1.1: Firefox webextension: translate the selected text with www.linguee.com
www-plugins/ublock-origin 1.17.2: Firefox webextension: An efficient list-based blocker
-x11-libs/gtk+ 2.24.32-r1 3.24.14: Gimp ToolKit +
+x11-libs/gtk+ 2.24.32-r1 3.24.16: Gimp ToolKit +
x11-libs/motif 2.3.8-r1: The Motif user interface component toolkit
x11-themes/fvwm-crystal 3.4.1-r2 3.6.2: Configurable FVWM theme with transparency and freedesktop compatible menu
diff --git a/x11-libs/gtk+/Manifest b/x11-libs/gtk+/Manifest
index f1bfc5ad..d7967b04 100644
--- a/x11-libs/gtk+/Manifest
+++ b/x11-libs/gtk+/Manifest
@@ -1,3 +1,3 @@
DIST gtk+-2.24.32-patchset-r1.tar.xz 13364 SHA512 1a15dce7578a914585981426d2e5d1cc45866866a70c3f443d1867ab1c0c28fb279bde6c3117b28eec2758a62c1b54bb6fb1b382ad6e9a7cf0114b13f2afd858
DIST gtk+-2.24.32.tar.xz 12620860 SHA512 8e8fd9ae32f1d6fb544da260f00599f0f05090d910d767b06ef086ab4f1f8373a29bb0da9767761c9b5f4cfd51b5c45d0fa5d39b0428c839ddf0a579df806696
-DIST gtk+-3.24.14.tar.xz 20420928 SHA512 a5ce659508933f6a3825aaafe9b30f51bd1357a62a6c66526ebd716627c829aa24543b4f8bd6f701dceda1d9fff94ad105f89f02a14d53749744e868bdff26bf
+DIST gtk+-3.24.16.tar.xz 20417592 SHA512 181d31dea038016357cd0eba5b9e8a17056bc061f4ae2ebc713bceee46cd30787993cec463aae658faddc57b9071549fa196f6a2a1f67c314d99e4365f50a0cb
diff --git a/x11-libs/gtk+/gtk+-3.24.14.ebuild b/x11-libs/gtk+/gtk+-3.24.16.ebuild
index 001701d2..1f5fabeb 100644
--- a/x11-libs/gtk+/gtk+-3.24.14.ebuild
+++ b/x11-libs/gtk+/gtk+-3.24.16.ebuild
@@ -19,7 +19,7 @@ REQUIRED_USE="
xinerama? ( X )
"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
# Upstream wants us to do their job:
# https://bugzilla.gnome.org/show_bug.cgi?id=768662#c1