summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-cdr/cdrtools/Manifest1
-rw-r--r--app-cdr/cdrtools/cdrtools-3.02_alpha07-r1.ebuild278
-rw-r--r--app-cdr/cdrtools/files/cdrtools-fix-clone-uclibc.patch69
-rw-r--r--app-cdr/cdrtools/metadata.xml24
-rw-r--r--app-shells/schily-tools/Manifest1
-rw-r--r--app-shells/schily-tools/metadata.xml1
-rw-r--r--app-shells/schily-tools/schily-tools-2017.10.10.ebuild410
-rw-r--r--metadata/pkg_desc_index3
-rw-r--r--profiles/use.local.desc2
9 files changed, 788 insertions, 1 deletions
diff --git a/app-cdr/cdrtools/Manifest b/app-cdr/cdrtools/Manifest
new file mode 100644
index 00000000..34a842e4
--- /dev/null
+++ b/app-cdr/cdrtools/Manifest
@@ -0,0 +1 @@
+DIST cdrtools-3.02a07.tar.bz2 2127058 SHA256 49c1a67fa7ad3d7c0b05d41d18cb6677b40d4811faba111f0c01145d3ef0491b SHA512 7f9835dd32ccca119d2ab77de1cdbd8cfbacc8e9923ca42175a15a5b1f45a8aa238fa3b0917ff67697b54905edc78a142f7106af9127854f944adead4a0d826d
diff --git a/app-cdr/cdrtools/cdrtools-3.02_alpha07-r1.ebuild b/app-cdr/cdrtools/cdrtools-3.02_alpha07-r1.ebuild
new file mode 100644
index 00000000..cececc32
--- /dev/null
+++ b/app-cdr/cdrtools/cdrtools-3.02_alpha07-r1.ebuild
@@ -0,0 +1,278 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit fcaps multilib toolchain-funcs flag-o-matic gnuconfig
+
+MY_P="${P/_alpha/a}"
+
+DESCRIPTION="A set of tools for CD/DVD reading and recording, including cdrecord"
+HOMEPAGE="https://sourceforge.net/projects/cdrtools/"
+SRC_URI="mirror://sourceforge/${PN}/$([[ -z ${PV/*_alpha*} ]] && echo 'alpha')/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1 CDDL-Schily"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="acl caps nls schily-tools unicode"
+
+RDEPEND="acl? ( virtual/acl )
+ caps? ( sys-libs/libcap )
+ nls? ( virtual/libintl )
+ schily-tools? ( app-shells/schily-tools[-system-libschily(-)] )"
+DEPEND="${RDEPEND}
+ x11-misc/makedepend
+ nls? ( >=sys-devel/gettext-0.18.1.1 )"
+
+S=${WORKDIR}/${P/_alpha[0-9][0-9]}
+
+FILECAPS=(
+ cap_sys_resource,cap_dac_override,cap_sys_admin,cap_sys_nice,cap_net_bind_service,cap_ipc_lock,cap_sys_rawio+ep usr/bin/cdrecord --
+ cap_dac_override,cap_sys_admin,cap_sys_nice,cap_net_bind_service,cap_sys_rawio+ep usr/bin/cdda2wav --
+ cap_dac_override,cap_sys_admin,cap_net_bind_service,cap_sys_rawio+ep usr/bin/readcd
+)
+
+cdrtools_os() {
+ local os="linux"
+ [[ ${CHOST} == *-darwin* ]] && os="mac-os10"
+ [[ ${CHOST} == *-freebsd* ]] && os="freebsd"
+ echo "${os}"
+}
+
+src_prepare() {
+ default
+
+ gnuconfig_update
+
+ # This fixes a clash with clone() on uclibc. Upstream isn't
+ # going to include this so let's try to carry it forward.
+ # Contact me if it needs updating. Bug #486782.
+ # Anthony G. Basile <blueness@gentoo.org>.
+ use elibc_uclibc && epatch "${FILESDIR}"/${PN}-fix-clone-uclibc.patch
+
+ # Remove profiled make files.
+ find -name '*_p.mk' -delete || die "delete *_p.mk"
+
+ # Adjusting hardcoded paths.
+ sed -i -e "s|opt/schily|usr|" \
+ $(find ./ -type f -name \*.[0-9ch] -exec grep -l 'opt/schily' '{}' '+') \
+ || die "sed opt/schily"
+
+ sed -i -e "s|\(^INSDIR=\t\tshare/doc/\)|\1${PF}/|" \
+ $(find ./ -type f -exec grep -l '^INSDIR.\+doc' '{}' '+') \
+ || die "sed doc"
+
+ # Respect libdir.
+ sed -i -e "s|\(^INSDIR=\t\t\)lib|\1$(get_libdir)|" \
+ $(find ./ -type f -exec grep -l '^INSDIR.\+lib\(/siconv\)\?$' '{}' '+') \
+ || die "sed multilib"
+
+ # Do not install static libraries.
+ sed -i -e "s|include\t\t.*rules.lib||" \
+ $(find ./ -type f -exec grep -l '^include.\+rules\.lib' '{}' '+') \
+ || die "sed rules"
+
+ # Enable verbose build.
+ sed -i -e '/@echo.*==>.*;/s:@echo[^;]*;:&set -x;:' \
+ RULES/*.rul RULES/rules.prg RULES/rules.inc \
+ || die "sed verbose rules"
+
+ # Respect CC/CXX variables.
+ cd "${S}"/RULES || die
+ local tcCC=$(tc-getCC)
+ local tcCXX=$(tc-getCXX)
+ sed -i -e "/cc-config.sh/s|\$(C_ARCH:%64=%) \$(CCOM_DEF)|${tcCC} ${tcCC}|" \
+ rules1.top || die "sed rules1.top"
+ sed -i -e "/^CC_COM_DEF=/s|gcc|${tcCC}|" \
+ -e "/^CC++_COM_DEF=/s|g++|${tcCXX}|" \
+ -e "/COPTOPT=/s|-O||" \
+ -e 's|$(GCCOPTOPT)||' \
+ cc-gcc.rul || die "sed cc-gcc.rul"
+ sed -i -e "s|^#\(CONFFLAGS +=\).*|\1\t-cc=${tcCC}|" \
+ rules.cnf || die "sed rules.cnf"
+
+ # Schily make setup.
+ cd "${S}"/DEFAULTS || die
+ local os=$(cdrtools_os)
+
+ sed -i \
+ -e "s|^\(DEFLINKMODE=\).*|\1\tdynamic|" \
+ -e "s|^\(LINUX_INCL_PATH=\).*|\1|" \
+ -e "s|^\(LDPATH=\).*|\1|" \
+ -e "s|^\(RUNPATH=\).*|\1|" \
+ -e "s|^\(INS_BASE=\).*|\1\t${ED}/usr|" \
+ -e "s|^\(INS_RBASE=\).*|\1\t${ED}|" \
+ -e "s|^\(DEFINSGRP=\).*|\1\t0|" \
+ -e '/^DEFUMASK/s,002,022,g' \
+ Defaults.${os} || die "sed Schily make setup"
+ # re DEFUMASK above:
+ # bug 486680: grsec TPE will block the exec if the directory is
+ # group-writable. This is painful with cdrtools, because it makes a bunch of
+ # group-writable directories during build. Change the umask on their
+ # creation to prevent this.
+}
+
+ac_cv_sizeof() {
+ cat <<-EOF >"${T}"/test.c
+ #include <inttypes.h>
+ #include <stddef.h>
+ #include <stdint.h>
+ #include <sys/types.h>
+ int main () {
+ static int test_array [1 - 2 * !((sizeof(TYPE)) == LEN)];
+ test_array [0] = 0;
+ return test_array [0];
+ }
+ EOF
+
+ local i=1
+ while [[ ${i} -lt 20 ]] ; do
+ if ${CC} ${CPPFLAGS} ${CFLAGS} -c "${T}"/test.c -o /dev/null -DTYPE="$1" -DLEN=$i 2>/dev/null; then
+ echo ${i}
+ return 0
+ fi
+ : $(( i += 1 ))
+ done
+ return 1
+}
+
+src_configure() {
+ use acl || export ac_cv_header_sys_acl_h="no"
+ use caps || export ac_cv_lib_cap_cap_get_proc="no"
+ export ac_cv_header_pulse_pulseaudio_h="no"
+
+ # skip obsolete configure script
+ if tc-is-cross-compiler ; then
+ # Cache known values for targets. #486680
+
+ tc-export CC
+ local var val t types=(
+ char "short int" int "long int" "long long"
+ "unsigned char" "unsigned short int" "unsigned int"
+ "unsigned long int" "unsigned long long"
+ float double "long double" size_t ssize_t ptrdiff_t
+ mode_t uid_t gid_t pid_t dev_t time_t wchar_t
+ "char *" "unsigned char *"
+ )
+ for t in "${types[@]}" ; do
+ var="ac_cv_sizeof_${t// /_}"
+ var=${var//[*]/p}
+ val=$(ac_cv_sizeof "${t}") || die "could not compute ${t}"
+ export "${var}=${val}"
+ einfo "Computing sizeof(${t}) as ${val}"
+ done
+ # We don't have these types.
+ export ac_cv_sizeof___int64=0
+ export ac_cv_sizeof_unsigned___int64=0
+ export ac_cv_sizeof_major_t=${ac_cv_sizeof_dev_t}
+ export ac_cv_sizeof_minor_t=${ac_cv_sizeof_dev_t}
+ export ac_cv_sizeof_wchar=${ac_cv_sizeof_wchar_t}
+
+ export ac_cv_type_prototypes="yes"
+ export ac_cv_func_mlock{,all}="yes"
+ export ac_cv_func_{e,f,g}cvt=$(usex elibc_glibc)
+ export ac_cv_func_dtoa_r="no"
+ export ac_cv_func_sys_siglist{,_def}="no"
+ export ac_cv_func_printf_{j,ll}="yes"
+ export ac_cv_realloc_null="yes"
+ export ac_cv_no_user_malloc="no"
+ export ac_cv_var_timezone="yes"
+ export ac_cv_var___progname{,_full}="yes"
+ export ac_cv_fnmatch_igncase="yes"
+ export ac_cv_file__dev_{fd_{0,1,2},null,std{err,in,out},tty,zero}="yes"
+ export ac_cv_file__usr_src_linux_include="no"
+
+ case $(cdrtools_os) in
+ linux)
+ export ac_cv_func_bsd_{g,s}etpgrp="no"
+ export ac_cv_hard_symlinks="yes"
+ export ac_cv_link_nofollow="yes"
+ export ac_cv_access_e_ok="no"
+
+ export ac_cv_dev_minor_noncontig="yes"
+ case ${ac_cv_sizeof_long_int} in
+ 4) export ac_cv_dev_minor_bits="32";;
+ 8) export ac_cv_dev_minor_bits="44";;
+ esac
+
+ cat <<-EOF >"${T}"/test.c
+ struct {
+ char start[6];
+ unsigned char x1:4;
+ unsigned char x2:4;
+ char end[5];
+ } a = {
+ .start = {'S', 't', 'A', 'r', 'T', '_'},
+ .x1 = 5,
+ .x2 = 4,
+ .end = {'_', 'e', 'N', 'd', 'X'},
+ };
+ EOF
+ ${CC} ${CPPFLAGS} ${CFLAGS} -c "${T}"/test.c -o "${T}"/test.o
+ if grep -q 'StArT_E_eNdX' "${T}"/test.o ; then
+ export ac_cv_c_bitfields_htol="no"
+ elif grep -q 'StArT_T_eNdX' "${T}"/test.o ; then
+ export ac_cv_c_bitfields_htol="yes"
+ fi
+ ;;
+ esac
+ fi
+}
+
+src_compile() {
+ if use unicode; then
+ local flags="$(test-flags -finput-charset=ISO-8859-1 -fexec-charset=UTF-8)"
+ if [[ -n ${flags} ]]; then
+ append-flags ${flags}
+ else
+ ewarn "Your compiler does not support the options required to build"
+ ewarn "cdrtools with unicode in USE. unicode flag will be ignored."
+ fi
+ fi
+
+ # If not built with -j1, "sometimes" cdda2wav will not be built.
+ emake -j1 CPPOPTX="${CPPFLAGS}" COPTX="${CFLAGS}" C++OPTX="${CXXFLAGS}" \
+ LDOPTX="${LDFLAGS}" GMAKE_NOWARN="true"
+}
+
+src_install() {
+ # If not built with -j1, "sometimes" manpages are not installed.
+ emake -j1 CPPOPTX="${CPPFLAGS}" COPTX="${CFLAGS}" C++OPTX="${CXXFLAGS}" \
+ LDOPTX="${LDFLAGS}" GMAKE_NOWARN="true" install
+
+ # These symlinks are for compat with cdrkit.
+ dosym schily /usr/include/scsilib
+ dosym ../scg /usr/include/schily/scg
+
+ dodoc ABOUT Changelog* CONTRIBUTING PORTING README.linux-shm READMEs/README.linux
+
+ cd "${S}"/cdda2wav || die
+ docinto cdda2wav
+ dodoc Changelog FAQ Frontends HOWTOUSE NEEDED README THANKS TODO
+
+ cd "${S}"/mkisofs || die
+ docinto mkisofs
+ dodoc ChangeLog* TODO
+
+ # Remove man pages related to the build system
+ rm -rvf "${ED}"/usr/share/man/man5 || die
+ if use schily-tools
+ then rm -rvf "${ED}"/usr/$(get_libdir)/libschily* || die
+ rm -rvf "${ED}"/usr/$(get_libdir)/libfind* || die
+ rm -rvf "${ED}"/usr/$(get_libdir)/libmdigest* || die
+ fi
+}
+
+pkg_postinst() {
+ fcaps_pkg_postinst
+
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ einfo
+ einfo "Darwin/OS X use the following device names:"
+ einfo
+ einfo "CD burners: (probably) ./cdrecord dev=IOCompactDiscServices"
+ einfo
+ einfo "DVD burners: (probably) ./cdrecord dev=IODVDServices"
+ einfo
+ fi
+}
diff --git a/app-cdr/cdrtools/files/cdrtools-fix-clone-uclibc.patch b/app-cdr/cdrtools/files/cdrtools-fix-clone-uclibc.patch
new file mode 100644
index 00000000..9ffd28a5
--- /dev/null
+++ b/app-cdr/cdrtools/files/cdrtools-fix-clone-uclibc.patch
@@ -0,0 +1,69 @@
+diff -Naur cdrtools-3.02.orig/readcd/readcd.c cdrtools-3.02/readcd/readcd.c
+--- cdrtools-3.02.orig/readcd/readcd.c 2016-01-24 11:15:19.000000000 -0500
++++ cdrtools-3.02/readcd/readcd.c 2016-04-09 12:29:54.727635502 -0400
+@@ -257,7 +257,7 @@
+ BOOL pifscan;
+ BOOL plot;
+ BOOL fulltoc;
+-BOOL clone;
++BOOL clonetoc;
+ BOOL edc_corr;
+ BOOL noerror;
+ BOOL nocorr;
+@@ -294,7 +294,7 @@
+ error(_("\t-plot Print data suitable for gnuplot\n"));
+ #ifdef CLONE_WRITE
+ error(_("\t-fulltoc Retrieve the full TOC\n"));
+- error(_("\t-clone Retrieve the full TOC and all data\n"));
++ error(_("\t-clonetoc Retrieve the full TOC and all data\n"));
+ error(_("\t-edc-corr Try to do user level Reed Solomon repair (experimental)\n"));
+ #endif
+ error(_("\ttimeout=# set the default SCSI command timeout to #.\n"));
+@@ -320,7 +320,7 @@
+ }
+
+ /* CSTYLED */
+-char opts[] = "debug#,d+,kdebug#,kd#,timeout#,quiet,q,verbose+,v+,Verbose+,V+,x+,xd#,silent,s,help,h,version,scanbus,dev*,scgopts*,sectors*,w,c2scan,cxscan,pi8scan,pifscan,plot,fulltoc,clone,edc-corr,noerror,nocorr,notrunc,retries#,factor,f*,speed#,ts&,overhead,meshpoints#";
++char opts[] = "debug#,d+,kdebug#,kd#,timeout#,quiet,q,verbose+,v+,Verbose+,V+,x+,xd#,silent,s,help,h,version,scanbus,dev*,scgopts*,sectors*,w,c2scan,cxscan,pi8scan,pifscan,plot,fulltoc,clonetoc,edc-corr,noerror,nocorr,notrunc,retries#,factor,f*,speed#,ts&,overhead,meshpoints#";
+
+ EXPORT int
+ main(ac, av)
+@@ -397,7 +397,7 @@
+ &scanbus, &dev, &scgopts, &sectors, &do_write,
+ &c2scan, &cxscan, &pi8scan, &pifscan,
+ &plot,
+- &fulltoc, &clone,
++ &fulltoc, &clonetoc,
+ &edc_corr,
+ &noerror, &nocorr,
+ &notrunc, &retries, &do_factor, &filename,
+@@ -679,7 +679,7 @@
+
+ if (filename || sectors || c2scan || cxscan || pi8scan || pifscan ||
+ meshpoints || fulltoc ||
+- clone || edc_corr) {
++ clonetoc || edc_corr) {
+ dorw(scgp, filename, sectors);
+ } else {
+ doit(scgp);
+@@ -894,9 +894,9 @@
+ if (params.name == NULL)
+ params.name = "/dev/null";
+ read_ftoc(scgp, &params, FALSE);
+- } else if (clone || edc_corr) {
++ } else if (clonetoc || edc_corr) {
+ if (!is_mmc(scgp, NULL, NULL))
+- comerrno(EX_BAD, _("Unsupported device for clone mode.\n"));
++ comerrno(EX_BAD, _("Unsupported device for clonetoc mode.\n"));
+ if (!edc_corr)
+ noerror = TRUE;
+ if (retries == MAX_RETRY)
+@@ -904,7 +904,7 @@
+ if (params.name == NULL)
+ params.name = "/dev/null";
+
+- if (clone)
++ if (clonetoc)
+ if (read_ftoc(scgp, &params, TRUE) < 0)
+ comerrno(EX_BAD, _("Read fulltoc problems.\n"));
+ readcd_disk(scgp, &params);
diff --git a/app-cdr/cdrtools/metadata.xml b/app-cdr/cdrtools/metadata.xml
new file mode 100644
index 00000000..65a11963
--- /dev/null
+++ b/app-cdr/cdrtools/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ <description>maintainer of the updates in the mv overlay</description>
+ </maintainer>
+ <maintainer type="person">
+ <email>billie@gentoo.org</email>
+ <name>Daniel Pielmeier</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>joerg.schilling@fokus.fraunhofer.de</email>
+ <name>Jörg Schilling</name>
+ </maintainer>
+ <remote-id type="sourceforge">cdrtools</remote-id>
+ </upstream>
+ <use>
+ <flag name="schily-tools">Use libschily from app-shells/schily-tools</flag>
+ </use>
+ <longdescription>CD and DVD command line recording and ripping tools.</longdescription>
+</pkgmetadata>
diff --git a/app-shells/schily-tools/Manifest b/app-shells/schily-tools/Manifest
index a68bc25b..3708264c 100644
--- a/app-shells/schily-tools/Manifest
+++ b/app-shells/schily-tools/Manifest
@@ -1 +1,2 @@
DIST schily-2017-09-25.tar.bz2 4182173 SHA256 21304d26b4f12b66c1879113a7cde5fe8d181ac707873167c867624d18827e3f SHA512 79b532f2ed0332f69edbd2dbe83e4acfdff5b4cfc0f8ade341ee0289375d824e3ad19816e3fc25ef3a108ffa8b9437000bd55f68c41bb187d45455c573fc316a
+DIST schily-2017-10-10.tar.bz2 4184991 SHA256 37fa539d8fd030616a977522f7a269e3a5474d5178d6d29433fb030c0a06a6c2 SHA512 16053974c85f56a90bfe967d25ca35a30a39ed07a70f48033f93f0b6476b6b7fd07fc0bf50ed3c32ec5a1b4385fc2cc1c7b5e86f88e22a7b5dcd1def2103d411
diff --git a/app-shells/schily-tools/metadata.xml b/app-shells/schily-tools/metadata.xml
index db7f14dc..c553ee01 100644
--- a/app-shells/schily-tools/metadata.xml
+++ b/app-shells/schily-tools/metadata.xml
@@ -11,6 +11,7 @@
<flag name="renameschily_count">Rename count to scount for compatibility with sys-devel/llvm</flag>
<flag name="renameschily_jsh">Rename jsh to sjsh for compatibility with app-shells/heirloom-sh</flag>
<flag name="renameschily_man2html">Rename man2html to sman2html for compatibility with sys-apps/man</flag>
+ <flag name="renameschily_libschily">Rename some manpages from libschily for compatibility with sys-apps/man</flag>
<flag name="renameschily_p">Rename p to sp for compatibility with dev-util/wiggle</flag>
<flag name="schilytools_bosh">Install bosh, a shell which aims to be fully POSIX compatible</flag>
<flag name="schilytools_calc">Install calc, a bc clone</flag>
diff --git a/app-shells/schily-tools/schily-tools-2017.10.10.ebuild b/app-shells/schily-tools/schily-tools-2017.10.10.ebuild
new file mode 100644
index 00000000..2e71116a
--- /dev/null
+++ b/app-shells/schily-tools/schily-tools-2017.10.10.ebuild
@@ -0,0 +1,410 @@
+# Copyright 2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+RESTRICT="mirror"
+inherit flag-o-matic gnuconfig toolchain-funcs
+
+MY_PV=${PV//./-}
+MY_P="schily-${MY_PV}"
+MY_P_TAR="${MY_P}.tar.bz2"
+S=${WORKDIR}/${MY_P}
+
+SRC_URI="mirror://sourceforge/schilytools/${MY_P}.tar.bz2"
+#mirror://sourceforge/schilytools/${MY_P}.patch"
+DESCRIPTION="Many tools from Joerg Schilling, including a POSIX compliant Bourne Shell"
+HOMEPAGE="https://sourceforge.net/projects/schilytools/"
+KEYWORDS="~amd64 ~x86"
+IUSE="acl caps doc static-libs system-libschily system-star xattr"
+REQUIRED_USE="!system-libschily"
+
+#PATCHES=(-p0 "$DISTDIR"/${MY_P}.patch)
+
+add_iuse_expand() {
+ local i j
+ j=${1}
+ shift
+ for i
+ do case ${i} in
+ +*)
+ IUSE=${IUSE}" +${j}_${i#?}";;
+ *)
+ IUSE=${IUSE}" ${j}_${i}";;
+ esac
+ done
+}
+add_iuse_expand renameschily \
+ +calc +compare +count +jsh +libschily +man2html +p
+add_iuse_expand schilytools \
+ +bosh +calc +calltree +change +compare +copy +count +cpp +cstyle +cut \
+ +hdump label +lndir +man2html manmake +match +mdigest mountcd osh \
+ +p +paste +patch pxupgrade +sccs +sfind +smake \
+ +termcap +translit +udiff +ved
+
+COMMON="system-libschily? ( app-cdr/cdrtools )
+!system-libschily? ( !app-cdr/cdrtools[-schily-tools(-)] )
+schilytools_match? (
+ system-star? ( app-arch/star )
+ !system-star? ( !app-arch/star )
+)
+schilytools_calc? (
+ !renameschily_calc? ( !sci-mathematics/calc )
+)
+schilytools_compare? (
+ !renameschily_compare? (
+ !media-gfx/imagemagick !media-gfx/graphicsmagick[imagemagick]
+ )
+)
+schilytools_count? (
+ !renameschily_count? ( !sys-devel/llvm )
+)
+schilytools_bosh? (
+ !renameschily_jsh? ( !app-shells/heirloom-sh )
+)
+schilytools_man2html? (
+ !renameschily_man2html? ( !sys-apps/man )
+)
+!system-libschily? (
+ !renameschily_libschily? ( !sys-apps/man )
+)
+schilytools_p? (
+ !renameschily_p? ( !dev-util/wiggle )
+)
+schilytools_translit? ( !dev-perl/Lingua-Translit )
+acl? ( virtual/acl )
+caps? ( sys-libs/libcap )
+xattr? ( sys-apps/attr )"
+DEPEND="${COMMON}"
+RDEPEND="${COMMON}"
+LICENSE="GPL-2 LGPL-2.1 CDDL-Schily"
+SLOT="0"
+
+# Lot of this code is taken from app-cdr/cdrtools
+
+cdrtools_os() {
+ local os="linux"
+ [[ ${CHOST} == *-darwin* ]] && os="mac-os10"
+ [[ ${CHOST} == *-freebsd* ]] && os="freebsd"
+ echo "${os}"
+}
+
+src_schily_prepare() (
+ gnuconfig_update
+
+ # Remove profiled make files.
+ find -name '*_p.mk' -delete || die "delete *_p.mk"
+
+ # Adjusting hardcoded paths.
+ sed -i -e "s|opt/schily|usr|" \
+ $(find ./ -type f -name \*.[0-9ch] -exec grep -l 'opt/schily' '{}' '+') \
+ || die "sed opt/schily"
+
+ sed -i -e "s|\(^INSDIR=\t\tshare/doc/\)|\1${PF}/|" \
+ $(find ./ -type f -exec grep -l '^INSDIR.\+doc' '{}' '+') \
+ || die "sed doc"
+
+ # Respect libdir.
+ sed -i -e "s|\(^INSDIR=\t\t\)lib|\1$(get_libdir)|" \
+ $(find ./ -type f -exec grep -l '^INSDIR.\+lib\(/\(siconv\)\?\)\?$' '{}' '+') \
+ || die "sed multilib"
+
+ # Respect libdir for defaults.smk
+ sed -i -e "s|/lib/|/$(get_libdir)/|" \
+ smake/Makefile \
+ || die "sed multilib for smake"
+
+ # Enable verbose build.
+ sed -i -e '/@echo.*==>.*;/s:@echo[^;]*;:&set -x;:' \
+ RULES/*.rul RULES/rules.prg RULES/rules.inc \
+ || die "sed verbose rules"
+
+ # Respect CC/CXX variables.
+ cd "${S}"/RULES || die
+ local tcCC=$(tc-getCC)
+ local tcCXX=$(tc-getCXX)
+ sed -i -e "/cc-config.sh/s|\$(C_ARCH:%64=%) \$(CCOM_DEF)|${tcCC} ${tcCC}|" \
+ rules1.top || die "sed rules1.top"
+ sed -i -e "/^CC_COM_DEF=/s|gcc|${tcCC}|" \
+ -e "/^CC++_COM_DEF=/s|g++|${tcCXX}|" \
+ -e "/COPTOPT=/s|-O||" \
+ -e 's|$(GCCOPTOPT)||' \
+ cc-gcc.rul || die "sed cc-gcc.rul"
+ sed -i -e "s|^#\(CONFFLAGS +=\).*|\1\t-cc=${tcCC}|" \
+ rules.cnf || die "sed rules.cnf"
+
+ # Schily make setup.
+ cd "${S}"/DEFAULTS || die
+ local os=$(cdrtools_os)
+
+ sed -i \
+ -e "s|^\(DEFLINKMODE=\).*|\1\tdynamic|" \
+ -e "s|^\(LINUX_INCL_PATH=\).*|\1|" \
+ -e "s|^\(LDPATH=\).*|\1|" \
+ -e "s|^\(RUNPATH=\).*|\1|" \
+ -e "s|^\(INS_BASE=\).*|\1\t${ED}usr|" \
+ -e "s|^\(INS_RBASE=\).*|\1\t${ED}|" \
+ -e "s|^\(DEFINSGRP=\).*|\1\t0|" \
+ -e '/^DEFUMASK/s,002,022,g' \
+ Defaults.${os} || die "sed Schily make setup"
+)
+
+targets=""
+
+targets() {
+ local i
+ for i
+ do case " ${targets} " in
+ *" ${i} "*)
+ continue;;
+ esac
+ mv -v UNUSED_TARGETS/??"${i}" TARGETS || die
+ targets=${targets}${targets:+\ }${i}
+ done
+}
+
+src_prepare() {
+ default
+ filter-flags -fPIE -pie -flto* -fwhole-program -fno-common
+ src_schily_prepare
+ sed -i -e '1s!man1/sh\.1!man1/bosh.1!' -- "${S}/sh/"{jsh,pfsh}.1 || die
+ sed -i \
+ -e '/-DDO_POSIX_SH/s/^[#]//' \
+ -e '/-DDO_POSIX_PATH/s/^/\#/' \
+ -e '/[+][=] -DPOSIX_BOSH_PATH/iCPPOPTS += -DPOSIX_BOSH_PATH=\\"'"${EPREFIX}"'/bin/sh\\"' \
+ -- "${S}/sh/"Makefile || die
+ mkdir UNUSED_TARGETS || die
+ mv TARGETS/[0-9][0-9]* UNUSED_TARGETS || die
+ targets inc
+ use system-libschily || targets include libschily libfind libmdigest
+ ! use schilytools_bosh || targets sh libxtermcap libshedit libgetopt
+ ! use schilytools_calc || targets calc
+ ! use schilytools_calltree || targets calltree
+ ! use schilytools_change || targets change
+# nonexistent:
+# ! use schilytools_cmd || targets cmd
+ ! use schilytools_compare || targets compare
+ ! use schilytools_copy || targets copy
+ ! use schilytools_count || targets count
+ ! use schilytools_cpp || targets cpp
+ ! use schilytools_cstyle || targets cstyle
+ ! use schilytools_cut || targets cut
+ ! use schilytools_hdump || targets hdump
+ ! use schilytools_label || targets label
+ ! use schilytools_lndir || targets lndir
+ ! use schilytools_man2html || targets man2html
+ ! use schilytools_manmake || targets man
+ ! use schilytools_match || targets match
+ ! use schilytools_mdigest || targets mdigest
+ ! use schilytools_mountcd || targets mountcd
+ ! use schilytools_osh || targets osh libgetopt
+ ! use schilytools_p || targets p libxtermcap
+ ! use schilytools_paste || targets paste
+ ! use schilytools_patch || targets patch
+ ! use schilytools_pxupgrade || targets pxupgrade
+ ! use schilytools_sccs || targets sccs libgetopt
+ ! use schilytools_sfind || targets sfind
+ ! use schilytools_smake || targets smake
+ ! use schilytools_termcap || targets termcap libxtermcap
+ ! use schilytools_translit || targets translit
+ ! use schilytools_udiff || targets udiff
+ ! use schilytools_ved || targets ved libxtermcap
+ eapply_user
+}
+
+ac_cv_sizeof() {
+ cat <<-EOF >"${T}"/test.c
+ #include <inttypes.h>
+ #include <stddef.h>
+ #include <stdint.h>
+ #include <sys/types.h>
+ int main () {
+ static int test_array [1 - 2 * !((sizeof(TYPE)) == LEN)];
+ test_array [0] = 0;
+ return test_array [0];
+ }
+ EOF
+
+ local i=1
+ while [[ ${i} -lt 20 ]] ; do
+ if ${CC} ${CPPFLAGS} ${CFLAGS} -c "${T}"/test.c -o /dev/null -DTYPE="$1" -DLEN=$i 2>/dev/null; then
+ echo ${i}
+ return 0
+ fi
+ : $(( i += 1 ))
+ done
+ return 1
+}
+
+src_configure() {
+ use acl || export ac_cv_header_sys_acl_h="no"
+ use caps || export ac_cv_lib_cap_cap_get_proc="no"
+ use xattr || export ac_cv_header_attr_xattr_h="no"
+
+ # skip obsolete configure script
+ if tc-is-cross-compiler ; then
+ # Cache known values for targets. #486680
+
+ tc-export CC
+ local var val t types=(
+ char "short int" int "long int" "long long"
+ "unsigned char" "unsigned short int" "unsigned int"
+ "unsigned long int" "unsigned long long"
+ float double "long double" size_t ssize_t ptrdiff_t
+ mode_t uid_t gid_t pid_t dev_t time_t wchar_t
+ "char *" "unsigned char *"
+ )
+ for t in "${types[@]}" ; do
+ var="ac_cv_sizeof_${t// /_}"
+ var=${var//[*]/p}
+ val=$(ac_cv_sizeof "${t}") || die "could not compute ${t}"
+ export "${var}=${val}"
+ einfo "Computing sizeof(${t}) as ${val}"
+ done
+ # We don't have these types.
+ export ac_cv_sizeof___int64=0
+ export ac_cv_sizeof_unsigned___int64=0
+ export ac_cv_sizeof_major_t=${ac_cv_sizeof_dev_t}
+ export ac_cv_sizeof_minor_t=${ac_cv_sizeof_dev_t}
+ export ac_cv_sizeof_wchar=${ac_cv_sizeof_wchar_t}
+
+ export ac_cv_type_prototypes="yes"
+ export ac_cv_func_mlock{,all}="yes"
+ export ac_cv_func_{e,f,g}cvt=$(usex elibc_glibc)
+ export ac_cv_func_dtoa_r="no"
+ export ac_cv_func_sys_siglist{,_def}="no"
+ export ac_cv_func_printf_{j,ll}="yes"
+ export ac_cv_realloc_null="yes"
+ export ac_cv_no_user_malloc="no"
+ export ac_cv_var_timezone="yes"
+ export ac_cv_var___progname{,_full}="yes"
+ export ac_cv_fnmatch_igncase="yes"
+ export ac_cv_file__dev_{fd_{0,1,2},null,std{err,in,out},tty,zero}="yes"
+ export ac_cv_file__usr_src_linux_include="no"
+
+ case $(cdrtools_os) in
+ linux)
+ export ac_cv_func_bsd_{g,s}etpgrp="no"
+ export ac_cv_hard_symlinks="yes"
+ export ac_cv_link_nofollow="yes"
+ export ac_cv_access_e_ok="no"
+
+ export ac_cv_dev_minor_noncontig="yes"
+ case ${ac_cv_sizeof_long_int} in
+ 4) export ac_cv_dev_minor_bits="32";;
+ 8) export ac_cv_dev_minor_bits="44";;
+ esac
+
+ cat <<-EOF >"${T}"/test.c
+ struct {
+ char start[6];
+ unsigned char x1:4;
+ unsigned char x2:4;
+ char end[5];
+ } a = {
+ .start = {'S', 't', 'A', 'r', 'T', '_'},
+ .x1 = 5,
+ .x2 = 4,
+ .end = {'_', 'e', 'N', 'd', 'X'},
+ };
+ EOF
+ ${CC} ${CPPFLAGS} ${CFLAGS} -c "${T}"/test.c -o "${T}"/test.o
+ if grep -q 'StArT_E_eNdX' "${T}"/test.o ; then
+ export ac_cv_c_bitfields_htol="no"
+ elif grep -q 'StArT_T_eNdX' "${T}"/test.o ; then
+ export ac_cv_c_bitfields_htol="yes"
+ fi
+ ;;
+ esac
+ fi
+ cd psmake || die
+}
+
+src_compile() {
+ emake -j1 CPPOPTX="${CPPFLAGS}" COPTX="${CFLAGS}" C++OPTX="${CXXFLAGS}" \
+ LDOPTX="${LDFLAGS}" GMAKE_NOWARN="true"
+}
+
+mustnothave() {
+ local i
+ for i
+ do test -r "${ED}${i}" && die "${ED}${i} must not exist"
+ done
+}
+
+mustremove() {
+ local i
+ for i
+ do test -r "${ED}${i}" && rm -v -- "${ED}${i}" || \
+ die "cannot remove ${ED}${i}"
+ done
+}
+
+src_install() {
+ local i
+ ! use doc || dodoc -r Schily.Copyright README.SSPM PORTING CONTRIBUTING \
+ AN-????-??-?? ANNOUNCEMENTS
+ emake -j1 CPPOPTX="${CPPFLAGS}" COPTX="${CFLAGS}" C++OPTX="${CXXFLAGS}" \
+ LDOPTX="${LDFLAGS}" GMAKE_NOWARN="true" install
+ if ! use static-libs
+ then find "${ED}" -name '*.a' -delete || die
+ ! test -d "${ED}"/usr/include || rm -rfv -- "${ED}"/usr/include || die
+ fi
+ if use schilytools_sccs
+ then mv -v "${ED}"/usr/share/man/man1/{,sccs-}diff.1 || die
+ else ! test -d "${ED}"/usr/ccs || rm -rfv -- "${ED}"/usr/ccs || die
+ mustnothave usr/share/man/man1/diff.1
+ fi
+ if use schilytools_hdump
+ then mustremove usr/bin/od usr/share/man/man1/od.1
+ else mustnothave usr/bin/od usr/share/man/man1/od.1
+ fi
+ if use schilytools_patch
+ then mustremove usr/share/man/man1/patch.1
+ else mustnothave usr/share/man/man1/patch.1
+ fi
+ if use schilytools_bosh
+ then dodir bin || die
+ rm -v "${ED}"/usr/bin/{bo,j,pf}sh \
+ "${ED}"/usr/share/man/man1/bosh.1 || die
+ rm -rfv "${ED}"/usr/xpg4 || die
+ mv -v -- "${ED}"/{usr/bin/sh,bin/bosh} || die
+ ln -s -- bosh "${ED}"/bin/jsh || die
+ ln -s -- bosh "${ED}"/bin/pfsh || die
+ mv -v -- "${ED}"/usr/share/man/man1/{,bo}sh.1 || die
+ if use renameschily_jsh
+ then mv -v -- "${ED}"/bin/{,s}jsh || die
+ mv -v -- "${ED}"/usr/share/man/man1/{,s}jsh.1 || die
+ fi
+ fi
+ if use schilytools_match && use system-star
+ then rm -v -- "${ED}"/usr/share/man/man1/match.1 || die
+ fi
+ if use schilytools_calc && use renameschily_calc
+ then mv -v -- "${ED}"/usr/bin/{,s}calc || die
+ mv -v -- "${ED}"/usr/share/man/man1/{,s}calc.1 || die
+ fi
+ if use schilytools_compare && use renameschily_compare
+ then mv -v -- "${ED}"/usr/bin/{,s}compare || die
+ mv -v -- "${ED}"/usr/share/man/man1/{,s}compare.1 || die
+ fi
+ if use schilytools_count && use renameschily_count
+ then mv -v -- "${ED}"/usr/bin/{,s}count || die
+ mv -v -- "${ED}"/usr/share/man/man1/{,s}count.1 || die
+ fi
+ if use schilytools_man2html && use renameschily_man2html
+ then mv -v -- "${ED}"/usr/bin/{,s}man2html || die
+ mv -v -- "${ED}"/usr/share/man/man1/{,s}man2html.1 || die
+ fi
+ if use schilytools_p && use renameschily_p
+ then mv -v -- "${ED}"/usr/bin/{,s}p || die
+ mv -v -- "${ED}"/usr/share/man/man1/{,s}p.1 || die
+ fi
+ if use schilytools_ved
+ then docompress -x /usr/share/man/help
+ fi
+ if ! use system-libschily && use renameschily_libschily
+ then for i in error fexecve fnmatch getline printf strlen
+ do mv -- "${ED}"/usr/share/man/man3/{,s}${i}.3 || die
+ done
+ fi
+}
diff --git a/metadata/pkg_desc_index b/metadata/pkg_desc_index
index 53782b15..baa3dcba 100644
--- a/metadata/pkg_desc_index
+++ b/metadata/pkg_desc_index
@@ -6,6 +6,7 @@ app-arch/archwrap 8.0: A collection of POSIX shell scripts to invoke archiver pr
app-arch/brotli 1.0.1: Generic-purpose lossless compression algorithm
app-arch/bzwc 5.0: A POSIX shell wrapper for wc, supporting compressed files (xz, lzma, bz2, gz)
app-arch/paq8l 20070308: Open source file compressor and archiver
+app-cdr/cdrtools 3.02_alpha07-r1: A set of tools for CD/DVD reading and recording, including cdrecord
app-dicts/ispell-de 20161207: German and Swiss dictionaries for ispell
app-dicts/ispell-de-alt 2-r1: German dictionary (traditional orthography) for ispell
app-dicts/stardict-dictd-BritannicaConcise 2.4.2: Stardict Dictionary for Dictd.org's The Britannica Concise Encyclopedia
@@ -41,7 +42,7 @@ app-shells/oh-my-zsh 99999999: A ready-to-use zsh configuration with plugins
app-shells/push 3.0-r1: A POSIX shell function to treat a variable like an array, quoting args
app-shells/quoter 4.0-r1: Quote arguments or standard input for usage in POSIX shell by eval
app-shells/runtitle 2.10: Scripts to run commands and set the hard status line (windows title)
-app-shells/schily-tools 2017.09.25: Many tools from Joerg Schilling, including a POSIX compliant Bourne Shell
+app-shells/schily-tools 2017.09.25 2017.10.10: Many tools from Joerg Schilling, including a POSIX compliant Bourne Shell
app-shells/set_prompt 3.0.0: An intelligent prompt for zsh or bash with status line (window title) support
app-shells/termcolors-mv 4.6: 256colors sample script and dircolors configuration for standard or 256 colors
app-shells/zsh-syntax-highlighting 0.6.0 99999999: Fish shell like syntax highlighting for zsh
diff --git a/profiles/use.local.desc b/profiles/use.local.desc
index ff03b2f3..637035b8 100644
--- a/profiles/use.local.desc
+++ b/profiles/use.local.desc
@@ -3,6 +3,7 @@
# * generated automatically using egencache *
app-admin/checksec:update - Support self-update functionality outside of the package-manager
+app-cdr/cdrtools:schily-tools - Use libschily from app-shells/schily-tools
app-portage/eix:debug - Build with upstream's CXXFLAGS/LDFLAGS for debugging support; not recommended for normal use.
app-portage/eix:dep - Make DEP=true the default which enables support for {,R,P}DEPEND but requires roughly double disk and memory.
app-portage/eix:doc - Create description of the eix cache file additionally in html format
@@ -27,6 +28,7 @@ app-shells/schily-tools:renameschily_calc - Rename calc to scalc for compatibili
app-shells/schily-tools:renameschily_compare - Rename compare to scompare for compatibility with imagemagick
app-shells/schily-tools:renameschily_count - Rename count to scount for compatibility with sys-devel/llvm
app-shells/schily-tools:renameschily_jsh - Rename jsh to sjsh for compatibility with app-shells/heirloom-sh
+app-shells/schily-tools:renameschily_libschily - Rename some manpages from libschily for compatibility with sys-apps/man
app-shells/schily-tools:renameschily_man2html - Rename man2html to sman2html for compatibility with sys-apps/man
app-shells/schily-tools:renameschily_p - Rename p to sp for compatibility with dev-util/wiggle
app-shells/schily-tools:schilytools_bosh - Install bosh, a shell which aims to be fully POSIX compatible