summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-portage/eix/eix-0.33.0.ebuild16
-rw-r--r--app-portage/eix/eix-0.33.0_alpha1.ebuild16
-rw-r--r--app-portage/eix/eix-99999999.ebuild16
-rw-r--r--metadata/pkg_desc_index2
4 files changed, 46 insertions, 4 deletions
diff --git a/app-portage/eix/eix-0.33.0.ebuild b/app-portage/eix/eix-0.33.0.ebuild
index 0321969e..401bdef1 100644
--- a/app-portage/eix/eix-0.33.0.ebuild
+++ b/app-portage/eix/eix-0.33.0.ebuild
@@ -32,11 +32,25 @@ pkg_setup() {
# remove stale cache file to prevent collisions
local old_cache="${EROOT}var/cache/${PN}"
test -f "${old_cache}" && rm -f -- "${old_cache}"
+
+ local i
+ if use meson && use strong-optimization
+ then for i in /usr/*/binutils-bin/lib/bfd-plugins/liblto_plugin.*
+ do test -h "$i" && return
+ done
+ fi
+ eerror "app-portage/eix[meson strong-optimization]' needs linker lto plugin."
+ eerror "To establish this plugin, execute as root something like"
+ eerror " mkdir -p /usr/*/binutils-bin/lib/bfd-plugins"
+ eerror " cd /usr/*/binutils-bin/lib/bfd-plugins"
+ eerror " ln -sfn /usr/libexec/gcc/*/*/liblto_plugin.so.*.*.* ."
+ eerror "The * might have to be replaced by your architecture or gcc version"
+ die "app-portage/eix[meson strong-optimization] needs linker lto plugin"
}
src_prepare() {
sed -i -e "s'/'${EPREFIX}/'" -- "${S}"/tmpfiles.d/eix.conf || die
- eapply_user
+ default
}
src_configure() {
diff --git a/app-portage/eix/eix-0.33.0_alpha1.ebuild b/app-portage/eix/eix-0.33.0_alpha1.ebuild
index b3198734..8251e5e2 100644
--- a/app-portage/eix/eix-0.33.0_alpha1.ebuild
+++ b/app-portage/eix/eix-0.33.0_alpha1.ebuild
@@ -47,11 +47,25 @@ pkg_setup() {
# remove stale cache file to prevent collisions
local old_cache="${EROOT}var/cache/${PN}"
test -f "${old_cache}" && rm -f -- "${old_cache}"
+
+ local i
+ if use meson && use strong-optimization
+ then for i in /usr/*/binutils-bin/lib/bfd-plugins/liblto_plugin.*
+ do test -h "$i" && return
+ done
+ fi
+ eerror "app-portage/eix[meson strong-optimization]' needs linker lto plugin."
+ eerror "To establish this plugin, execute as root something like"
+ eerror " mkdir -p /usr/*/binutils-bin/lib/bfd-plugins"
+ eerror " cd /usr/*/binutils-bin/lib/bfd-plugins"
+ eerror " ln -sfn /usr/libexec/gcc/*/*/liblto_plugin.so.*.*.* ."
+ eerror "The * might have to be replaced by your architecture or gcc version"
+ die "app-portage/eix[meson strong-optimization] needs linker lto plugin"
}
src_prepare() {
sed -i -e "s'/'${EPREFIX}/'" -- "${S}"/tmpfiles.d/eix.conf || die
- eapply_user
+ default
use meson || {
eautopoint
eautoreconf
diff --git a/app-portage/eix/eix-99999999.ebuild b/app-portage/eix/eix-99999999.ebuild
index b3198734..8251e5e2 100644
--- a/app-portage/eix/eix-99999999.ebuild
+++ b/app-portage/eix/eix-99999999.ebuild
@@ -47,11 +47,25 @@ pkg_setup() {
# remove stale cache file to prevent collisions
local old_cache="${EROOT}var/cache/${PN}"
test -f "${old_cache}" && rm -f -- "${old_cache}"
+
+ local i
+ if use meson && use strong-optimization
+ then for i in /usr/*/binutils-bin/lib/bfd-plugins/liblto_plugin.*
+ do test -h "$i" && return
+ done
+ fi
+ eerror "app-portage/eix[meson strong-optimization]' needs linker lto plugin."
+ eerror "To establish this plugin, execute as root something like"
+ eerror " mkdir -p /usr/*/binutils-bin/lib/bfd-plugins"
+ eerror " cd /usr/*/binutils-bin/lib/bfd-plugins"
+ eerror " ln -sfn /usr/libexec/gcc/*/*/liblto_plugin.so.*.*.* ."
+ eerror "The * might have to be replaced by your architecture or gcc version"
+ die "app-portage/eix[meson strong-optimization] needs linker lto plugin"
}
src_prepare() {
sed -i -e "s'/'${EPREFIX}/'" -- "${S}"/tmpfiles.d/eix.conf || die
- eapply_user
+ default
use meson || {
eautopoint
eautoreconf
diff --git a/metadata/pkg_desc_index b/metadata/pkg_desc_index
index 3cf816b4..be79b404 100644
--- a/metadata/pkg_desc_index
+++ b/metadata/pkg_desc_index
@@ -41,7 +41,7 @@ app-shells/oh-my-zsh 99999999: A ready-to-use zsh configuration with plugins
app-shells/push 3.0: A POSIX shell function to treat a variable like an array, quoting args
app-shells/quoter 4.0: Quote arguments or standard input for usage in POSIX shell by eval
app-shells/runtitle 2.10: Scripts to run commands and set the hard status line (windows title)
-app-shells/schily-tools 2017.08.14: Many tools from Joerg Schilling, including a POSIX compliant Bourne Shell
+app-shells/schily-tools 2017.08.14-r1: Many tools from Joerg Schilling, including a POSIX compliant Bourne Shell
app-shells/set_prompt 3.0.0: An intelligent prompt for zsh or bash with status line (window title) support
app-shells/termcolors-mv 4.1: 256colors sample script and dircolors configuration for standard or 256 colors
app-shells/zsh 5.4.1 99999999: UNIX Shell similar to the Korn shell