summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--metadata/pkg_desc_index4
-rw-r--r--x11-libs/gtk+/Manifest1
-rw-r--r--x11-libs/gtk+/gtk+-3.22.16.ebuild2
-rw-r--r--x11-libs/gtk+/gtk+-3.22.17.ebuild236
4 files changed, 240 insertions, 3 deletions
diff --git a/metadata/pkg_desc_index b/metadata/pkg_desc_index
index 5e997bbf..796f9238 100644
--- a/metadata/pkg_desc_index
+++ b/metadata/pkg_desc_index
@@ -93,7 +93,7 @@ net-misc/openrdate 1.2: use TCP or UDP to retrieve the current time of another m
net-misc/sshstart 3.00: Start ssh-agent/ssh-add only if you really use ssh or friends
net-print/foo2zjs 20160722: Support for printing to ZjStream-based printers
sci-mathematics/genius 1.0.21: Genius Mathematics Tool and the GEL Language
-sci-mathematics/reduce 20141130-r1 20141130-r2: A general-purpose computer algebra system
+sci-mathematics/reduce 20141130-r2: A general-purpose computer algebra system
sys-apps/cpi 2.15: A wrapper for cp -i -a, making use of diff
sys-apps/less 487 497: Excellent text file viewer, optionally with additional selection feature
sys-apps/openrc-wrapper 2.2: Use openrc init scripts with systemd or other init systems
@@ -122,7 +122,7 @@ www-plugins/requestpolicy 0.5.28-r1: Mozilla plugin: controll cross-site request
www-plugins/shumway 0.11.394: Mozilla plugin: Flashplayer emulation with javascript and html5
www-plugins/xclear 1.8.2: Firefox plugin: button to clear URL
x11-drivers/nvidia-drivers 173.14.39-r2: NVIDIA Accelerated Graphics Driver
-x11-libs/gtk+ 2.24.31-r1 3.22.16: Gimp ToolKit +
+x11-libs/gtk+ 2.24.31-r1 3.22.16 3.22.17: Gimp ToolKit +
x11-libs/motif 2.3.6-r1: The Motif user interface component toolkit
x11-misc/redshift 1.8: A screen color temperature adjusting software
x11-wm/fvwm 2.6.5-r2 2.6.7-r1: An extremely powerful ICCCM-compliant multiple virtual desktop window manager
diff --git a/x11-libs/gtk+/Manifest b/x11-libs/gtk+/Manifest
index cc6ea758..5fa63f95 100644
--- a/x11-libs/gtk+/Manifest
+++ b/x11-libs/gtk+/Manifest
@@ -1,2 +1,3 @@
DIST gtk+-2.24.31.tar.xz 12805344 SHA256 68c1922732c7efc08df4656a5366dcc3afdc8791513400dac276009b40954658
DIST gtk+-3.22.16.tar.xz 18655144 SHA256 3e0c3ad01f3c8c5c9b1cc1ae00852bd55164c8e5a9c1f90ba5e07f14f175fe2c
+DIST gtk+-3.22.17.tar.xz 18702864 SHA256 a6c1fb8f229c626a3d9c0e1ce6ea138de7f64a5a6bc799d45fa286fe461c3437
diff --git a/x11-libs/gtk+/gtk+-3.22.16.ebuild b/x11-libs/gtk+/gtk+-3.22.16.ebuild
index 53ffc2eb..32d35231 100644
--- a/x11-libs/gtk+/gtk+-3.22.16.ebuild
+++ b/x11-libs/gtk+/gtk+-3.22.16.ebuild
@@ -17,7 +17,7 @@ REQUIRED_USE="
xinerama? ( X )
"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="alpha amd64 arm ~arm64 ~hppa ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
# Upstream wants us to do their job:
# https://bugzilla.gnome.org/show_bug.cgi?id=768662#c1
diff --git a/x11-libs/gtk+/gtk+-3.22.17.ebuild b/x11-libs/gtk+/gtk+-3.22.17.ebuild
new file mode 100644
index 00000000..53ffc2eb
--- /dev/null
+++ b/x11-libs/gtk+/gtk+-3.22.17.ebuild
@@ -0,0 +1,236 @@
+# Copyright 2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit autotools flag-o-matic gnome2 multilib virtualx multilib-minimal
+
+DESCRIPTION="Gimp ToolKit +"
+HOMEPAGE="http://www.gtk.org/"
+
+LICENSE="LGPL-2+"
+SLOT="3"
+IUSE="adwaita-icon-theme aqua atk-bridge broadway cloudprint colord cups debug examples +introspection test vim-syntax wayland +X xinerama"
+REQUIRED_USE="
+ || ( aqua wayland X )
+ xinerama? ( X )
+"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+# Upstream wants us to do their job:
+# https://bugzilla.gnome.org/show_bug.cgi?id=768662#c1
+RESTRICT="test"
+
+# FIXME: introspection data is built against system installation of gtk+:3,
+# bug #????
+COMMON_DEPEND="
+ >=dev-libs/atk-2.15[introspection?,${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.49.4:2[${MULTILIB_USEDEP}]
+ media-libs/fontconfig[${MULTILIB_USEDEP}]
+ >=media-libs/libepoxy-1.0[X(+)?,${MULTILIB_USEDEP}]
+ >=x11-libs/cairo-1.14[aqua?,glib,svg,X?,${MULTILIB_USEDEP}]
+ >=x11-libs/gdk-pixbuf-2.30:2[introspection?,${MULTILIB_USEDEP}]
+ >=x11-libs/pango-1.37.3[introspection?,${MULTILIB_USEDEP}]
+ x11-misc/shared-mime-info
+
+ cloudprint? (
+ >=net-libs/rest-0.7[${MULTILIB_USEDEP}]
+ >=dev-libs/json-glib-1.0[${MULTILIB_USEDEP}] )
+ colord? ( >=x11-misc/colord-0.1.9:0=[${MULTILIB_USEDEP}] )
+ cups? ( >=net-print/cups-1.2[${MULTILIB_USEDEP}] )
+ introspection? ( >=dev-libs/gobject-introspection-1.39:= )
+ wayland? (
+ >=dev-libs/wayland-1.9.91[${MULTILIB_USEDEP}]
+ >=dev-libs/wayland-protocols-1.7
+ media-libs/mesa[wayland,${MULTILIB_USEDEP}]
+ >=x11-libs/libxkbcommon-0.2[${MULTILIB_USEDEP}]
+ )
+ X? (
+ atk-bridge? ( >=app-accessibility/at-spi2-atk-2.5.3[${MULTILIB_USEDEP}] )
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ >=x11-libs/libXi-1.3[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ >=x11-libs/libXrandr-1.5[${MULTILIB_USEDEP}]
+ x11-libs/libXcursor[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes[${MULTILIB_USEDEP}]
+ x11-libs/libXcomposite[${MULTILIB_USEDEP}]
+ x11-libs/libXdamage[${MULTILIB_USEDEP}]
+ xinerama? ( x11-libs/libXinerama[${MULTILIB_USEDEP}] )
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xsl-stylesheets
+ app-text/docbook-xml-dtd:4.1.2
+ dev-libs/libxslt
+ dev-libs/gobject-introspection-common
+ >=dev-util/gdbus-codegen-2.48
+ >=dev-util/gtk-doc-am-1.20
+ >=sys-devel/gettext-0.19.7[${MULTILIB_USEDEP}]
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+ X? (
+ x11-proto/xextproto[${MULTILIB_USEDEP}]
+ x11-proto/xproto[${MULTILIB_USEDEP}]
+ x11-proto/inputproto[${MULTILIB_USEDEP}]
+ x11-proto/damageproto[${MULTILIB_USEDEP}]
+ xinerama? ( x11-proto/xineramaproto[${MULTILIB_USEDEP}] )
+ )
+ test? (
+ media-fonts/font-misc-misc
+ media-fonts/font-cursor-misc )
+"
+# gtk+-3.2.2 breaks Alt key handling in <=x11-libs/vte-0.30.1:2.90
+# gtk+-3.3.18 breaks scrolling in <=x11-libs/vte-0.31.0:2.90
+RDEPEND="${COMMON_DEPEND}
+ >=dev-util/gtk-update-icon-cache-3
+ !<gnome-base/gail-1000
+ !<x11-libs/vte-0.31.0:2.90
+ adwaita-icon-theme? ( >=x11-themes/adwaita-icon-theme-3.14 )
+ !adwaita-icon-theme? ( x11-themes/hicolor-icon-theme virtual/freedesktop-icon-theme )
+"
+# librsvg for svg icons (PDEPEND to avoid circular dep), bug #547710
+PDEPEND="
+ adwaita-icon-theme? ( gnome-base/librsvg[${MULTILIB_USEDEP}] )
+ vim-syntax? ( app-vim/gtk-syntax )
+"
+
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/gtk-query-immodules-3.0$(get_exeext)
+)
+
+strip_builddir() {
+ local rule=$1
+ shift
+ local directory=$1
+ shift
+ sed -e "s/^\(${rule} =.*\)${directory}\(.*\)$/\1\2/" -i $@ \
+ || die "Could not strip director ${directory} from build."
+}
+
+src_prepare() {
+ if ! use test ; then
+ # don't waste time building tests
+ strip_builddir SRC_SUBDIRS testsuite Makefile.{am,in}
+
+ # the tests dir needs to be build now because since commit
+ # 7ff3c6df80185e165e3bf6aa31bd014d1f8bf224 tests/gtkgears.o needs to be there
+ # strip_builddir SRC_SUBDIRS tests Makefile.{am,in}
+ fi
+
+ if ! use examples; then
+ # don't waste time building demos
+ strip_builddir SRC_SUBDIRS demos Makefile.{am,in}
+ strip_builddir SRC_SUBDIRS examples Makefile.{am,in}
+ fi
+
+ # gtk-update-icon-cache is installed by dev-util/gtk-update-icon-cache
+ eapply "${FILESDIR}"/${PN}-3.22.2-update-icon-cache.patch
+
+ # Use patches from BSD to make gtk3-atk-bridge a true option -
+ # This was intentionally removed by upstream, see
+ # https://mail.gnome.org/archives/commits-list/2012-June/msg03813.html
+ eapply "${FILESDIR}"/${PN}-atk-bridge-config.ac.patch
+ eapply "${FILESDIR}"/${PN}-atk-bridge-config.h.in.patch
+ eapply "${FILESDIR}"/${PN}-atk-bridge-gtkaccessibility.patch
+
+ eautoreconf
+ gnome2_src_prepare
+}
+
+multilib_src_configure() {
+ # need libdir here to avoid a double slash in a path that libtool doesn't
+ # grok so well during install (// between $EPREFIX and usr ...)
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure \
+ $(use_enable aqua quartz-backend) \
+ $(use_enable broadway broadway-backend) \
+ $(use_enable cloudprint) \
+ $(use_enable colord) \
+ $(use_enable cups cups auto) \
+ $(multilib_native_use_enable introspection) \
+ $(use_enable wayland wayland-backend) \
+ $(use_enable X x11-backend) \
+ $(use_enable X xcomposite) \
+ $(use_enable X xdamage) \
+ $(use_enable X xfixes) \
+ $(use_enable X xkb) \
+ $(use_enable X xrandr) \
+ $(use_enable xinerama) \
+ $(use_with atk-bridge) \
+ $(usex debug --enable-debug --enable-debug=minimum) \
+ --disable-papi \
+ --disable-mir-backend \
+ --enable-man \
+ --with-xml-catalog="${EPREFIX}"/etc/xml/catalog \
+ --libdir="${EPREFIX}"/usr/$(get_libdir) \
+ CUPS_CONFIG="${EPREFIX}/usr/bin/${CHOST}-cups-config"
+
+ # work-around gtk-doc out-of-source brokedness
+ if multilib_is_native_abi; then
+ local d
+ for d in gdk gtk libgail-util; do
+ ln -s "${S}"/docs/reference/${d}/html docs/reference/${d}/html || die
+ done
+ fi
+}
+
+multilib_src_test() {
+ "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/gtk" || die
+ GSETTINGS_SCHEMA_DIR="${S}/gtk" virtx emake check
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}
+
+multilib_src_install_all() {
+ insinto /etc/gtk-3.0
+ doins "${FILESDIR}"/settings.ini
+ # Skip README.{in,commits,win32} and useless ChangeLog that would get installed by default
+ DOCS=( AUTHORS NEWS README )
+ einstalldocs
+}
+
+pkg_preinst() {
+ gnome2_pkg_preinst
+
+ multilib_pkg_preinst() {
+ # Make immodules.cache belongs to gtk+ alone
+ local cache="usr/$(get_libdir)/gtk-3.0/3.0.0/immodules.cache"
+
+ if [[ -e ${EROOT}${cache} ]]; then
+ cp "${EROOT}"${cache} "${ED}"/${cache} || die
+ else
+ touch "${ED}"/${cache} || die
+ fi
+ }
+ multilib_parallel_foreach_abi multilib_pkg_preinst
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ multilib_pkg_postinst() {
+ gnome2_query_immodules_gtk3 \
+ || die "Update immodules cache failed (for ${ABI})"
+ }
+ multilib_parallel_foreach_abi multilib_pkg_postinst
+
+ if ! has_version "app-text/evince"; then
+ elog "Please install app-text/evince for print preview functionality."
+ elog "Alternatively, check \"gtk-print-preview-command\" documentation and"
+ elog "add it to your settings.ini file."
+ fi
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+
+ if [[ -z ${REPLACED_BY_VERSION} ]]; then
+ multilib_pkg_postrm() {
+ rm -f "${EROOT}"usr/$(get_libdir)/gtk-3.0/3.0.0/immodules.cache
+ }
+ multilib_foreach_abi multilib_pkg_postrm
+ fi
+}