summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--metadata/pkg_desc_index4
-rw-r--r--sys-block/zram-init/Manifest2
-rw-r--r--sys-block/zram-init/zram-init-10.0.ebuild (renamed from sys-block/zram-init/zram-init-9.1.ebuild)37
3 files changed, 26 insertions, 17 deletions
diff --git a/metadata/pkg_desc_index b/metadata/pkg_desc_index
index 4743c588..90c6738b 100644
--- a/metadata/pkg_desc_index
+++ b/metadata/pkg_desc_index
@@ -99,13 +99,13 @@ sci-mathematics/genius 1.0.21: Genius Mathematics Tool and the GEL Language
sci-mathematics/reduce 20141130-r2 20190413: A general-purpose computer algebra system
sys-apps/cpi 3.1: A wrapper for cp -i -a, making use of diff
sys-apps/less 562: Excellent text file viewer, optionally with additional selection feature
-sys-apps/man 1.6g-r1: Standard commands to read man pages
+sys-apps/man 1.6g-r2: Standard commands to read man pages
sys-apps/openrc-wrapper 2.3-r2: Use openrc init scripts with systemd or other init systems
sys-apps/paxopen 1.2: A wrapper script to set PAX kernel variables to an insecure/safe state
sys-apps/schedule 8.0-r1: script to schedule jobs in a multiuser multitasking environment
sys-apps/starter 3.0: POSIX shell script and function to schedule commands
sys-block/parted 2.4-r3: Create, destroy, resize, check, copy partitions and file systems
-sys-block/zram-init 9.1: Scripts to support compressed swap devices or ramdisks with zram
+sys-block/zram-init 10.0: Scripts to support compressed swap devices or ramdisks with zram
sys-boot/grub-cfg-mv 1.7: A grub.cfg library/example for GRUB2
sys-fs/emount 3.0.4: mount/unmount create/remove dm-crypt filesystems according to your /etc/fstab
sys-fs/squash_dir 13.14-r1: Keep directories compressed with squashfs. Useful for portage tree, texmf-dist
diff --git a/sys-block/zram-init/Manifest b/sys-block/zram-init/Manifest
index 2eda1883..48595af0 100644
--- a/sys-block/zram-init/Manifest
+++ b/sys-block/zram-init/Manifest
@@ -1 +1 @@
-DIST zram-init-9.1.tar.gz 11414 SHA512 4e3c76a389d188df98479f3f70af28405144b065df60ba191777cbec88d9bfe94be472d94bbb16314c0eefd41d177105cba74b45d1f13e82a741ff21a4d69c6a
+DIST zram-init-10.0.tar.gz 18373 SHA512 3512b9c5507523e0235d53c4e584c2051a9650fd7eff654fcb2f38f9c556e629b65de2fb16364dd96d708e1917670a19decce888757c192664f2685e13596bbf
diff --git a/sys-block/zram-init/zram-init-9.1.ebuild b/sys-block/zram-init/zram-init-10.0.ebuild
index 65dd8139..c0727682 100644
--- a/sys-block/zram-init/zram-init-9.1.ebuild
+++ b/sys-block/zram-init/zram-init-10.0.ebuild
@@ -12,10 +12,16 @@ SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
-IUSE="split-usr"
+IUSE="nls split-usr"
+LINGUAS="de fr"
+for i in ${LINGUAS}; do
+ IUSE="l10n_${i} ${IUSE}"
+done
+BDEPEND="nls? ( sys-devel/gettext )"
RDEPEND=">=app-shells/push-2.0-r2
- !<sys-apps/openrc-0.13"
+ !<sys-apps/openrc-0.13
+ nls? ( virtual/libintl )"
DISABLE_AUTOFORMATTING="true"
DOC_CONTENTS="To use zram, activate it in your kernel and add it to default runlevel:
@@ -23,26 +29,29 @@ DOC_CONTENTS="To use zram, activate it in your kernel and add it to default runl
If you use systemd enable zram_swap, tmp, and/or var_tmp with systemctl.
You might need to modify /etc/modprobe.d/zram.conf"
-src_prepare() {
- use prefix || sed -i \
- -e '1s"^#!/usr/bin/env sh$"#!'"${EPREFIX}$(get_usr)/bin/sh"'"' \
- -- sbin/* || die
- default
+src_compile() {
+ SHEBANG="#!${EPREFIX}$(get_usr)/bin/sh" \
+ make MODIFY_SHEBANG=$(usex prefix FALSE TRUE) \
+ GETTEXT=$(usex nls TRUE FALSE)
}
src_install() {
+ local i po
+ po=
+ for i in ${LINGUAS}; do
+ eval use "l10n_${i}" && po=${po}${po:+\ }i18n/${i}.po
+ done
+ make DESTDIR="${D}" \
+ PREFIX=/usr BINDIR="${ED}$(get_usr)/sbin" SYSCONFDIR="${EPREFIX}/etc" \
+ OPENRC=FALSE SYSTEMD=FALSE MANPAGE=FALSE \
+ GETTEXT=$(usex nls TRUE FALSE) PO="${po}" \
+ install
doinitd openrc/init.d/*
doconfd openrc/conf.d/*
systemd_dounit systemd/system/*
- insinto /etc/modprobe.d
- doins modprobe.d/*
- insinto /usr/share/zsh/site-functions
- doins zsh/*
- dodoc AUTHORS ChangeLog README.md
doman man/*
+ dodoc AUTHORS ChangeLog README.md
readme.gentoo_create_doc
- into $(get_usr)/
- dosbin sbin/*
}
pkg_postinst() {