summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emacs/po-mode/Manifest1
-rw-r--r--app-emacs/po-mode/files/50po-mode-gentoo.el8
-rw-r--r--app-emacs/po-mode/metadata.xml8
-rw-r--r--app-emacs/po-mode/po-mode-0.19.8.1.ebuild19
4 files changed, 36 insertions, 0 deletions
diff --git a/app-emacs/po-mode/Manifest b/app-emacs/po-mode/Manifest
new file mode 100644
index 00000000..4c1399a0
--- /dev/null
+++ b/app-emacs/po-mode/Manifest
@@ -0,0 +1 @@
+DIST gettext-0.19.8.1.tar.gz 19704011 SHA256 ff942af0e438ced4a8b0ea4b0b6e0d6d657157c5e2364de57baa279c1c125c43
diff --git a/app-emacs/po-mode/files/50po-mode-gentoo.el b/app-emacs/po-mode/files/50po-mode-gentoo.el
new file mode 100644
index 00000000..47adee8f
--- /dev/null
+++ b/app-emacs/po-mode/files/50po-mode-gentoo.el
@@ -0,0 +1,8 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'po-mode "po-mode" "Major mode for translators to edit PO files" t)
+(or (fboundp 'po-find-file-coding-system)
+ (autoload 'po-find-file-coding-system "po-compat"))
+
+(add-to-list 'auto-mode-alist '("\\.po\\'\\|\\.po\\." . po-mode))
+(modify-coding-system-alist 'file "\\.po\\'\\|\\.po\\."
+ 'po-find-file-coding-system)
diff --git a/app-emacs/po-mode/metadata.xml b/app-emacs/po-mode/metadata.xml
new file mode 100644
index 00000000..c438baf3
--- /dev/null
+++ b/app-emacs/po-mode/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/app-emacs/po-mode/po-mode-0.19.8.1.ebuild b/app-emacs/po-mode/po-mode-0.19.8.1.ebuild
new file mode 100644
index 00000000..cfac9b6d
--- /dev/null
+++ b/app-emacs/po-mode/po-mode-0.19.8.1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Major mode for GNU gettext PO files"
+HOMEPAGE="https://www.gnu.org/software/gettext/"
+SRC_URI="mirror://gnu/gettext/gettext-${PV}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-macos"
+
+S="${WORKDIR}/gettext-${PV}/gettext-tools/misc"
+ELISP_REMOVE="start-po.el"
+SITEFILE="50${PN}-gentoo.el"