summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-shells/fast-syntax-highlighting/fast-syntax-highlighting-1.21.ebuild11
-rw-r--r--app-shells/fast-syntax-highlighting/fast-syntax-highlighting-99999999.ebuild11
-rw-r--r--app-shells/zsh-autosuggestions/Manifest2
-rw-r--r--app-shells/zsh-autosuggestions/metadata.xml12
-rw-r--r--app-shells/zsh-autosuggestions/zsh-autosuggestions-0.4.3.ebuild52
-rw-r--r--app-shells/zsh-autosuggestions/zsh-autosuggestions-0.4.4_alpha20180521.ebuild52
-rw-r--r--app-shells/zsh-autosuggestions/zsh-autosuggestions-99999999.ebuild52
-rw-r--r--app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.6.0.ebuild2
-rw-r--r--app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.6.1_alpha20180411.ebuild2
-rw-r--r--app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-99999999.ebuild2
-rw-r--r--app-shells/zshrc-mv/Manifest2
-rw-r--r--app-shells/zshrc-mv/zshrc-mv-4.2.ebuild (renamed from app-shells/zshrc-mv/zshrc-mv-4.1.ebuild)1
-rw-r--r--metadata/pkg_desc_index3
13 files changed, 177 insertions, 27 deletions
diff --git a/app-shells/fast-syntax-highlighting/fast-syntax-highlighting-1.21.ebuild b/app-shells/fast-syntax-highlighting/fast-syntax-highlighting-1.21.ebuild
index 8af368de..d636d94d 100644
--- a/app-shells/fast-syntax-highlighting/fast-syntax-highlighting-1.21.ebuild
+++ b/app-shells/fast-syntax-highlighting/fast-syntax-highlighting-1.21.ebuild
@@ -32,17 +32,6 @@ IUSE=""
RDEPEND="app-shells/zsh"
DEPEND=""
-DISABLE_AUTOFORMATTING="true"
-DOC_CONTENTS="In order to use ${CATEGORY}/${PN} add
-. /usr/share/zsh/site-contrib/${PN}/fast-syntax-highlighting.plugin.zsh
-at the end of your ~/.zshrc
-For testing, you can also execute the above command in your zsh."
-
-MAKE_ARGS=(
- "SHARE_DIR=${ED}/usr/share/zsh/site-contrib/${PN}"
- "DOC_DIR=${ED}/usr/share/doc/${PF}"
-)
-
src_install() {
local DISABLE_AUTOFORMATTING DOC_CONTENTS dir
dir="/usr/share/zsh/site-contrib/${PN}"
diff --git a/app-shells/fast-syntax-highlighting/fast-syntax-highlighting-99999999.ebuild b/app-shells/fast-syntax-highlighting/fast-syntax-highlighting-99999999.ebuild
index 8af368de..d636d94d 100644
--- a/app-shells/fast-syntax-highlighting/fast-syntax-highlighting-99999999.ebuild
+++ b/app-shells/fast-syntax-highlighting/fast-syntax-highlighting-99999999.ebuild
@@ -32,17 +32,6 @@ IUSE=""
RDEPEND="app-shells/zsh"
DEPEND=""
-DISABLE_AUTOFORMATTING="true"
-DOC_CONTENTS="In order to use ${CATEGORY}/${PN} add
-. /usr/share/zsh/site-contrib/${PN}/fast-syntax-highlighting.plugin.zsh
-at the end of your ~/.zshrc
-For testing, you can also execute the above command in your zsh."
-
-MAKE_ARGS=(
- "SHARE_DIR=${ED}/usr/share/zsh/site-contrib/${PN}"
- "DOC_DIR=${ED}/usr/share/doc/${PF}"
-)
-
src_install() {
local DISABLE_AUTOFORMATTING DOC_CONTENTS dir
dir="/usr/share/zsh/site-contrib/${PN}"
diff --git a/app-shells/zsh-autosuggestions/Manifest b/app-shells/zsh-autosuggestions/Manifest
new file mode 100644
index 00000000..ece197ff
--- /dev/null
+++ b/app-shells/zsh-autosuggestions/Manifest
@@ -0,0 +1,2 @@
+DIST zsh-autosuggestions-0.4.3.tar.gz 20243 SHA512 c9be728bfd4cea67cc580548bda4c1b043e275a5a6f0c2134120e7e62e4522da2eddfff4c9414b5d6f28210d2f0b0f5bf008e7275c977c81bd61194f653c922c
+DIST zsh-autosuggestions-0.4.4_alpha20180521.tar.gz 20246 SHA512 71c79c4cd006de2172509a18790b2f8216a5b0f91219accea9788545eb863d54e63169b8b71393bfdae721e1445b52fe1f85c4e235420b92ae0584423dfbef51
diff --git a/app-shells/zsh-autosuggestions/metadata.xml b/app-shells/zsh-autosuggestions/metadata.xml
new file mode 100644
index 00000000..3432e56a
--- /dev/null
+++ b/app-shells/zsh-autosuggestions/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/zsh-users/zsh-autosuggestions/issues</bugs-to>
+ <remote-id type="github">zsh-users/zsh-autosuggestions</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-shells/zsh-autosuggestions/zsh-autosuggestions-0.4.3.ebuild b/app-shells/zsh-autosuggestions/zsh-autosuggestions-0.4.3.ebuild
new file mode 100644
index 00000000..e4048aae
--- /dev/null
+++ b/app-shells/zsh-autosuggestions/zsh-autosuggestions-0.4.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2011-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit readme.gentoo-r1
+
+RESTRICT="mirror"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+case ${PV} in
+99999999*)
+ EGIT_REPO_URI="https://github.com/zsh-users/${PN}.git"
+ inherit git-r3
+ PROPERTIES="live"
+ SRC_URI=""
+ KEYWORDS="";;
+*alpha*)
+ EGIT_COMMIT="d7c796719e6352666f7a9c94da9ddaed10f3217d"
+ SRC_URI="https://github.com/zsh-users/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${EGIT_COMMIT}";;
+*)
+ SRC_URI="https://github.com/zsh-users/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz";;
+esac
+
+DESCRIPTION="Fish-like autosuggestions for zsh"
+HOMEPAGE="https://github.com/zsh-users/zsh-autosuggestions/"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="app-shells/zsh"
+DEPEND=""
+
+src_install() {
+ local DISABLE_AUTOFORMATTING DOC_CONTENTS dir
+ dir="/usr/share/zsh/site-contrib/${PN}"
+ DISABLE_AUTOFORMATTING="true"
+ DOC_CONTENTS="In order to use ${CATEGORY}/${PN} add
+. ${EPREFIX}${dir}/zsh-autosuggestions.zsh"'
+at the end of your ~/.zshrc
+For testing, you can also execute the above command in your zsh.'
+ readme.gentoo_create_doc
+ insinto "${dir}"
+ doins *.zsh
+ doins -r spec src
+ dodoc *.md
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
diff --git a/app-shells/zsh-autosuggestions/zsh-autosuggestions-0.4.4_alpha20180521.ebuild b/app-shells/zsh-autosuggestions/zsh-autosuggestions-0.4.4_alpha20180521.ebuild
new file mode 100644
index 00000000..e4048aae
--- /dev/null
+++ b/app-shells/zsh-autosuggestions/zsh-autosuggestions-0.4.4_alpha20180521.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2011-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit readme.gentoo-r1
+
+RESTRICT="mirror"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+case ${PV} in
+99999999*)
+ EGIT_REPO_URI="https://github.com/zsh-users/${PN}.git"
+ inherit git-r3
+ PROPERTIES="live"
+ SRC_URI=""
+ KEYWORDS="";;
+*alpha*)
+ EGIT_COMMIT="d7c796719e6352666f7a9c94da9ddaed10f3217d"
+ SRC_URI="https://github.com/zsh-users/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${EGIT_COMMIT}";;
+*)
+ SRC_URI="https://github.com/zsh-users/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz";;
+esac
+
+DESCRIPTION="Fish-like autosuggestions for zsh"
+HOMEPAGE="https://github.com/zsh-users/zsh-autosuggestions/"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="app-shells/zsh"
+DEPEND=""
+
+src_install() {
+ local DISABLE_AUTOFORMATTING DOC_CONTENTS dir
+ dir="/usr/share/zsh/site-contrib/${PN}"
+ DISABLE_AUTOFORMATTING="true"
+ DOC_CONTENTS="In order to use ${CATEGORY}/${PN} add
+. ${EPREFIX}${dir}/zsh-autosuggestions.zsh"'
+at the end of your ~/.zshrc
+For testing, you can also execute the above command in your zsh.'
+ readme.gentoo_create_doc
+ insinto "${dir}"
+ doins *.zsh
+ doins -r spec src
+ dodoc *.md
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
diff --git a/app-shells/zsh-autosuggestions/zsh-autosuggestions-99999999.ebuild b/app-shells/zsh-autosuggestions/zsh-autosuggestions-99999999.ebuild
new file mode 100644
index 00000000..e4048aae
--- /dev/null
+++ b/app-shells/zsh-autosuggestions/zsh-autosuggestions-99999999.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2011-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit readme.gentoo-r1
+
+RESTRICT="mirror"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+case ${PV} in
+99999999*)
+ EGIT_REPO_URI="https://github.com/zsh-users/${PN}.git"
+ inherit git-r3
+ PROPERTIES="live"
+ SRC_URI=""
+ KEYWORDS="";;
+*alpha*)
+ EGIT_COMMIT="d7c796719e6352666f7a9c94da9ddaed10f3217d"
+ SRC_URI="https://github.com/zsh-users/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${EGIT_COMMIT}";;
+*)
+ SRC_URI="https://github.com/zsh-users/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz";;
+esac
+
+DESCRIPTION="Fish-like autosuggestions for zsh"
+HOMEPAGE="https://github.com/zsh-users/zsh-autosuggestions/"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="app-shells/zsh"
+DEPEND=""
+
+src_install() {
+ local DISABLE_AUTOFORMATTING DOC_CONTENTS dir
+ dir="/usr/share/zsh/site-contrib/${PN}"
+ DISABLE_AUTOFORMATTING="true"
+ DOC_CONTENTS="In order to use ${CATEGORY}/${PN} add
+. ${EPREFIX}${dir}/zsh-autosuggestions.zsh"'
+at the end of your ~/.zshrc
+For testing, you can also execute the above command in your zsh.'
+ readme.gentoo_create_doc
+ insinto "${dir}"
+ doins *.zsh
+ doins -r spec src
+ dodoc *.md
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
diff --git a/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.6.0.ebuild b/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.6.0.ebuild
index e28aceb3..d72b7865 100644
--- a/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.6.0.ebuild
+++ b/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.6.0.ebuild
@@ -23,7 +23,7 @@ case ${PV} in
esac
DESCRIPTION="Fish shell like syntax highlighting for zsh"
-HOMEPAGE="https://github.com/zsh-users/zsh-syntax-highlighting"
+HOMEPAGE="https://github.com/zsh-users/zsh-syntax-highlighting/"
LICENSE="HPND"
SLOT="0"
diff --git a/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.6.1_alpha20180411.ebuild b/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.6.1_alpha20180411.ebuild
index e28aceb3..d72b7865 100644
--- a/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.6.1_alpha20180411.ebuild
+++ b/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.6.1_alpha20180411.ebuild
@@ -23,7 +23,7 @@ case ${PV} in
esac
DESCRIPTION="Fish shell like syntax highlighting for zsh"
-HOMEPAGE="https://github.com/zsh-users/zsh-syntax-highlighting"
+HOMEPAGE="https://github.com/zsh-users/zsh-syntax-highlighting/"
LICENSE="HPND"
SLOT="0"
diff --git a/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-99999999.ebuild b/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-99999999.ebuild
index e28aceb3..d72b7865 100644
--- a/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-99999999.ebuild
+++ b/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-99999999.ebuild
@@ -23,7 +23,7 @@ case ${PV} in
esac
DESCRIPTION="Fish shell like syntax highlighting for zsh"
-HOMEPAGE="https://github.com/zsh-users/zsh-syntax-highlighting"
+HOMEPAGE="https://github.com/zsh-users/zsh-syntax-highlighting/"
LICENSE="HPND"
SLOT="0"
diff --git a/app-shells/zshrc-mv/Manifest b/app-shells/zshrc-mv/Manifest
index 28a366a6..9d8004d8 100644
--- a/app-shells/zshrc-mv/Manifest
+++ b/app-shells/zshrc-mv/Manifest
@@ -1 +1 @@
-DIST zshrc-mv-4.1.tar.gz 11429 SHA512 8d54e0edcbb433fb1314776688ff89452c638d1e9d6988fc8de3b3c4ebf1e0212da9e12dc71c48e20013d8ec9cad1eda82ad284f9f52bbdd1122995e3d739697
+DIST zshrc-mv-4.2.tar.gz 11477 SHA512 b485da5d7af00620e65afa7a6d87c6db23c41fee853f74783327c56b057f086d7c2fb36a1be42480cf422ab4744542564a5ef60b1297002dde2d588e4d322797
diff --git a/app-shells/zshrc-mv/zshrc-mv-4.1.ebuild b/app-shells/zshrc-mv/zshrc-mv-4.2.ebuild
index 0ae20bba..0458608b 100644
--- a/app-shells/zshrc-mv/zshrc-mv-4.1.ebuild
+++ b/app-shells/zshrc-mv/zshrc-mv-4.2.ebuild
@@ -18,6 +18,7 @@ IUSE=""
OPTIONAL_RDEPEND=">=app-shells/auto-fu-zsh-0.0.1.12_p0
>=app-shells/set_prompt-3.0.0
app-shells/termcolors-mv
+app-shells/zsh-autosuggestions
|| ( app-shells/fast-syntax-highlighting app-shells/zsh-syntax-highlighting )"
RDEPEND="!app-shells/auto-fu-zsh[kill-line(-)]
diff --git a/metadata/pkg_desc_index b/metadata/pkg_desc_index
index f5368049..3fca2ead 100644
--- a/metadata/pkg_desc_index
+++ b/metadata/pkg_desc_index
@@ -42,8 +42,9 @@ app-shells/runtitle 2.10: Scripts to run commands and set the hard status line (
app-shells/schily-tools 2018.05.25: Many tools from Joerg Schilling, including a POSIX compliant Bourne Shell
app-shells/set_prompt 3.1: An intelligent prompt for zsh or bash with status line (window title) support
app-shells/termcolors-mv 4.7-r1: 256colors sample script and dircolors configuration for standard or 256 colors
+app-shells/zsh-autosuggestions 0.4.3 0.4.4_alpha20180521 99999999: Fish-like autosuggestions for zsh
app-shells/zsh-syntax-highlighting 0.6.0 0.6.1_alpha20180411 99999999: Fish shell like syntax highlighting for zsh
-app-shells/zshrc-mv 4.1: A zshrc file initializing zsh specific interactive features
+app-shells/zshrc-mv 4.2: A zshrc file initializing zsh specific interactive features
app-text/ispell 3.3.02-r1 3.4.00: fast screen-oriented spelling checker
app-text/lesspipe 1.83-r2 1.84_alpha20180414-r2 99999999: Wolfgang Friebel's preprocessor for sys-apps/less. Disable by appending colon
app-text/mbtpdfasm 1.0.28-r1: Tool to assemble/merge, extract information from, and update the metadata in PDF