summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-portage/eix/Manifest1
-rw-r--r--app-portage/eix/eix-0.32.3-r1.ebuild80
-rw-r--r--app-portage/eix/eix-0.32.3.ebuild2
-rw-r--r--app-portage/eix/eix-0.32.4.ebuild2
-rw-r--r--app-portage/eix/eix-0.32.5_beta0.ebuild (renamed from app-portage/eix/eix-99999999-r1.ebuild)22
-rw-r--r--app-portage/eix/eix-99999999.ebuild30
6 files changed, 37 insertions, 100 deletions
diff --git a/app-portage/eix/Manifest b/app-portage/eix/Manifest
index 8379cc96..dd605d86 100644
--- a/app-portage/eix/Manifest
+++ b/app-portage/eix/Manifest
@@ -1,2 +1,3 @@
DIST eix-0.32.3.tar.xz 590064 SHA256 fc3b8493a765063d0b912ad7b16e4513a0e18a9be28d77e5148f97a9b838a39b
DIST eix-0.32.4.tar.xz 592284 SHA256 8132be9c496b5b19699c50d9aacd49560ca1f0466e3de4f47b896337f3527fc6
+DIST eix-0.32.5_beta0.tar.gz 642937 SHA256 4888842cbd54ec8ceb1a6c9b25c131616f0e2a1274de3e084a50c76471d28aa6
diff --git a/app-portage/eix/eix-0.32.3-r1.ebuild b/app-portage/eix/eix-0.32.3-r1.ebuild
deleted file mode 100644
index 91533008..00000000
--- a/app-portage/eix/eix-0.32.3-r1.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PLOCALES="de ru"
-inherit bash-completion-r1 l10n tmpfiles
-
-DESCRIPTION="Search and query ebuilds, portage incl. local settings, ext. overlays and more"
-HOMEPAGE="https://github.com/vaeth/eix/"
-SRC_URI="https://github.com/vaeth/eix/releases/download/v${PV}/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="debug +dep doc nls optimization +required-use security strong-optimization strong-security sqlite swap-remote tools"
-
-BOTHDEPEND="nls? ( virtual/libintl )
- sqlite? ( >=dev-db/sqlite-3:= )"
-RDEPEND="${BOTHDEPEND}
- >=app-shells/push-2.0
- >=app-shells/quoter-3.0"
-DEPEND="${BOTHDEPEND}
- app-arch/xz-utils
- nls? ( sys-devel/gettext )"
-
-pkg_setup() {
- # remove stale cache file to prevent collisions
- local old_cache="${EROOT}var/cache/${PN}"
- test -f "${old_cache}" && rm -f -- "${old_cache}"
-}
-
-src_prepare() {
- sed -i -e "s'/'${EPREFIX}/'" -- "${S}"/tmpfiles.d/eix.conf || die
- eapply_user
-}
-
-src_configure() {
- econf \
- $(use_with sqlite) \
- $(use_with doc extra-doc) \
- $(use_enable nls) \
- $(use_enable tools separate-tools) \
- $(use_enable security) \
- $(use_enable optimization) \
- $(use_enable strong-security) \
- $(use_enable strong-optimization) \
- $(use_enable debug debugging) \
- $(use_enable swap-remote) \
- $(use_with prefix always-accept-keywords) \
- $(use_with dep dep-default) \
- $(use_with required-use required-use-default) \
- --with-zsh-completion \
- --with-portage-rootpath="${ROOTPATH}" \
- --with-eprefix-default="${EPREFIX}"
-}
-
-src_install() {
- default
- dobashcomp bash/eix
- dotmpfiles tmpfiles.d/eix.conf
- diropts -m0755
- dodir /var/cache/eix
- # note: portage:portage ownership may be reset to root
- fowners root:portage "${EROOT}var/cache/${PN}"
-}
-
-pkg_postinst() {
- local obs="${EROOT}var/cache/eix.previous"
- if test -f "${obs}"; then
- ewarn "Found obsolete ${obs}, please remove it"
- fi
- tmpfiles_process eix.conf
-}
-
-pkg_postrm() {
- if [ -z "${REPLACED_BY_VERSION}" ]; then
- rm -rf -- "${EROOT}var/cache/${PN}"
- fi
-}
diff --git a/app-portage/eix/eix-0.32.3.ebuild b/app-portage/eix/eix-0.32.3.ebuild
index cd9709d0..cd451fb9 100644
--- a/app-portage/eix/eix-0.32.3.ebuild
+++ b/app-portage/eix/eix-0.32.3.ebuild
@@ -6,7 +6,7 @@ EAPI=6
PLOCALES="de ru"
inherit bash-completion-r1 l10n systemd
-DESCRIPTION="Search and query ebuilds, portage incl. local settings, ext. overlays and more"
+DESCRIPTION="Search and query ebuilds"
HOMEPAGE="https://github.com/vaeth/eix/"
SRC_URI="https://github.com/vaeth/eix/releases/download/v${PV}/${P}.tar.xz"
diff --git a/app-portage/eix/eix-0.32.4.ebuild b/app-portage/eix/eix-0.32.4.ebuild
index 5652fc7a..f46fd2be 100644
--- a/app-portage/eix/eix-0.32.4.ebuild
+++ b/app-portage/eix/eix-0.32.4.ebuild
@@ -6,7 +6,7 @@ EAPI=6
PLOCALES="de ru"
inherit bash-completion-r1 l10n tmpfiles
-DESCRIPTION="Search and query ebuilds, portage incl. local settings, ext. overlays and more"
+DESCRIPTION="Search and query ebuilds"
HOMEPAGE="https://github.com/vaeth/eix/"
SRC_URI="https://github.com/vaeth/eix/releases/download/v${PV}/${P}.tar.xz"
diff --git a/app-portage/eix/eix-99999999-r1.ebuild b/app-portage/eix/eix-0.32.5_beta0.ebuild
index 279962ca..cb812f13 100644
--- a/app-portage/eix/eix-99999999-r1.ebuild
+++ b/app-portage/eix/eix-0.32.5_beta0.ebuild
@@ -2,16 +2,26 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-
-EGIT_REPO_URI="git://github.com/vaeth/${PN}.git"
+RESTRICT="mirror"
WANT_LIBTOOL=none
PLOCALES="de ru"
-inherit autotools bash-completion-r1 git-r3 l10n tmpfiles
+inherit autotools bash-completion-r1 l10n tmpfiles
+
+case ${PV} in
+99999999*)
+ EGIT_REPO_URI="git://github.com/vaeth/${PN}.git"
+ inherit git-r3
+ SRC_URI=""
+ PROPERTIES="live";;
+*)
+ RESTRICT="mirror"
+ EGIT_COMMIT="792fec8088bc78ea916aa73c2692d4987c8142be"
+ SRC_URI="https://github.com/vaeth/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${EGIT_COMMIT}";;
+esac
-DESCRIPTION="Search and query ebuilds, portage incl. local settings, ext. overlays and more"
+DESCRIPTION="Search and query ebuilds"
HOMEPAGE="https://github.com/vaeth/eix/"
-SRC_URI=""
-PROPERTIES="live"
LICENSE="GPL-2"
SLOT="0"
diff --git a/app-portage/eix/eix-99999999.ebuild b/app-portage/eix/eix-99999999.ebuild
index 531b470c..cb812f13 100644
--- a/app-portage/eix/eix-99999999.ebuild
+++ b/app-portage/eix/eix-99999999.ebuild
@@ -2,16 +2,26 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-
-EGIT_REPO_URI="git://github.com/vaeth/${PN}.git"
+RESTRICT="mirror"
WANT_LIBTOOL=none
PLOCALES="de ru"
-inherit autotools bash-completion-r1 git-r3 l10n systemd
+inherit autotools bash-completion-r1 l10n tmpfiles
+
+case ${PV} in
+99999999*)
+ EGIT_REPO_URI="git://github.com/vaeth/${PN}.git"
+ inherit git-r3
+ SRC_URI=""
+ PROPERTIES="live";;
+*)
+ RESTRICT="mirror"
+ EGIT_COMMIT="792fec8088bc78ea916aa73c2692d4987c8142be"
+ SRC_URI="https://github.com/vaeth/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${EGIT_COMMIT}";;
+esac
-DESCRIPTION="Search and query ebuilds, portage incl. local settings, ext. overlays and more"
+DESCRIPTION="Search and query ebuilds"
HOMEPAGE="https://github.com/vaeth/eix/"
-SRC_URI=""
-PROPERTIES="live"
LICENSE="GPL-2"
SLOT="0"
@@ -62,19 +72,15 @@ src_configure() {
src_install() {
default
dobashcomp bash/eix
- systemd_dotmpfilesd tmpfiles.d/eix.conf
+ dotmpfiles tmpfiles.d/eix.conf
}
pkg_postinst() {
- if ! use prefix && ! test -d "${EROOT}var/cache/${PN}"; then
- # note: if this is done in src_install(), portage:portage
- # ownership may be reset to root
- fowners portage:portage "${EROOT%/}"/var/cache/eix
- fi
local obs="${EROOT}var/cache/eix.previous"
if test -f "${obs}"; then
ewarn "Found obsolete ${obs}, please remove it"
fi
+ tmpfiles_process eix.conf
}
pkg_postrm() {