summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-shells/dash/dash-99999999.ebuild4
-rw-r--r--app-shells/dash/metadata.xml2
-rw-r--r--profiles/make.defaults2
-rw-r--r--profiles/use.local.desc2
4 files changed, 5 insertions, 5 deletions
diff --git a/app-shells/dash/dash-99999999.ebuild b/app-shells/dash/dash-99999999.ebuild
index 96940531..fb47384b 100644
--- a/app-shells/dash/dash-99999999.ebuild
+++ b/app-shells/dash/dash-99999999.ebuild
@@ -36,7 +36,7 @@ HOMEPAGE="http://gondor.apana.org.au/~herbert/dash/"
LICENSE="BSD"
SLOT="0"
-IUSE="dumb-echo libedit static"
+IUSE="libedit static vanilla"
RDEPEND="!static? ( libedit? ( dev-libs/libedit ) )"
DEPEND="${RDEPEND}
@@ -46,7 +46,7 @@ DEPEND="${RDEPEND}
src_prepare() {
local c
default
- ! use dumb-echo || eapply "${FILESDIR}"/dumb-echo.patch
+ use vanilla || eapply "${FILESDIR}"/dumb-echo.patch
if [ -n "${DEB_PATCH}" ]
then eapply "${WORKDIR}"/${DEB_PF}.diff
eapply */debian/diff/*
diff --git a/app-shells/dash/metadata.xml b/app-shells/dash/metadata.xml
index eda7dfb4..2af3d735 100644
--- a/app-shells/dash/metadata.xml
+++ b/app-shells/dash/metadata.xml
@@ -14,7 +14,7 @@
<remote-id type="cpe">cpe:/a:dash:dash</remote-id>
</upstream>
<use>
- <flag name="dumb-echo">Disable echo -n and character sequence interpretation for added fun</flag>
+ <flag name="vanilla">Let echo escapes and -n work as decided by upstream</flag>
</use>
<longdescription lang="en">
DASH is a direct descendant of the NetBSD version of ash (the Almquist SHell)
diff --git a/profiles/make.defaults b/profiles/make.defaults
index a4a87ba0..52a740fa 100644
--- a/profiles/make.defaults
+++ b/profiles/make.defaults
@@ -1 +1 @@
-USE_EXPAND="BROWSER COMPLETION FOO2ZJS_DEVICES PDFVIEWER RENAMESCHILY SCHILYTOOLS"
+USE_EXPAND="BROWSER FOO2ZJS_DEVICES PDFVIEWER RENAMESCHILY SCHILYTOOLS"
diff --git a/profiles/use.local.desc b/profiles/use.local.desc
index 820424ec..90e1c815 100644
--- a/profiles/use.local.desc
+++ b/profiles/use.local.desc
@@ -17,7 +17,7 @@ app-portage/eix:swap-remote - Swap role of remote addresses in eix-remote, makin
app-portage/eix:tools - Create separate binary for script helper tools; useful if they are called extremely often
app-portage/portage-postsyncd-mv:portage-utils - Make /etc/portage/repo.postsync.d/q-reinit from app-portage/portage-utils non-executable and install a hack in /etc/portage/env/app-portage/portage-utils so that it stays so
app-shells/auto-fu-zsh:compile - Byte-compile to speed up. Do not use this if you are cross-compiling
-app-shells/dash:dumb-echo - Disable echo -n and character sequence interpretation for added fun
+app-shells/dash:vanilla - Let echo escapes and -n work as decided by upstream
app-shells/schily-tools:renameschily_calc - Rename calc to scalc for compatibility with sci-mathematics/calc
app-shells/schily-tools:renameschily_compare - Rename compare to scompare for compatibility with imagemagick
app-shells/schily-tools:renameschily_count - Rename count to scount for compatibility with sys-devel/llvm