summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--eclass/ChangeLog3
-rw-r--r--eclass/mv_mozextension-r1.eclass131
-rw-r--r--metadata/pkg_desc_index22
-rw-r--r--www-plugins/bookmark-deduplicator/Manifest2
-rw-r--r--www-plugins/bookmark-deduplicator/bookmark-deduplicator-1.3.1-r1.ebuild (renamed from www-plugins/bookmark-deduplicator/bookmark-deduplicator-1.3.1.ebuild)4
-rw-r--r--www-plugins/bookmark-duplicate-cleaner/Manifest2
-rw-r--r--www-plugins/bookmark-duplicate-cleaner/bookmark-duplicate-cleaner-0.2-r1.ebuild (renamed from www-plugins/bookmark-duplicate-cleaner/bookmark-duplicate-cleaner-0.2.ebuild)4
-rw-r--r--www-plugins/classic-theme-restorer/classic-theme-restorer-1.7.0-r1.ebuild (renamed from www-plugins/classic-theme-restorer/classic-theme-restorer-1.7.0.ebuild)4
-rw-r--r--www-plugins/duckduckgo/Manifest2
-rw-r--r--www-plugins/duckduckgo/duckduckgo-1.1.23.ebuild (renamed from www-plugins/duckduckgo/duckduckgo-1.1.22.ebuild)4
-rw-r--r--www-plugins/epubreader/Manifest4
-rw-r--r--www-plugins/epubreader/epubreader-1.5.0.12-r1.ebuild (renamed from www-plugins/epubreader/epubreader-1.5.0.12.ebuild)4
-rw-r--r--www-plugins/epubreader/epubreader-2.0.5-r1.ebuild (renamed from www-plugins/epubreader/epubreader-2.0.5.ebuild)9
-rw-r--r--www-plugins/form-history-control/Manifest2
-rw-r--r--www-plugins/form-history-control/form-history-control-1.4.0.6-r1.ebuild (renamed from www-plugins/form-history-control/form-history-control-1.4.0.6.ebuild)4
-rw-r--r--www-plugins/locale-switcher/Manifest2
-rw-r--r--www-plugins/locale-switcher/locale-switcher-3-r2.ebuild (renamed from www-plugins/locale-switcher/locale-switcher-3-r1.ebuild)4
-rw-r--r--www-plugins/noscript/noscript-2.9.0.14-r1.ebuild (renamed from www-plugins/noscript/noscript-2.9.0.14.ebuild)9
-rw-r--r--www-plugins/noscript/noscript-5.0.10-r1.ebuild (renamed from www-plugins/noscript/noscript-5.0.10.ebuild)11
-rw-r--r--www-plugins/requestpolicy/Manifest2
-rw-r--r--www-plugins/requestpolicy/requestpolicy-0.5.28-r2.ebuild (renamed from www-plugins/requestpolicy/requestpolicy-0.5.28-r1.ebuild)4
-rw-r--r--www-plugins/stylus/stylus-1.1.4.1-r1.ebuild (renamed from www-plugins/stylus/stylus-1.1.4.1.ebuild)2
-rw-r--r--www-plugins/xclear/Manifest2
-rw-r--r--www-plugins/xclear/xclear-1.8.2-r1.ebuild (renamed from www-plugins/xclear/xclear-1.8.2.ebuild)4
24 files changed, 147 insertions, 94 deletions
diff --git a/eclass/ChangeLog b/eclass/ChangeLog
index 79f24054..09d29de8 100644
--- a/eclass/ChangeLog
+++ b/eclass/ChangeLog
@@ -65,3 +65,6 @@
26 Jul 2017; Martin Väth <martin@mvath.de>:
Reflect changes in documentation of meson_optional.eclass
+
+ 17 Sep 2017; Martin Väth <martin@mvath.de>:
+ Support version specification in mv_mozextension-r1.eclass
diff --git a/eclass/mv_mozextension-r1.eclass b/eclass/mv_mozextension-r1.eclass
index 8d995d78..da389935 100644
--- a/eclass/mv_mozextension-r1.eclass
+++ b/eclass/mv_mozextension-r1.eclass
@@ -17,7 +17,7 @@
# @CODE
# inherit moz
#
-# MOZ="firefox palemoon seamonkey"
+# MOZ="<firefox-57 palemoon seamonkey"
# DEPEND=${MOZ_DEPEND}
# RDEPEND=$(moz_rdepend ${MOZ})
# IUSE=$(moz_iuse ${MOZ})
@@ -106,61 +106,125 @@ moz_install$quoteargs
# This is an eclass-generated depend expression needed for moz_unpack to work
MOZ_DEPEND='app-arch/unzip'
-# @FUNCTION: moz_atom
+# @FUNCTION: moz_split_browser
+# @USAGE: <browser>
+# @DESCRIPTION:
+# browser is one of [operator](firefox|palemoon|seamonkey)[-source|-bin][*].
+# The function outputs the "browser[-source|-bin]" part
+moz_split_browser() {
+ local browser
+ for browser in firefox palemoon seamonkey
+ do case ${1} in
+ *"${browser}"?source*)
+ echo "${browser}-source"
+ return;;
+ *"${browser}"?bin*)
+ echo "${browser}-bin"
+ return;;
+ *"${browser}"*)
+ echo "${browser}"
+ return;;
+ esac
+ done
+ die "args must be [operator](firefox|palemoon|seamonkey)[-source|-bin][*]"
+}
+
+# @FUNCTION: moz_split_operator
+# @USAGE: <browser>
+# @DESCRIPTION:
+# browser is one of [operator](firefox|palemoon|seamonkey)[-source|-bin][*].
+# The function outputs the "[operator]" part
+moz_split_operator() {
+ local browser operator
+ for browser in firefox palemoon seamonkey
+ do case ${1} in
+ *"${browser}"*)
+ operator=${1%%"${browser}"*}
+ echo "${operator}"
+ return;;
+ esac
+ done
+ die "args must be [operator](firefox|palemoon|seamonkey)[-source|-bin][*]"
+}
+
+# @FUNCTION: moz_split_rest
# @USAGE: <browser>
# @DESCRIPTION:
+# browser is one of [operator](firefox|palemoon|seamonkey)[-source|-bin][*].
+# The function outputs the "[*]" part
+moz_split_rest() {
+ local front rest
+ for front in source bin firefox palemoon seamonkey
+ do case ${1} in
+ *"${front}"*)
+ rest=${1#*"${front}"}
+ echo "${rest}"
+ return;;
+ esac
+ done
+ die "args must be [operator](firefox|palemoon|seamonkey)[-source|-bin][*]"
+}
+
+# @FUNCTION: moz_atom
+# @USAGE: <browser> <operator> <rest>
+# @DESCRIPTION:
# Prints the atom/subexpression used in RDEPEND for the corresponding browser,
-# e.g. www-client/firefox-bin
+# e.g. [operator]www-client/firefox-bin[rest]
# browser is one of (firefox|palemoon|seamonkey)(-source|-bin)
-# If nothing is printed, the output of "moz_atom_default <browser>" is used.
+# If nothing is printed, the output of
+# "moz_atom_default <browser> <operator> <rest>"
+# is used (see below).
# moz_atom is meant to be defined by the ebuild if non-defaults are used.
# @DEFAULT_UNSET
# @FUNCTION: moz_atom_default
-# @USAGE: <browser>
+# @USAGE: <browser> <operator> <rest>
# @DESCRIPTION:
# Prints the atom/subexpression used in RDEPEND for the corresponding browser,
# when moz_atom is not defined or prints nothing.
-# brower is one of (firefox|palemoon|seamonkey)(-source|-bin)
+# browser is one of (firefox|palemoon|seamonkey)(-source|-bin).
moz_atom_default() {
- echo "www-client/${1%-source}"
+ echo "${2}www-client/${1%?source}${3}"
}
# @FUNCTION: moz_rdepend
# @USAGE: [<browser>] [<browser>] [...]
# @DESCRIPTION:
# Outputs RDEPEND expression appropriate for browsers.
-# browser is (firefox|palemoon|seamonkey)[-source|-bin] (no specified = all)
+# browser is one of [operator](firefox|palemoon|seamonkey)[-source|-bin][*]
+# (none specified = all browsers)
# Note that moz_rdepend_atom (if defined by the ebuild) is used to calculate
# the expression.
moz_rdepend() {
- local rdep browser count modes mode atom useflag
+ local arg rdep browser count modes mode atom useflag operator rest
[ ${#} -ne 0 ] || set -- firefox palemoon seamonkey
count=
rdep=
- for browser in firefox palemoon seamonkey
- do modes=
- case ${*} in
- *"${browser}"?source*)
+ for arg
+ do browser=`moz_split_browser "${arg}"`
+ operator=`moz_split_operator "${arg}"`
+ rest=`moz_split_rest "${arg}"`
+ modes="source bin"
+ case ${browser} in
+ *source*)
+ browser=${browser%?source*}
modes=source;;
- *"${browser}"?bin*)
+ *bin*)
+ browser=${browser%?bin*}
modes=bin;;
- *"${browser}"*)
- modes="source bin";;
esac
for mode in $modes
do atom=
[ "$(type -t moz_atom)" != "function" ] || \
- atom=`moz_atom "${browser}-${mode}"`
+ atom=`moz_atom "${browser}-${mode}" "${operator}" "${rest}"`
[ -n "$atom" ] || \
- atom=`moz_atom_default "${browser}-${mode}"`
+ atom=`moz_atom_default "${browser}-${mode}" "${operator}" "${rest}"`
useflag=browser_${browser}
[ "$mode" = "source" ] || useflag=${useflag}-${mode}
rdep=${rdep}${rdep:+\ }"${useflag}? ( ${atom} )"
count=${count}a
done
done
- [ -n "${count}" ] || die "args must be (firefox|palemoon|seamonkey)[-source|-bin]"
[ "${count}" = a ] && echo "${rdep}" || echo "|| ( ${rdep} )"
}
@@ -168,7 +232,8 @@ moz_rdepend() {
# @USAGE: [-c|-C|-n] [--] [<browser>] [<browser>] [...]
# @DESCRIPTION:
# Outputs IUSE expression appropriate for browsers.
-# browser is (firefox|palemoon|seamonkey)[-source|-bin] (no specified = all).
+# browser is [opertator](firefox|palemoon|seamonkey)[-source|-bin][*]
+# (none specified = all browsers).
# If option -C or -n is specified, IUSE=compressed is not default/added.
moz_iuse() {
local iuse i opt
@@ -193,7 +258,7 @@ moz_iuse() {
iuse=${iuse}${iuse:+\ }"browser_${i} browser_${i}-bin";;
esac
done
- [ -n "${iuse}" ] || die "args must be (firefox|palemoon|seamonkey)[-source|-bin]"
+ [ -n "${iuse}" ] || die "args must be [operator](firefox|palemoon|seamonkey)[-source|-bin][*]"
echo "${iuse}"
}
@@ -201,7 +266,8 @@ moz_iuse() {
# @USAGE: [<browser>] [<browser>] [...]
# @DESCRIPTION:
# Outputs REQUIRED_USE expression appropriate for browsers.
-# browser is (firefox|palemoon|seamonkey)[-source|-bin] (no specified means all)
+# browser is [operator](firefox|palemoon|seamonkey)[-source|-bin][*]
+# (none specified = all browsers).
moz_required_use() {
set -- $(moz_iuse -n "${@}")
[ ${#} -lt 2 ] && echo "${*}" || echo "|| ( ${*} )"
@@ -338,7 +404,8 @@ moz_install_to_dir() {
# @FUNCTION: moz_install_for_browser
# @USAGE: [-n] [-i id] [--] <browser> <dir> <dir> [...]
# @DESCRIPTION:
-# Installs dirs.xpi for browser ({firefox,palemoon,seymonkey}{,-bin}).
+# Installs dirs.xpi for browser.
+# browser is [operator](firefox|palemoon|seymonkey)[-source|-bin][*]
# Arguments which are not directories are silently ignored.
# If arguments are specified, they must contain at least one directory.
# If no argument is specified, all directories from "${S}" are considered.
@@ -361,18 +428,18 @@ moz_install_for_browser() {
palemoon="palemoon/browser/extensions"
seamonkey="seamonkey/extensions"
case ${1} in
- firefox)
- dest="/usr/$(get_libdir)/${firefox}";;
- firefox?bin)
+ *firefox*bin*)
dest="/opt/${firefox}";;
- palemoon)
- dest="/usr/$(get_libdir)/${palemoon}";;
- palemoon?bin)
+ *firefox*)
+ dest="/usr/$(get_libdir)/${firefox}";;
+ *palemoon?bin*)
dest="/opt/${palemoon}";;
- seamonkey)
- dest="/usr/$(get_libdir)/${seamonkey}";;
- seamonkey?bin)
+ *palemoon*)
+ dest="/usr/$(get_libdir)/${palemoon}";;
+ *seamonkey?bin*)
dest="/opt/${seamonkey}";;
+ *seamonkey*)
+ dest="/usr/$(get_libdir)/${seamonkey}";;
*)
die "unknown browser specified";;
esac
diff --git a/metadata/pkg_desc_index b/metadata/pkg_desc_index
index 741889e2..d8b37bbe 100644
--- a/metadata/pkg_desc_index
+++ b/metadata/pkg_desc_index
@@ -110,20 +110,20 @@ sys-process/systemd-cron 1.5.4 1.5.10: systemd units to create timers for cron d
virtual/freedesktop-icon-theme 0-r2: A virtual to choose between different icon themes
www-client/palemoon 27: This is only a dummy ebuild. Use e.g. octopus or palemoon overlay
www-client/palemoon-bin 27: This is only a dummy ebuild. Use e.g. palemoon overlay
-www-plugins/bookmark-deduplicator 1.3.1: Firefox plugin: Deduplicate your bookmarks
-www-plugins/bookmark-duplicate-cleaner 0.2: Firefox plugin: Remove duplicate bookmarks
-www-plugins/classic-theme-restorer 1.7.0: Firefox plugin: restore partially the functionality of non-broken firefox
-www-plugins/duckduckgo 1.1.22: Firefox plugin: enable duckduckgo search engine
-www-plugins/epubreader 1.5.0.12 2.0.5: Firefox plugin for ebook (.epub) files
-www-plugins/form-history-control 1.4.0.6: Edit the saved history of forms in mozilla
+www-plugins/bookmark-deduplicator 1.3.1-r1: <firefox-57 add-on: deduplicate your bookmarks
+www-plugins/bookmark-duplicate-cleaner 0.2-r1: <firefox-57 add-on: remove duplicate bookmarks
+www-plugins/classic-theme-restorer 1.7.0-r1: <firefox-57 add-on: restore partially the look of classical firefox
+www-plugins/duckduckgo 1.1.23: <firefox-57 add-on: enable duckduckgo search engine
+www-plugins/epubreader 1.5.0.12-r1 2.0.5-r1: Firefox webextension: read ebook (.epub) files
+www-plugins/form-history-control 1.4.0.6-r1: <firefox-57 add-on: edit the saved history of forms
www-plugins/google-translation 2.6: Firefox webextension: translate to your native language a selected text
-www-plugins/locale-switcher 3-r1: Firefox plugin: button to switch GUI locale
+www-plugins/locale-switcher 3-r2: <firefox-57 add-on: button to switch GUI locale
www-plugins/no-color 0.9: Firefox webextension: remove colors and background images from the page
-www-plugins/noscript 2.9.0.14 5.0.10: Mozilla plugin: Restrict active contents like java/javascript/flash
-www-plugins/requestpolicy 0.5.28-r1: Mozilla plugin: controll cross-site requests (increases privacy/security)
-www-plugins/stylus 1.1.4.1: Firefox plugin: Install themes and skins for many popular sites
+www-plugins/noscript 2.9.0.14-r1 5.0.10-r1: <firefox-57 add-on: restrict active contents like java/javascript/flash
+www-plugins/requestpolicy 0.5.28-r2: <firefox-57 add-on: control cross-site requests (increases privacy/security)
+www-plugins/stylus 1.1.4.1-r1: Firefox webextension: install themes and skins for many popular sites
www-plugins/translate-to-me 1.1: Firefox webextension: translate the selected text with www.linguee.com
-www-plugins/xclear 1.8.2: Firefox plugin: button to clear URL
+www-plugins/xclear 1.8.2-r1: <firefox-57 add-on: button to clear URL
x11-drivers/nvidia-drivers 173.14.39-r2: NVIDIA Accelerated Graphics Driver
x11-libs/gtk+ 2.24.31-r1 3.22.16 3.22.19: Gimp ToolKit +
x11-libs/motif 2.3.6-r1: The Motif user interface component toolkit
diff --git a/www-plugins/bookmark-deduplicator/Manifest b/www-plugins/bookmark-deduplicator/Manifest
index 05d976d9..ca22351e 100644
--- a/www-plugins/bookmark-deduplicator/Manifest
+++ b/www-plugins/bookmark-deduplicator/Manifest
@@ -1 +1 @@
-DIST bookmark_deduplicator-1.3.1-fx.xpi 19394 SHA256 02fca08f38ffb0b4e28ed2ad424287d6e4618dfd0b829c6526ad910738dfdbed
+DIST bookmark_deduplicator-1.3.1-fx.xpi 19394 SHA256 02fca08f38ffb0b4e28ed2ad424287d6e4618dfd0b829c6526ad910738dfdbed SHA512 e18ab7684a8ca25b3aca437d7ab9849d405c8888890da149cfcad7f8a9b8a5dc74d808fb978bc09a2df5f840be1b5c992c7a27709781d498fc1c4127828bf6de
diff --git a/www-plugins/bookmark-deduplicator/bookmark-deduplicator-1.3.1.ebuild b/www-plugins/bookmark-deduplicator/bookmark-deduplicator-1.3.1-r1.ebuild
index 783e6c08..6acd21a6 100644
--- a/www-plugins/bookmark-deduplicator/bookmark-deduplicator-1.3.1.ebuild
+++ b/www-plugins/bookmark-deduplicator/bookmark-deduplicator-1.3.1-r1.ebuild
@@ -7,7 +7,7 @@ RESTRICT="mirror"
MY_P="${P/-/_}"
NAME="${MY_P}-fx.xpi"
-DESCRIPTION="Firefox plugin: Deduplicate your bookmarks"
+DESCRIPTION="<firefox-57 add-on: deduplicate your bookmarks"
HOMEPAGE="https://addons.mozilla.org/en-US/firefox/addon/bookmark-deduplicator/"
SRC_URI="https://addons.cdn.mozilla.net/user-media/addons/422748/${NAME}"
@@ -16,4 +16,4 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-moz_defaults firefox palemoon
+moz_defaults '<firefox-57' palemoon
diff --git a/www-plugins/bookmark-duplicate-cleaner/Manifest b/www-plugins/bookmark-duplicate-cleaner/Manifest
index 439bf258..e5b7f1f6 100644
--- a/www-plugins/bookmark-duplicate-cleaner/Manifest
+++ b/www-plugins/bookmark-duplicate-cleaner/Manifest
@@ -1 +1 @@
-DIST bookmark_duplicate_cleaner-0.2-fx.xpi 9968 SHA256 4552188b01688f17b3ae1a7af7c85cfaa54c80f3c31146f33f84fcdb9ea0f396
+DIST bookmark_duplicate_cleaner-0.2-fx.xpi 9968 SHA256 4552188b01688f17b3ae1a7af7c85cfaa54c80f3c31146f33f84fcdb9ea0f396 SHA512 609c834fdb2d001472def6e57a18a19b940b8185613ff9bce95bf719f7a4e6ac41169fcdfd154321ff8e8512dbc6e9902d4d90902b61e74cc9a2730c22fdb20e
diff --git a/www-plugins/bookmark-duplicate-cleaner/bookmark-duplicate-cleaner-0.2.ebuild b/www-plugins/bookmark-duplicate-cleaner/bookmark-duplicate-cleaner-0.2-r1.ebuild
index ccc5bb80..d1cc0210 100644
--- a/www-plugins/bookmark-duplicate-cleaner/bookmark-duplicate-cleaner-0.2.ebuild
+++ b/www-plugins/bookmark-duplicate-cleaner/bookmark-duplicate-cleaner-0.2-r1.ebuild
@@ -8,7 +8,7 @@ RESTRICT="mirror"
MY_P="${P/-/_}"
MY_P="${MY_P/-/_}"
NAME="${MY_P}-fx.xpi"
-DESCRIPTION="Firefox plugin: Remove duplicate bookmarks"
+DESCRIPTION="<firefox-57 add-on: remove duplicate bookmarks"
HOMEPAGE="https://addons.mozilla.org/de/firefox/addon/bookmark-duplicate-cleaner/"
SRC_URI="https://addons.cdn.mozilla.net/user-media/addons/416156/${NAME}"
@@ -17,4 +17,4 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-moz_defaults firefox palemoon
+moz_defaults '<firefox-57' palemoon
diff --git a/www-plugins/classic-theme-restorer/classic-theme-restorer-1.7.0.ebuild b/www-plugins/classic-theme-restorer/classic-theme-restorer-1.7.0-r1.ebuild
index 833d4003..7360dcc3 100644
--- a/www-plugins/classic-theme-restorer/classic-theme-restorer-1.7.0.ebuild
+++ b/www-plugins/classic-theme-restorer/classic-theme-restorer-1.7.0-r1.ebuild
@@ -6,7 +6,7 @@ inherit mv_mozextension-r1
RESTRICT="mirror"
mPN="${PN//-/_}-${PV}"
-DESCRIPTION="Firefox plugin: restore partially the functionality of non-broken firefox"
+DESCRIPTION="<firefox-57 add-on: restore partially the look of classical firefox"
HOMEPAGE="https://addons.mozilla.org/de/firefox/addon/classicthemerestorer/"
SRC_URI="https://addons.cdn.mozilla.net/user-media/addons/472577/${mPN}-fx.xpi"
@@ -15,4 +15,4 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-moz_defaults firefox
+moz_defaults '<firefox-57'
diff --git a/www-plugins/duckduckgo/Manifest b/www-plugins/duckduckgo/Manifest
index f9b77109..2dd58d78 100644
--- a/www-plugins/duckduckgo/Manifest
+++ b/www-plugins/duckduckgo/Manifest
@@ -1 +1 @@
-DIST duckduckgo_plus-1.1.22-fx.xpi 1985099 SHA256 a13a5aa8b7fe294e6ce759918d6a0deff99efb1029f0aa43aafbfa96fd9ef9cf SHA512 e3a5201fbb4b9f53162b04615efa868db89ef90f33b7a853d0393570db1fe58b06ce8f3bb06f37df845339eedb990cc06accd25324cbacdde4a73515477e2f3d
+DIST duckduckgo_plus-1.1.23-fx.xpi 1985827 SHA256 48e1e453df3cb8aba31d5522225006e629c3d475acc2eb1472e45e278a5cafc4 SHA512 cb46c69b7a3ce8fa182e2f39149f6d2c2d1ee092711fbbe8276662d4d69524fe162c24673d70fef39572aa2ad8138460c4bebed157d71ff504224bd07dc2808a
diff --git a/www-plugins/duckduckgo/duckduckgo-1.1.22.ebuild b/www-plugins/duckduckgo/duckduckgo-1.1.23.ebuild
index 755efdad..526cf053 100644
--- a/www-plugins/duckduckgo/duckduckgo-1.1.22.ebuild
+++ b/www-plugins/duckduckgo/duckduckgo-1.1.23.ebuild
@@ -6,7 +6,7 @@ inherit mv_mozextension-r1
RESTRICT="mirror"
mPN="${PN}_plus-${PV}"
-DESCRIPTION="Firefox plugin: enable duckduckgo search engine"
+DESCRIPTION="<firefox-57 add-on: enable duckduckgo search engine"
HOMEPAGE="http://addons.mozilla.org/en-US/firefox/addon/duckduckgo-for-firefox/"
SRC_URI="https://addons.cdn.mozilla.net/user-media/addons/385621/${mPN}-fx.xpi"
@@ -15,4 +15,4 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-moz_defaults firefox
+moz_defaults '<firefox-57'
diff --git a/www-plugins/epubreader/Manifest b/www-plugins/epubreader/Manifest
index 67499f69..1e828323 100644
--- a/www-plugins/epubreader/Manifest
+++ b/www-plugins/epubreader/Manifest
@@ -1,2 +1,2 @@
-DIST epubreader-1.5.0.12-fx+sm.xpi 268172 SHA256 5fdd200f9e868273350e558d4e0457b5d313229448203d4b2ec586191b2aaf72
-DIST epubreader-2.0.5-an+fx.xpi 162455 SHA256 c360eb36775af8cc3c7fc0ed284c1898f442fe958c7cf38f53f2b8746c88e9a6
+DIST epubreader-1.5.0.12-fx+sm.xpi 268172 SHA256 5fdd200f9e868273350e558d4e0457b5d313229448203d4b2ec586191b2aaf72 SHA512 93d5e140e2e537c905455c3ea73d1258fcc3bdb44b49c688ad25f30bb8ea650b76c56cbae80177a7cb3e1719e68308b15e5693b8e94b75e1f1750b0a9eacaf5b
+DIST epubreader-2.0.5-an+fx.xpi 162455 SHA256 c360eb36775af8cc3c7fc0ed284c1898f442fe958c7cf38f53f2b8746c88e9a6 SHA512 8dbf9b4770c2a8660bfbffddc31a192b62a6cf3f8c9723ddabf206494d0afae76ddfed1801b83ca4a261db685aaff037fb33bacbfc7f1cf2c1c32301d06d7f44
diff --git a/www-plugins/epubreader/epubreader-1.5.0.12.ebuild b/www-plugins/epubreader/epubreader-1.5.0.12-r1.ebuild
index 58466c95..834df3cd 100644
--- a/www-plugins/epubreader/epubreader-1.5.0.12.ebuild
+++ b/www-plugins/epubreader/epubreader-1.5.0.12-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=6
inherit mv_mozextension-r1
RESTRICT="mirror"
-DESCRIPTION="Firefox plugin for ebook (.epub) files"
+DESCRIPTION="<firefox-57 add-on: read ebook (.epub) files"
HOMEPAGE="http://addons.mozilla.org/de/firefox/addon/epubreader/"
SRC_URI="https://addons.cdn.mozilla.net/user-media/addons/45281/${P}-fx+sm.xpi"
@@ -14,4 +14,4 @@ SLOT="1"
KEYWORDS="~amd64 ~x86"
IUSE=""
-moz_defaults
+moz_defaults '<firefox-57' palemoon seamonkey
diff --git a/www-plugins/epubreader/epubreader-2.0.5.ebuild b/www-plugins/epubreader/epubreader-2.0.5-r1.ebuild
index 2a7f1bc8..619731ba 100644
--- a/www-plugins/epubreader/epubreader-2.0.5.ebuild
+++ b/www-plugins/epubreader/epubreader-2.0.5-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=6
inherit mv_mozextension-r1
RESTRICT="mirror"
-DESCRIPTION="Firefox plugin for ebook (.epub) files"
+DESCRIPTION="Firefox webextension: read ebook (.epub) files"
HOMEPAGE="http://addons.mozilla.org/de/firefox/addon/epubreader/"
SRC_URI="https://addons.cdn.mozilla.net/user-media/addons/45281/${P}-an+fx.xpi"
@@ -14,9 +14,4 @@ SLOT="2"
KEYWORDS="~amd64 ~x86"
IUSE=""
-moz_defaults -i'{5384767E-00D9-40E9-B72F-9CC39D655D6F}' firefox
-
-DEPEND="${DEPEND}
- !${CATEGORY}/${PN}:1[browser_firefox]
- !${CATEGORY}/${PN}:1[browser_firefox-bin]
-"
+moz_defaults -i'{5384767E-00D9-40E9-B72F-9CC39D655D6F}' firefox seamonkey
diff --git a/www-plugins/form-history-control/Manifest b/www-plugins/form-history-control/Manifest
index a062d320..2105d436 100644
--- a/www-plugins/form-history-control/Manifest
+++ b/www-plugins/form-history-control/Manifest
@@ -1 +1 @@
-DIST form_history_control-1.4.0.6-sm+fx.xpi 579576 SHA256 c83e324fd1076eb54e78a659d2631bda0749a7ff69dfb1c484c9a88c887ddfc9
+DIST form_history_control-1.4.0.6-sm+fx.xpi 579576 SHA256 c83e324fd1076eb54e78a659d2631bda0749a7ff69dfb1c484c9a88c887ddfc9 SHA512 8ea8bd6326fb1b659a7117a9b99972b50b66f059584cdfb22009e1ff6e51b6ddf64b306b22038378f3ea3f8bc9c0c06c3d961a2574b79776bae8bd302d143162
diff --git a/www-plugins/form-history-control/form-history-control-1.4.0.6.ebuild b/www-plugins/form-history-control/form-history-control-1.4.0.6-r1.ebuild
index 764351a9..348cdad8 100644
--- a/www-plugins/form-history-control/form-history-control-1.4.0.6.ebuild
+++ b/www-plugins/form-history-control/form-history-control-1.4.0.6-r1.ebuild
@@ -8,7 +8,7 @@ RESTRICT="mirror"
MY_P="${P/-/_}"
MY_P="${MY_P/-/_}"
NAME="${MY_P}-sm+fx.xpi"
-DESCRIPTION="Edit the saved history of forms in mozilla"
+DESCRIPTION="<firefox-57 add-on: edit the saved history of forms"
HOMEPAGE="http://www.formhistory.blogspot.com/"
SRC_URI="http://addons.cdn.mozilla.net/user-media/addons/12021/${NAME}"
@@ -17,4 +17,4 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-moz_defaults
+moz_defaults '<firefox-57' palemoon seamonkey
diff --git a/www-plugins/locale-switcher/Manifest b/www-plugins/locale-switcher/Manifest
index ba11565b..dc93c57c 100644
--- a/www-plugins/locale-switcher/Manifest
+++ b/www-plugins/locale-switcher/Manifest
@@ -1 +1 @@
-DIST locale_switcher-3-fx.xpi 6853 SHA256 b48be1cc5570c646e233a27300988f1dc6e7c978cdee0bab9e5cce4777d14161
+DIST locale_switcher-3-fx.xpi 6853 SHA256 b48be1cc5570c646e233a27300988f1dc6e7c978cdee0bab9e5cce4777d14161 SHA512 c4b657b5f9ee5007d7f5a89fdf451a5eb613180d2833c38f21a230d823b84098497dd06c0c1dd8e45b59e437250ffba32946a40c35051527268605993b243786
diff --git a/www-plugins/locale-switcher/locale-switcher-3-r1.ebuild b/www-plugins/locale-switcher/locale-switcher-3-r2.ebuild
index f0cafe86..700d850b 100644
--- a/www-plugins/locale-switcher/locale-switcher-3-r1.ebuild
+++ b/www-plugins/locale-switcher/locale-switcher-3-r2.ebuild
@@ -7,7 +7,7 @@ RESTRICT="mirror"
MY_P="${P/-/_}"
NAME="${MY_P}-fx.xpi"
-DESCRIPTION="Firefox plugin: button to switch GUI locale"
+DESCRIPTION="<firefox-57 add-on: button to switch GUI locale"
HOMEPAGE="http://addons.mozilla.org/firefox/addon/locale-switcher/"
SRC_URI="https://addons.cdn.mozilla.net/user-media/addons/356/${NAME}"
@@ -16,4 +16,4 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-moz_defaults
+moz_defaults '<firefox-57' palemoon seamonkey
diff --git a/www-plugins/noscript/noscript-2.9.0.14.ebuild b/www-plugins/noscript/noscript-2.9.0.14-r1.ebuild
index 0762e6ef..54813020 100644
--- a/www-plugins/noscript/noscript-2.9.0.14.ebuild
+++ b/www-plugins/noscript/noscript-2.9.0.14-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=6
inherit mv_mozextension-r1
RESTRICT="mirror"
-DESCRIPTION="Mozilla plugin: Restrict active contents like java/javascript/flash"
+DESCRIPTION="<firefox-57 add-on: restrict active contents like java/javascript/flash"
HOMEPAGE="http://noscript.net/"
SRC_URI="https://secure.informaction.com/download/releases/${P}.xpi
https://addons.cdn.mozilla.net/user-media/addons/722/noscript_security_suite-${PV}-fx+fn+sm.xpi -> ${P}.xpi"
@@ -15,9 +15,4 @@ SLOT="palemoon26"
KEYWORDS="~amd64 ~x86"
IUSE=""
-moz_defaults palemoon
-
-DEPEND="${DEPEND}
- browser_palemoon? ( !${CATEGORY}/${PN}:0[browser_palemoon] )
- browser_palemoon-bin? ( !${CATEGORY}/${PN}:0[browser_palemoon-bin] )
-"
+moz_defaults '<palemoon-27'
diff --git a/www-plugins/noscript/noscript-5.0.10.ebuild b/www-plugins/noscript/noscript-5.0.10-r1.ebuild
index 5a1e86f6..21430640 100644
--- a/www-plugins/noscript/noscript-5.0.10.ebuild
+++ b/www-plugins/noscript/noscript-5.0.10-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=6
inherit mv_mozextension-r1
RESTRICT="mirror"
-DESCRIPTION="Mozilla plugin: Restrict active contents like java/javascript/flash"
+DESCRIPTION="<firefox-57 add-on: restrict active contents like java/javascript/flash"
HOMEPAGE="http://noscript.net/"
SRC_URI="https://secure.informaction.com/download/releases/${P}.xpi
https://addons.cdn.mozilla.net/user-media/addons/722/noscript_security_suite-${PV}-fx+sm.xpi -> ${P}.xpi"
@@ -15,11 +15,4 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-moz_atom() {
- case $1 in
- palemoon*)
- echo ">=$(moz_atom_default "$1")-27";;
- esac
-}
-
-moz_defaults
+moz_defaults '<firefox-57' '>=palemoon-27' seamonkey
diff --git a/www-plugins/requestpolicy/Manifest b/www-plugins/requestpolicy/Manifest
index 721c8243..0034fdfe 100644
--- a/www-plugins/requestpolicy/Manifest
+++ b/www-plugins/requestpolicy/Manifest
@@ -1 +1 @@
-DIST requestpolicy-0.5.28-sm+fx.xpi 165630 SHA256 f23b90aa6795ce6a9343a29d79b93c2fb6fa83b5c7b1e80ce829ee8446962bc9
+DIST requestpolicy-0.5.28-sm+fx.xpi 165630 SHA256 f23b90aa6795ce6a9343a29d79b93c2fb6fa83b5c7b1e80ce829ee8446962bc9 SHA512 27cdb397eb16ba8ca1ae841020893e11b1f8ac857a950f5528dc914c47c417a3c77c3779f82bcdbc0f45eff02b9b573d8f705826ac4ffe4d1c10c930152c1e37
diff --git a/www-plugins/requestpolicy/requestpolicy-0.5.28-r1.ebuild b/www-plugins/requestpolicy/requestpolicy-0.5.28-r2.ebuild
index f8d976a5..728b4969 100644
--- a/www-plugins/requestpolicy/requestpolicy-0.5.28-r1.ebuild
+++ b/www-plugins/requestpolicy/requestpolicy-0.5.28-r2.ebuild
@@ -5,7 +5,7 @@ EAPI=6
inherit mv_mozextension-r1
RESTRICT="mirror"
-DESCRIPTION="Mozilla plugin: controll cross-site requests (increases privacy/security)"
+DESCRIPTION="<firefox-57 add-on: control cross-site requests (increases privacy/security)"
HOMEPAGE="https://www.requestpolicy.com/"
SRC_URI="https://addons.cdn.mozilla.net/user-media/addons/9727/${P}-sm+fx.xpi"
@@ -14,4 +14,4 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-moz_defaults
+moz_defaults '<firefox-57' palemoon seamonkey
diff --git a/www-plugins/stylus/stylus-1.1.4.1.ebuild b/www-plugins/stylus/stylus-1.1.4.1-r1.ebuild
index 2157fc88..4cdea2e6 100644
--- a/www-plugins/stylus/stylus-1.1.4.1.ebuild
+++ b/www-plugins/stylus/stylus-1.1.4.1-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=6
inherit mv_mozextension-r1 readme.gentoo-r1
RESTRICT="mirror"
-DESCRIPTION="Firefox plugin: Install themes and skins for many popular sites"
+DESCRIPTION="Firefox webextension: install themes and skins for many popular sites"
HOMEPAGE="https://addons.mozilla.org/en-US/firefox/addon/styl-us/"
SRC_URI="https://addons.cdn.mozilla.net/user-media/addons/814814/${PN}_beta-${PV}-an+fx.xpi"
diff --git a/www-plugins/xclear/Manifest b/www-plugins/xclear/Manifest
index f2c8660b..9c87011f 100644
--- a/www-plugins/xclear/Manifest
+++ b/www-plugins/xclear/Manifest
@@ -1 +1 @@
-DIST xclear-1.8.2-fx+sm.xpi 8803 SHA256 aed473c5a6065fb02ec13b9dc7fd86d033e71a862358c69a9c793afed8b91d6b
+DIST xclear-1.8.2-fx+sm.xpi 8803 SHA256 aed473c5a6065fb02ec13b9dc7fd86d033e71a862358c69a9c793afed8b91d6b SHA512 ea3d678b4b0252c891938e1f3a74a17aeb9c3391ffebf953e7b35d21e8415f99b673dad5baf31162cd49d80f871619bd54562e6286e76c246bc4c4fc09b1dfe5
diff --git a/www-plugins/xclear/xclear-1.8.2.ebuild b/www-plugins/xclear/xclear-1.8.2-r1.ebuild
index 540c7c5e..29864e3e 100644
--- a/www-plugins/xclear/xclear-1.8.2.ebuild
+++ b/www-plugins/xclear/xclear-1.8.2-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=6
inherit mv_mozextension-r1
RESTRICT="mirror"
-DESCRIPTION="Firefox plugin: button to clear URL"
+DESCRIPTION="<firefox-57 add-on: button to clear URL"
HOMEPAGE="http://addons.mozilla.org/firefox/addon/xclear/"
SRC_URI="https://addons.cdn.mozilla.net/user-media/addons/13078/${P}-fx+sm.xpi"
@@ -14,4 +14,4 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-moz_defaults
+moz_defaults '<firefox-57' palemoon seamonkey