summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--eclass/ChangeLog5
-rw-r--r--eclass/mv_mozextension-r1.eclass84
-rw-r--r--metadata/pkg_desc_index16
-rw-r--r--www-client/palemoon-bin/metadata.xml8
-rw-r--r--www-client/palemoon-bin/palemoon-bin-26.ebuild13
-rw-r--r--www-client/palemoon-bin/palemoon-bin-27.ebuild13
-rw-r--r--www-client/palemoon/metadata.xml8
-rw-r--r--www-client/palemoon/palemoon-27.ebuild13
-rw-r--r--www-plugins/bookmark-deduplicator/Manifest1
-rw-r--r--www-plugins/bookmark-deduplicator/bookmark-deduplicator-1.3.1-r1.ebuild19
-rw-r--r--www-plugins/bookmark-deduplicator/metadata.xml8
-rw-r--r--www-plugins/bookmark-duplicate-cleaner/Manifest1
-rw-r--r--www-plugins/bookmark-duplicate-cleaner/bookmark-duplicate-cleaner-0.2-r1.ebuild20
-rw-r--r--www-plugins/bookmark-duplicate-cleaner/metadata.xml8
-rw-r--r--www-plugins/classic-theme-restorer/Manifest1
-rw-r--r--www-plugins/classic-theme-restorer/classic-theme-restorer-1.7.3.4.ebuild18
-rw-r--r--www-plugins/classic-theme-restorer/metadata.xml8
-rw-r--r--www-plugins/duckduckgo/Manifest1
-rw-r--r--www-plugins/duckduckgo/duckduckgo-1.1.26.ebuild18
-rw-r--r--www-plugins/epubreader/Manifest1
-rw-r--r--www-plugins/epubreader/epubreader-1.5.0.12-r2.ebuild17
-rw-r--r--www-plugins/form-history-control/Manifest1
-rw-r--r--www-plugins/form-history-control/form-history-control-1.4.0.6-r2.ebuild17
-rw-r--r--www-plugins/locale-switcher/Manifest1
-rw-r--r--www-plugins/locale-switcher/locale-switcher-3-r2.ebuild19
-rw-r--r--www-plugins/locale-switcher/metadata.xml8
-rw-r--r--www-plugins/noscript/Manifest1
-rw-r--r--www-plugins/noscript/noscript-5.1.8.4.ebuild18
-rw-r--r--www-plugins/requestpolicy/Manifest1
-rw-r--r--www-plugins/requestpolicy/metadata.xml8
-rw-r--r--www-plugins/requestpolicy/requestpolicy-0.5.28-r2.ebuild17
-rw-r--r--www-plugins/xclear/Manifest1
-rw-r--r--www-plugins/xclear/metadata.xml8
-rw-r--r--www-plugins/xclear/xclear-1.8.2-r1.ebuild17
34 files changed, 45 insertions, 353 deletions
diff --git a/eclass/ChangeLog b/eclass/ChangeLog
index bf4c76a6..9a5d4909 100644
--- a/eclass/ChangeLog
+++ b/eclass/ChangeLog
@@ -1,5 +1,5 @@
# ChangeLog for eclass directory
-# Copyright 2018 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 2012-2018 Gentoo Foundation; Distributed under the GPL v2
12 May 2012; Martin Väth <martin@mvath.de>:
Created ChangeLog
@@ -77,3 +77,6 @@
27 Jan 2018; Martin Väth <martin@mvath.de>:
mv_mozextension-r1.eclass: manifest.json: search "id" only inside "gecko"
+
+ 14 Apr 2018; Martin Väth <martin@mvath.de>:
+ mv_mozextension-r1.eclass: remove support for legacy extensions
diff --git a/eclass/mv_mozextension-r1.eclass b/eclass/mv_mozextension-r1.eclass
index 7062cd3a..8d99800c 100644
--- a/eclass/mv_mozextension-r1.eclass
+++ b/eclass/mv_mozextension-r1.eclass
@@ -1,4 +1,4 @@
-# Copyright 2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: mv_mozextension-r1.eclass
@@ -12,12 +12,12 @@
# @CODE
# inherit mv_mozextension-r1
#
-# moz_defaults firefox palemoon seamonkey # no arguments mean all browsers
+# moz_defaults firefox seamonkey # no arguments mean all browsers
#
# @CODE
# inherit mv_mozextension-r1
#
-# MOZ="<firefox-57 palemoon seamonkey"
+# MOZ="<firefox-57 seamonkey"
# DEPEND=${MOZ_DEPEND}
# RDEPEND=$(moz_rdepend ${MOZ})
# IUSE=$(moz_iuse ${MOZ})
@@ -49,7 +49,7 @@ moz_defaults() {
# @USAGE: [-c|-C|-n] [-i id] [--] [<browser>] [<browser>] [...]
# @DESCRIPTION:
# Sets the variables DEPEND, RDEPEND, IUSE, REQUIRED_USE for browsers.
-# browser is (firefox|seamonkey|palemoon) and implies source or binary version.
+# browser is (firefox|seamonkey) and implies source or binary version.
# If no browser is specified, all are assumed.
# If option -C or -n is specified, IUSE=compressed is not default/added.
moz_variables() {
@@ -109,11 +109,11 @@ MOZ_DEPEND='app-arch/unzip'
# @FUNCTION: moz_split_browser
# @USAGE: <browser>
# @DESCRIPTION:
-# browser is one of [operator](firefox|palemoon|seamonkey)[-source|-bin][*].
+# browser is one of [operator](firefox|seamonkey)[-source|-bin][*].
# The function outputs the "browser[-source|-bin]" part
moz_split_browser() {
local browser
- for browser in firefox palemoon seamonkey
+ for browser in firefox seamonkey
do case ${1} in
*"${browser}"?source*)
echo "${browser}-source"
@@ -126,17 +126,17 @@ moz_split_browser() {
return;;
esac
done
- die "args must be [operator](firefox|palemoon|seamonkey)[-source|-bin][*]"
+ die "args must be [operator](firefox|seamonkey)[-source|-bin][*]"
}
# @FUNCTION: moz_split_operator
# @USAGE: <browser>
# @DESCRIPTION:
-# browser is one of [operator](firefox|palemoon|seamonkey)[-source|-bin][*].
+# browser is one of [operator](firefox|seamonkey)[-source|-bin][*].
# The function outputs the "[operator]" part
moz_split_operator() {
local browser operator
- for browser in firefox palemoon seamonkey
+ for browser in firefox seamonkey
do case ${1} in
*"${browser}"*)
operator=${1%%"${browser}"*}
@@ -144,17 +144,17 @@ moz_split_operator() {
return;;
esac
done
- die "args must be [operator](firefox|palemoon|seamonkey)[-source|-bin][*]"
+ die "args must be [operator](firefox|seamonkey)[-source|-bin][*]"
}
# @FUNCTION: moz_split_rest
# @USAGE: <browser>
# @DESCRIPTION:
-# browser is one of [operator](firefox|palemoon|seamonkey)[-source|-bin][*].
+# browser is one of [operator](firefox|seamonkey)[-source|-bin][*].
# The function outputs the "[*]" part
moz_split_rest() {
local front rest
- for front in source bin firefox palemoon seamonkey
+ for front in source bin firefox seamonkey
do case ${1} in
*"${front}"*)
rest=${1#*"${front}"}
@@ -162,7 +162,7 @@ moz_split_rest() {
return;;
esac
done
- die "args must be [operator](firefox|palemoon|seamonkey)[-source|-bin][*]"
+ die "args must be [operator](firefox|seamonkey)[-source|-bin][*]"
}
# @FUNCTION: moz_atom
@@ -170,7 +170,7 @@ moz_split_rest() {
# @DESCRIPTION:
# Prints the atom/subexpression used in RDEPEND for the corresponding browser,
# e.g. [operator]www-client/firefox-bin[rest]
-# browser is one of (firefox|palemoon|seamonkey)(-source|-bin)
+# browser is one of (firefox|seamonkey)(-source|-bin)
# If nothing is printed, the output of
# "moz_atom_default <browser> <operator> <rest>"
# is used (see below).
@@ -182,7 +182,7 @@ moz_split_rest() {
# @DESCRIPTION:
# Prints the atom/subexpression used in RDEPEND for the corresponding browser,
# when moz_atom is not defined or prints nothing.
-# browser is one of (firefox|palemoon|seamonkey)(-source|-bin).
+# browser is one of (firefox|seamonkey)(-source|-bin).
moz_atom_default() {
echo "${2}www-client/${1%?source}${3}"
}
@@ -191,13 +191,13 @@ moz_atom_default() {
# @USAGE: [<browser>] [<browser>] [...]
# @DESCRIPTION:
# Outputs RDEPEND expression appropriate for browsers.
-# browser is one of [operator](firefox|palemoon|seamonkey)[-source|-bin][*]
+# browser is one of [operator](firefox|seamonkey)[-source|-bin][*]
# (none specified = all browsers)
# Note that moz_rdepend_atom (if defined by the ebuild) is used to calculate
# the expression.
moz_rdepend() {
local arg rdep browser count modes mode atom useflag operator rest
- [ ${#} -ne 0 ] || set -- firefox palemoon seamonkey
+ [ ${#} -ne 0 ] || set -- firefox seamonkey
count=
rdep=
for arg
@@ -232,7 +232,7 @@ moz_rdepend() {
# @USAGE: [-c|-C|-n] [--] [<browser>] [<browser>] [...]
# @DESCRIPTION:
# Outputs IUSE expression appropriate for browsers.
-# browser is [opertator](firefox|palemoon|seamonkey)[-source|-bin][*]
+# browser is [opertator](firefox|seamonkey)[-source|-bin][*]
# (none specified = all browsers).
# If option -C or -n is specified, IUSE=compressed is not default/added.
moz_iuse() {
@@ -247,8 +247,8 @@ moz_iuse() {
esac
done
shift $(( ${OPTIND} - 1 ))
- [ ${#} -ne 0 ] || set -- firefox palemoon seamonkey
- for i in firefox palemoon seamonkey
+ [ ${#} -ne 0 ] || set -- firefox seamonkey
+ for i in firefox seamonkey
do case "${*}" in
*"${i}"?source*)
iuse=${iuse}${iuse:+\ }"browser_${i}";;
@@ -258,7 +258,7 @@ moz_iuse() {
iuse=${iuse}${iuse:+\ }"browser_${i} browser_${i}-bin";;
esac
done
- [ -n "${iuse}" ] || die "args must be [operator](firefox|palemoon|seamonkey)[-source|-bin][*]"
+ [ -n "${iuse}" ] || die "args must be [operator](firefox|seamonkey)[-source|-bin][*]"
echo "${iuse}"
}
@@ -266,7 +266,7 @@ moz_iuse() {
# @USAGE: [<browser>] [<browser>] [...]
# @DESCRIPTION:
# Outputs REQUIRED_USE expression appropriate for browsers.
-# browser is [operator](firefox|palemoon|seamonkey)[-source|-bin][*]
+# browser is [operator](firefox|seamonkey)[-source|-bin][*]
# (none specified = all browsers).
moz_required_use() {
set -- $(moz_iuse -n "${@}")
@@ -327,8 +327,8 @@ moz_unpack() {
cd -- "${S}/${xpiname}" || die
if ${comp}
then if ! ${id}
- then einfo "Extracting install.rdf/manifest.json for ${xpiname}"
- unzip -qo -- "${archiv}" install.rdf manifest.json
+ then einfo "Extracting manifest.json for ${xpiname}"
+ unzip -qo -- "${archiv}" manifest.json
# Do not die on failure: One of the two files will not exist
fi
else einfo "Unpacking ${xpiname}"
@@ -339,9 +339,9 @@ moz_unpack() {
}
# @FUNCTION: moz_getid
-# @USAGE: <variable> [<path/to/[install.rdf,manifest.json]>]
+# @USAGE: <variable> [<path/to/manifest.json>]
# @DESCRIPTION:
-# Extracts the package id from the install.rdf/manifest.json
+# Extracts the package id from the manifest.json
# and stores the result in the variable.
moz_getid() {
local var res sub dir file
@@ -350,17 +350,12 @@ moz_getid() {
dir=${2:-.}
dir=${dir%/}
test -d "${dir}" || die "moz_getid: argument must be a directory"
- file=${dir}/install.rdf
- if test -f "${file}"
- then sub='{ /\<\(em:\)*id\>/!d; s/.*[\">]\([^\"<>]*\)[\"<].*/\1/; p; q }'
- res=$(sed -n -e '/install-manifest/,$ '"${sub}" -- "${file}") || res=
- else file=${dir}/manifest.json
- test -f "${file}" || die "cannot find ${dir}/{install.rdf,manifest.json}"
- sub='/^[[:space:]]*["'\'']gecko["'\''][[:space:]]*:/,/\}/s/'
- sub=${sub}'^[[:space:]]*["'\'']id["'\''][[:space:]]*:[[:space:]]*'
- sub=${sub}'["'\'']\(.*\)["'\''][[:space:]]*,\?[[:space:]]*$/\1/p'
- res=$(sed -n -e "${sub}" -- "${file}") || res=
- fi
+ file=${dir}/manifest.json
+ test -f "${file}" || die "cannot find ${file}"
+ sub='/^[[:space:]]*["'\'']gecko["'\''][[:space:]]*:/,/\}/s/'
+ sub=${sub}'^[[:space:]]*["'\'']id["'\''][[:space:]]*:[[:space:]]*'
+ sub=${sub}'["'\'']\(.*\)["'\''][[:space:]]*,\?[[:space:]]*$/\1/p'
+ res=$(sed -n -e "${sub}" -- "${file}") || res=
[ -n "${res}" ] || die "failed to determine id from ${file}"
eval ${var}=\${res}
}
@@ -368,8 +363,8 @@ moz_getid() {
# @FUNCTION: moz_install_to_dir
# @USAGE: [-n] [-i id] [--] <extension-directory> <dir> <dir> [...]
# @DESCRIPTION:
-# Installs dir.xpi as (id) of extension-directory,
-# the name of the id being determined from ${dir}/install.rdf.
+# Installs dir.xpi as (id) of extension-directory.
+# If -i is not passed it is determined from ${dir}/manifest.json
# Arguments which are not directories are silently ignored.
# If arguments are specified, they must contain at least one directory.
# If no argument is specified, all directories from "${S}" are considered.
@@ -414,13 +409,13 @@ moz_install_to_dir() {
# @USAGE: [-n] [-i id] [--] <browser> <dir> <dir> [...]
# @DESCRIPTION:
# Installs dirs.xpi for browser.
-# browser is [operator](firefox|palemoon|seymonkey)[-source|-bin][*]
+# browser is [operator](firefox|seymonkey)[-source|-bin][*]
# Arguments which are not directories are silently ignored.
# If arguments are specified, they must contain at least one directory.
# If no argument is specified, all directories from "${S}" are considered.
# Option -n means nocompression mode: Install dirs instead of dirs.xpi.
moz_install_for_browser() {
- local dest firefox palemoon seamonkey o opt
+ local dest firefox seamonkey o opt
o=()
OPTIND=1
while getopts 'cni:' opt
@@ -434,17 +429,12 @@ moz_install_for_browser() {
shift $(( ${OPTIND} - 1 ))
[ ${#} -ne 0 ] || die "${FUNCNAME} needs at least one argument"
firefox="firefox/browser/extensions"
- palemoon="palemoon/browser/extensions"
seamonkey="seamonkey/extensions"
case ${1} in
*firefox*bin*)
dest="/opt/${firefox}";;
*firefox*)
dest="/usr/$(get_libdir)/${firefox}";;
- *palemoon?bin*)
- dest="/opt/${palemoon}";;
- *palemoon*)
- dest="/usr/$(get_libdir)/${palemoon}";;
*seamonkey?bin*)
dest="/opt/${seamonkey}";;
*seamonkey*)
@@ -483,7 +473,7 @@ moz_install() {
then o="-n"
else o=
fi
- for i in firefox firefox-bin palemoon palemoon-bin seamonkey seamonkey-bin
+ for i in firefox firefox-bin seamonkey seamonkey-bin
do if in_iuse "browser_${i}" && use "browser_${i}"
then moz_install_for_browser ${o} ${id:+-i "$id"} -- "${i}" "${@}"
fi
diff --git a/metadata/pkg_desc_index b/metadata/pkg_desc_index
index 32319094..3a3d087d 100644
--- a/metadata/pkg_desc_index
+++ b/metadata/pkg_desc_index
@@ -104,32 +104,24 @@ sys-kernel/kccmp 0.3-r1: A simple tool for comparing two linux kernel .config fi
sys-kernel/kernel 4.5: A POSIX shell script to compile the kernel with user permissions
sys-power/nut 2.7.4-r1: Network-UPS Tools
virtual/freedesktop-icon-theme 0-r3: A virtual to choose between different icon themes
-www-client/palemoon 27: This is only a dummy ebuild. Use e.g. octopus or palemoon overlay
-www-client/palemoon-bin 26 27: This is only a dummy ebuild. Use e.g. palemoon overlay
-www-plugins/bookmark-deduplicator 1.3.1-r1: Firefox legacy add-on: deduplicate your bookmarks
www-plugins/bookmark-dupes 5.7: Firefox webextension: remove duplicate bookmarks/empty folders/descriptions
-www-plugins/bookmark-duplicate-cleaner 0.2-r1: Firefox legacy add-on: remove duplicate bookmarks
www-plugins/calc-extension 5.1: Firefox webextension: calculate values of mathematical expressions
www-plugins/canvasblocker 0.4.4b: Firefox webextension: block canvas API to prevent canvas fingerprinting
-www-plugins/classic-theme-restorer 1.7.3.4: Firefox legacy add-on: restore partially the look of classical firefox
www-plugins/dark-mode 0.2.3: Firefox webextension: a global dark theme for the web
www-plugins/decentraleyes 2.0.3: Firefox webextension: avoid centralized services
-www-plugins/duckduckgo 1.1.26 2018.3.29.1: Firefox webextension: privacy essentials, including duckduckgo search engine
-www-plugins/epubreader 1.5.0.12-r2 2.0.5-r2: Firefox webextension: read ebook (.epub) files
-www-plugins/form-history-control 1.4.0.6-r2 2.0.3.2: Firefox webextension: edit the saved history of forms
+www-plugins/duckduckgo 2018.3.29.1: Firefox webextension: privacy essentials, including duckduckgo search engine
+www-plugins/epubreader 2.0.5-r2: Firefox webextension: read ebook (.epub) files
+www-plugins/form-history-control 2.0.3.2: Firefox webextension: edit the saved history of forms
www-plugins/google-translation 2.6: Firefox webextension: translate to your native language a selected text
www-plugins/https-everywhere 2018.4.11: Firefox webextension: force https for all websites of a provided list
-www-plugins/locale-switcher 3-r2: Firefox legacy add-on: button to switch GUI locale
www-plugins/no-color 0.9.4: Firefox webextension: remove colors and background images from the page
-www-plugins/noscript 5.1.8.4 10.1.7.2 10.1.7.5: Firefox webextension: restrict active contents like java/javascript/flash
+www-plugins/noscript 10.1.7.2 10.1.7.5: Firefox webextension: restrict active contents like java/javascript/flash
www-plugins/open-in-google-translate 0.1.3: Firefox webextension: open selected text or webpage in google translator
-www-plugins/requestpolicy 0.5.28-r2: Firefox legacy add-on: control cross-site requests
www-plugins/simple-calculator 1.3.2: Firefox webextension: a basic simple math calculator
www-plugins/skip-redirect 2.2.1: Firefox webextension: skip intermediary pages before redirecting
www-plugins/stylus 1.3.17: Firefox webextension: install themes and skins for many popular sites
www-plugins/translate-to-me 1.1: Firefox webextension: translate the selected text with www.linguee.com
www-plugins/ublock-origin 1.15.24: Firefox webextension: An efficient list-based blocker
-www-plugins/xclear 1.8.2-r1: Firefox legacy add-on: button to clear URL
x11-libs/gtk+ 2.24.31-r1 3.22.19 3.22.26: Gimp ToolKit +
x11-libs/motif 2.3.7 2.3.8-r1: The Motif user interface component toolkit
x11-misc/redshift 1.8: A screen color temperature adjusting software
diff --git a/www-client/palemoon-bin/metadata.xml b/www-client/palemoon-bin/metadata.xml
deleted file mode 100644
index b919c846..00000000
--- a/www-client/palemoon-bin/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>martin@mvath.de</email>
- <name>Martin Väth</name>
- </maintainer>
-</pkgmetadata>
diff --git a/www-client/palemoon-bin/palemoon-bin-26.ebuild b/www-client/palemoon-bin/palemoon-bin-26.ebuild
deleted file mode 100644
index 613c0f54..00000000
--- a/www-client/palemoon-bin/palemoon-bin-26.ebuild
+++ /dev/null
@@ -1,13 +0,0 @@
-# Copyright 2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="This is only a dummy ebuild. Use e.g. palemoon overlay"
-HOMEPAGE="https://www.palemoon.org/"
-SRC_URI=""
-
-LICENSE="MPL-2.0 GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
diff --git a/www-client/palemoon-bin/palemoon-bin-27.ebuild b/www-client/palemoon-bin/palemoon-bin-27.ebuild
deleted file mode 100644
index 613c0f54..00000000
--- a/www-client/palemoon-bin/palemoon-bin-27.ebuild
+++ /dev/null
@@ -1,13 +0,0 @@
-# Copyright 2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="This is only a dummy ebuild. Use e.g. palemoon overlay"
-HOMEPAGE="https://www.palemoon.org/"
-SRC_URI=""
-
-LICENSE="MPL-2.0 GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
diff --git a/www-client/palemoon/metadata.xml b/www-client/palemoon/metadata.xml
deleted file mode 100644
index b919c846..00000000
--- a/www-client/palemoon/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>martin@mvath.de</email>
- <name>Martin Väth</name>
- </maintainer>
-</pkgmetadata>
diff --git a/www-client/palemoon/palemoon-27.ebuild b/www-client/palemoon/palemoon-27.ebuild
deleted file mode 100644
index a34f30c6..00000000
--- a/www-client/palemoon/palemoon-27.ebuild
+++ /dev/null
@@ -1,13 +0,0 @@
-# Copyright 2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="This is only a dummy ebuild. Use e.g. octopus or palemoon overlay"
-HOMEPAGE="https://www.palemoon.org/"
-SRC_URI=""
-
-LICENSE="MPL-2.0 GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
diff --git a/www-plugins/bookmark-deduplicator/Manifest b/www-plugins/bookmark-deduplicator/Manifest
deleted file mode 100644
index ca22351e..00000000
--- a/www-plugins/bookmark-deduplicator/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST bookmark_deduplicator-1.3.1-fx.xpi 19394 SHA256 02fca08f38ffb0b4e28ed2ad424287d6e4618dfd0b829c6526ad910738dfdbed SHA512 e18ab7684a8ca25b3aca437d7ab9849d405c8888890da149cfcad7f8a9b8a5dc74d808fb978bc09a2df5f840be1b5c992c7a27709781d498fc1c4127828bf6de
diff --git a/www-plugins/bookmark-deduplicator/bookmark-deduplicator-1.3.1-r1.ebuild b/www-plugins/bookmark-deduplicator/bookmark-deduplicator-1.3.1-r1.ebuild
deleted file mode 100644
index c4a41696..00000000
--- a/www-plugins/bookmark-deduplicator/bookmark-deduplicator-1.3.1-r1.ebuild
+++ /dev/null
@@ -1,19 +0,0 @@
-# Copyright 2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit mv_mozextension-r1
-RESTRICT="mirror"
-
-MY_P="${P/-/_}"
-NAME="${MY_P}-fx.xpi"
-DESCRIPTION="Firefox legacy add-on: deduplicate your bookmarks"
-HOMEPAGE="https://addons.mozilla.org/en-US/firefox/addon/bookmark-deduplicator/"
-SRC_URI="https://addons.cdn.mozilla.net/user-media/addons/422748/${NAME}"
-
-LICENSE="MPL-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-moz_defaults '<firefox-57' palemoon
diff --git a/www-plugins/bookmark-deduplicator/metadata.xml b/www-plugins/bookmark-deduplicator/metadata.xml
deleted file mode 100644
index b919c846..00000000
--- a/www-plugins/bookmark-deduplicator/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>martin@mvath.de</email>
- <name>Martin Väth</name>
- </maintainer>
-</pkgmetadata>
diff --git a/www-plugins/bookmark-duplicate-cleaner/Manifest b/www-plugins/bookmark-duplicate-cleaner/Manifest
deleted file mode 100644
index e5b7f1f6..00000000
--- a/www-plugins/bookmark-duplicate-cleaner/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST bookmark_duplicate_cleaner-0.2-fx.xpi 9968 SHA256 4552188b01688f17b3ae1a7af7c85cfaa54c80f3c31146f33f84fcdb9ea0f396 SHA512 609c834fdb2d001472def6e57a18a19b940b8185613ff9bce95bf719f7a4e6ac41169fcdfd154321ff8e8512dbc6e9902d4d90902b61e74cc9a2730c22fdb20e
diff --git a/www-plugins/bookmark-duplicate-cleaner/bookmark-duplicate-cleaner-0.2-r1.ebuild b/www-plugins/bookmark-duplicate-cleaner/bookmark-duplicate-cleaner-0.2-r1.ebuild
deleted file mode 100644
index 9206ee20..00000000
--- a/www-plugins/bookmark-duplicate-cleaner/bookmark-duplicate-cleaner-0.2-r1.ebuild
+++ /dev/null
@@ -1,20 +0,0 @@
-# Copyright 2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit mv_mozextension-r1
-RESTRICT="mirror"
-
-MY_P="${P/-/_}"
-MY_P="${MY_P/-/_}"
-NAME="${MY_P}-fx.xpi"
-DESCRIPTION="Firefox legacy add-on: remove duplicate bookmarks"
-HOMEPAGE="https://addons.mozilla.org/en-US/firefox/addon/bookmark-duplicate-cleaner/"
-SRC_URI="https://addons.cdn.mozilla.net/user-media/addons/416156/${NAME}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-moz_defaults '<firefox-57' palemoon
diff --git a/www-plugins/bookmark-duplicate-cleaner/metadata.xml b/www-plugins/bookmark-duplicate-cleaner/metadata.xml
deleted file mode 100644
index b919c846..00000000
--- a/www-plugins/bookmark-duplicate-cleaner/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>martin@mvath.de</email>
- <name>Martin Väth</name>
- </maintainer>
-</pkgmetadata>
diff --git a/www-plugins/classic-theme-restorer/Manifest b/www-plugins/classic-theme-restorer/Manifest
deleted file mode 100644
index b0763de9..00000000
--- a/www-plugins/classic-theme-restorer/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST classic_theme_restorer_fx29_56-1.7.3.4-fx.xpi 1070216 SHA512 761d405baf907500731f8064c91a4bca402a7a7c0274cd8585cf858553d457e9b9b652fb7fe75bb78e5068ad1105117834afe852ab99d0ccc5363ce0cbe3d604
diff --git a/www-plugins/classic-theme-restorer/classic-theme-restorer-1.7.3.4.ebuild b/www-plugins/classic-theme-restorer/classic-theme-restorer-1.7.3.4.ebuild
deleted file mode 100644
index ce4e5f6e..00000000
--- a/www-plugins/classic-theme-restorer/classic-theme-restorer-1.7.3.4.ebuild
+++ /dev/null
@@ -1,18 +0,0 @@
-# Copyright 2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit mv_mozextension-r1
-RESTRICT="mirror"
-
-mPN="${PN//-/_}_fx29_56-${PV}"
-DESCRIPTION="Firefox legacy add-on: restore partially the look of classical firefox"
-HOMEPAGE="https://addons.mozilla.org/en-US/firefox/addon/classicthemerestorer/"
-SRC_URI="https://addons.cdn.mozilla.net/user-media/addons/472577/${mPN}-fx.xpi"
-
-LICENSE="MPL-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-moz_defaults '<firefox-57'
diff --git a/www-plugins/classic-theme-restorer/metadata.xml b/www-plugins/classic-theme-restorer/metadata.xml
deleted file mode 100644
index b919c846..00000000
--- a/www-plugins/classic-theme-restorer/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>martin@mvath.de</email>
- <name>Martin Väth</name>
- </maintainer>
-</pkgmetadata>
diff --git a/www-plugins/duckduckgo/Manifest b/www-plugins/duckduckgo/Manifest
index 8dbc5eb2..a0e654cb 100644
--- a/www-plugins/duckduckgo/Manifest
+++ b/www-plugins/duckduckgo/Manifest
@@ -1,2 +1 @@
-DIST duckduckgo_plus-1.1.26-fx.xpi 2031610 SHA512 58ce236a0422573744cc4e4b99c2d78f65b3c74201fba25ae0d49198ecde44efd16dec7d325e0763d02442d41c844370ab275452687b80cf517ce97dc10a04f6
DIST duckduckgo_privacy_essentials-2018.3.29.1-an+fx.xpi 638170 SHA512 ec43b0c64f3b7e7205e56e159a7824ae1caf3c3a96621ed3f989ecd577b627189c8e5c96847ef595c86f40923435f454ca445e1c89d943429c984949c2641125
diff --git a/www-plugins/duckduckgo/duckduckgo-1.1.26.ebuild b/www-plugins/duckduckgo/duckduckgo-1.1.26.ebuild
deleted file mode 100644
index 95fbe016..00000000
--- a/www-plugins/duckduckgo/duckduckgo-1.1.26.ebuild
+++ /dev/null
@@ -1,18 +0,0 @@
-# Copyright 2012-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit mv_mozextension-r1
-RESTRICT="mirror"
-
-mPN="${PN}_plus-${PV}"
-DESCRIPTION="Firefox legacy add-on: enable duckduckgo search engine"
-HOMEPAGE="http://addons.mozilla.org/en-US/firefox/addon/duckduckgo-for-firefox/"
-SRC_URI="https://addons.cdn.mozilla.net/user-media/addons/385621/${mPN}-fx.xpi"
-
-LICENSE="Apache-2.0"
-SLOT="legacy"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-moz_defaults '<firefox-57'
diff --git a/www-plugins/epubreader/Manifest b/www-plugins/epubreader/Manifest
index 1e828323..6b652892 100644
--- a/www-plugins/epubreader/Manifest
+++ b/www-plugins/epubreader/Manifest
@@ -1,2 +1 @@
-DIST epubreader-1.5.0.12-fx+sm.xpi 268172 SHA256 5fdd200f9e868273350e558d4e0457b5d313229448203d4b2ec586191b2aaf72 SHA512 93d5e140e2e537c905455c3ea73d1258fcc3bdb44b49c688ad25f30bb8ea650b76c56cbae80177a7cb3e1719e68308b15e5693b8e94b75e1f1750b0a9eacaf5b
DIST epubreader-2.0.5-an+fx.xpi 162455 SHA256 c360eb36775af8cc3c7fc0ed284c1898f442fe958c7cf38f53f2b8746c88e9a6 SHA512 8dbf9b4770c2a8660bfbffddc31a192b62a6cf3f8c9723ddabf206494d0afae76ddfed1801b83ca4a261db685aaff037fb33bacbfc7f1cf2c1c32301d06d7f44
diff --git a/www-plugins/epubreader/epubreader-1.5.0.12-r2.ebuild b/www-plugins/epubreader/epubreader-1.5.0.12-r2.ebuild
deleted file mode 100644
index bfdc2aaa..00000000
--- a/www-plugins/epubreader/epubreader-1.5.0.12-r2.ebuild
+++ /dev/null
@@ -1,17 +0,0 @@
-# Copyright 2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit mv_mozextension-r1
-RESTRICT="mirror"
-
-DESCRIPTION="Firefox legacy add-on: read ebook (.epub) files"
-HOMEPAGE="http://addons.mozilla.org/en-US/firefox/addon/epubreader/"
-SRC_URI="https://addons.cdn.mozilla.net/user-media/addons/45281/${P}-fx+sm.xpi"
-
-LICENSE="epubreader"
-SLOT="legacy"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-moz_defaults palemoon
diff --git a/www-plugins/form-history-control/Manifest b/www-plugins/form-history-control/Manifest
index 0375b747..e8d90b9d 100644
--- a/www-plugins/form-history-control/Manifest
+++ b/www-plugins/form-history-control/Manifest
@@ -1,2 +1 @@
-DIST form_history_control-1.4.0.6-sm+fx.xpi 579576 SHA256 c83e324fd1076eb54e78a659d2631bda0749a7ff69dfb1c484c9a88c887ddfc9 SHA512 8ea8bd6326fb1b659a7117a9b99972b50b66f059584cdfb22009e1ff6e51b6ddf64b306b22038378f3ea3f8bc9c0c06c3d961a2574b79776bae8bd302d143162
DIST form_history_control-2.0.3.2-an+fx.xpi 283580 SHA512 199a8f1f6c67be05682218b29acea5dbbeca43b12a60a0e618035978bd35d6778489d8748f5fbee687441edb15fdf392b21ea976cb84d6f8df6f8d1ed1df1574
diff --git a/www-plugins/form-history-control/form-history-control-1.4.0.6-r2.ebuild b/www-plugins/form-history-control/form-history-control-1.4.0.6-r2.ebuild
deleted file mode 100644
index 33daed5a..00000000
--- a/www-plugins/form-history-control/form-history-control-1.4.0.6-r2.ebuild
+++ /dev/null
@@ -1,17 +0,0 @@
-# Copyright 2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit mv_mozextension-r1
-RESTRICT="mirror"
-
-DESCRIPTION="legacy add-on: edit the saved history of forms"
-HOMEPAGE="http://www.formhistory.blogspot.com/"
-SRC_URI="https://addons.cdn.mozilla.net/user-media/addons/12021/${PN//-/_}-${PV}-sm+fx.xpi"
-
-LICENSE="MPL-1.1"
-SLOT="legacy"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-moz_defaults palemoon
diff --git a/www-plugins/locale-switcher/Manifest b/www-plugins/locale-switcher/Manifest
deleted file mode 100644
index dc93c57c..00000000
--- a/www-plugins/locale-switcher/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST locale_switcher-3-fx.xpi 6853 SHA256 b48be1cc5570c646e233a27300988f1dc6e7c978cdee0bab9e5cce4777d14161 SHA512 c4b657b5f9ee5007d7f5a89fdf451a5eb613180d2833c38f21a230d823b84098497dd06c0c1dd8e45b59e437250ffba32946a40c35051527268605993b243786
diff --git a/www-plugins/locale-switcher/locale-switcher-3-r2.ebuild b/www-plugins/locale-switcher/locale-switcher-3-r2.ebuild
deleted file mode 100644
index 031f112f..00000000
--- a/www-plugins/locale-switcher/locale-switcher-3-r2.ebuild
+++ /dev/null
@@ -1,19 +0,0 @@
-# Copyright 2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit mv_mozextension-r1
-RESTRICT="mirror"
-
-MY_P="${P/-/_}"
-NAME="${MY_P}-fx.xpi"
-DESCRIPTION="Firefox legacy add-on: button to switch GUI locale"
-HOMEPAGE="http://addons.mozilla.org/firefox/addon/locale-switcher/"
-SRC_URI="https://addons.cdn.mozilla.net/user-media/addons/356/${NAME}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-moz_defaults '<firefox-57' palemoon seamonkey
diff --git a/www-plugins/locale-switcher/metadata.xml b/www-plugins/locale-switcher/metadata.xml
deleted file mode 100644
index b919c846..00000000
--- a/www-plugins/locale-switcher/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>martin@mvath.de</email>
- <name>Martin Väth</name>
- </maintainer>
-</pkgmetadata>
diff --git a/www-plugins/noscript/Manifest b/www-plugins/noscript/Manifest
index b9bb9369..a62a74b1 100644
--- a/www-plugins/noscript/Manifest
+++ b/www-plugins/noscript/Manifest
@@ -1,3 +1,2 @@
DIST noscript-10.1.7.2.xpi 376028 SHA512 6a34aa4b2697c5eb92bb115b83d9f1179725669208b85e58371f7dd0d4a344c04c5577fa06db6d9f244bba551f2c2889f217feec6b49826d436a54ebed269f7a
DIST noscript-10.1.7.5.xpi 375278 SHA512 41174b1abf1c1eec6226928a099fff17ef5598ba6d63263213ae973205ce3d8102cac0487d8b981d738fa4a0b2c56940a27fc2001a30ccac3e42456c359447f1
-DIST noscript-5.1.8.4.xpi 777343 SHA512 0cb73a1b3165d187dc7143cd09e7b84909c64fdcb3400ccd341d33db75847d795d3d8e9a2e87a8960ee5c5e1e9c1b97a47253eb65ce7528e83fe6ccb5e373a17
diff --git a/www-plugins/noscript/noscript-5.1.8.4.ebuild b/www-plugins/noscript/noscript-5.1.8.4.ebuild
deleted file mode 100644
index b1cb264d..00000000
--- a/www-plugins/noscript/noscript-5.1.8.4.ebuild
+++ /dev/null
@@ -1,18 +0,0 @@
-# Copyright 2010-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit mv_mozextension-r1
-RESTRICT="mirror"
-
-DESCRIPTION="Firefox legacy add-on: restrict active contents like java/javascript/flash"
-HOMEPAGE="http://noscript.net/"
-SRC_URI="https://secure.informaction.com/download/releases/${P}.xpi
-https://addons.cdn.mozilla.net/user-media/addons/722/noscript_security_suite-${PV}-fx+sm.xpi -> ${P}.xpi"
-
-LICENSE="GPL-2"
-SLOT="legacy"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-moz_defaults '<firefox-57' '>=palemoon-27'
diff --git a/www-plugins/requestpolicy/Manifest b/www-plugins/requestpolicy/Manifest
deleted file mode 100644
index 0034fdfe..00000000
--- a/www-plugins/requestpolicy/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST requestpolicy-0.5.28-sm+fx.xpi 165630 SHA256 f23b90aa6795ce6a9343a29d79b93c2fb6fa83b5c7b1e80ce829ee8446962bc9 SHA512 27cdb397eb16ba8ca1ae841020893e11b1f8ac857a950f5528dc914c47c417a3c77c3779f82bcdbc0f45eff02b9b573d8f705826ac4ffe4d1c10c930152c1e37
diff --git a/www-plugins/requestpolicy/metadata.xml b/www-plugins/requestpolicy/metadata.xml
deleted file mode 100644
index b919c846..00000000
--- a/www-plugins/requestpolicy/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>martin@mvath.de</email>
- <name>Martin Väth</name>
- </maintainer>
-</pkgmetadata>
diff --git a/www-plugins/requestpolicy/requestpolicy-0.5.28-r2.ebuild b/www-plugins/requestpolicy/requestpolicy-0.5.28-r2.ebuild
deleted file mode 100644
index 840e7fb0..00000000
--- a/www-plugins/requestpolicy/requestpolicy-0.5.28-r2.ebuild
+++ /dev/null
@@ -1,17 +0,0 @@
-# Copyright 2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit mv_mozextension-r1
-RESTRICT="mirror"
-
-DESCRIPTION="Firefox legacy add-on: control cross-site requests"
-HOMEPAGE="https://www.requestpolicy.com/"
-SRC_URI="https://addons.cdn.mozilla.net/user-media/addons/9727/${P}-sm+fx.xpi"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-moz_defaults '<firefox-57' palemoon seamonkey
diff --git a/www-plugins/xclear/Manifest b/www-plugins/xclear/Manifest
deleted file mode 100644
index 9c87011f..00000000
--- a/www-plugins/xclear/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST xclear-1.8.2-fx+sm.xpi 8803 SHA256 aed473c5a6065fb02ec13b9dc7fd86d033e71a862358c69a9c793afed8b91d6b SHA512 ea3d678b4b0252c891938e1f3a74a17aeb9c3391ffebf953e7b35d21e8415f99b673dad5baf31162cd49d80f871619bd54562e6286e76c246bc4c4fc09b1dfe5
diff --git a/www-plugins/xclear/metadata.xml b/www-plugins/xclear/metadata.xml
deleted file mode 100644
index b919c846..00000000
--- a/www-plugins/xclear/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>martin@mvath.de</email>
- <name>Martin Väth</name>
- </maintainer>
-</pkgmetadata>
diff --git a/www-plugins/xclear/xclear-1.8.2-r1.ebuild b/www-plugins/xclear/xclear-1.8.2-r1.ebuild
deleted file mode 100644
index 1d057cd0..00000000
--- a/www-plugins/xclear/xclear-1.8.2-r1.ebuild
+++ /dev/null
@@ -1,17 +0,0 @@
-# Copyright 2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit mv_mozextension-r1
-RESTRICT="mirror"
-
-DESCRIPTION="Firefox legacy add-on: button to clear URL"
-HOMEPAGE="http://addons.mozilla.org/firefox/addon/xclear/"
-SRC_URI="https://addons.cdn.mozilla.net/user-media/addons/13078/${P}-fx+sm.xpi"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-moz_defaults '<firefox-57' palemoon seamonkey