summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-portage/eix/Manifest3
-rw-r--r--app-portage/eix/eix-0.34.5.ebuild (renamed from app-portage/eix/eix-0.34.4.ebuild)0
-rw-r--r--app-portage/eix/eix-0.34.5_alpha200906.ebuild176
-rw-r--r--metadata/pkg_desc_index2
4 files changed, 2 insertions, 179 deletions
diff --git a/app-portage/eix/Manifest b/app-portage/eix/Manifest
index f72c7032..c40d3fd7 100644
--- a/app-portage/eix/Manifest
+++ b/app-portage/eix/Manifest
@@ -1,2 +1 @@
-DIST eix-0.34.4.tar.xz 628516 SHA512 a96714fba8324529bf63de63f9eb11cc76da05e3d43c5eedad49079b6e3a1960376bd5d3bc116dba49bc7f694c7588741e518438936abd4b37edfe0a097ecd3d
-DIST eix-0.34.5_alpha200906.tar.gz 687164 SHA512 4c63a3fb3c373a7a48ea364c9ba78bb72e5daa24580093ebf988afd06558d7f050b79a9d2e502400ed2e24c10d9646fe11abe4a9c70803fed80bba22b078e358
+DIST eix-0.34.5.tar.xz 629276 SHA512 b11744ea36c0771e4959de4925b3d74df8c270633a21c82ff27f4c91cc5a9281a85a594f0d20d5eb5c3c15a6c08e74232030687cc85f588545216438dc4ff7d7
diff --git a/app-portage/eix/eix-0.34.4.ebuild b/app-portage/eix/eix-0.34.5.ebuild
index b3364c27..b3364c27 100644
--- a/app-portage/eix/eix-0.34.4.ebuild
+++ b/app-portage/eix/eix-0.34.5.ebuild
diff --git a/app-portage/eix/eix-0.34.5_alpha200906.ebuild b/app-portage/eix/eix-0.34.5_alpha200906.ebuild
deleted file mode 100644
index 7b1d0b85..00000000
--- a/app-portage/eix/eix-0.34.5_alpha200906.ebuild
+++ /dev/null
@@ -1,176 +0,0 @@
-# Copyright 1999-2020 Martin V\"ath and others
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-WANT_LIBTOOL=none
-AUTOTOOLS_AUTO_DEPEND=no
-MESON_AUTO_DEPEND=no
-inherit autotools bash-completion-r1 meson tmpfiles
-
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-case ${PV} in
-99999999*)
- EGIT_REPO_URI="https://github.com/vaeth/${PN}.git"
- inherit git-r3
- SRC_URI=""
- KEYWORDS=""
- PROPERTIES="live";;
-*)
- RESTRICT="mirror"
- EGIT_COMMIT="b032c6826dba1136b4dcf077ace5529c4e6ac708"
- SRC_URI="https://github.com/vaeth/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/${PN}-${EGIT_COMMIT}";;
-esac
-
-DESCRIPTION="Search and query ebuilds"
-HOMEPAGE="https://github.com/vaeth/eix/"
-
-LICENSE="GPL-2"
-SLOT="0"
-PLOCALES="de ru"
-IUSE="debug +dep doc +jumbo-build"
-for i in ${PLOCALES}; do
- IUSE+=" l10n_${i}"
-done
-IUSE+=" +meson nls optimization +protobuf +required-use security +src-uri strong-optimization strong-security sqlite swap-remote tools usr-portage"
-
-DEPEND="nls? ( virtual/libintl )
- sqlite? ( >=dev-db/sqlite-3:= )"
-RDEPEND="${DEPEND}
- >=app-shells/push-3.1
- >=app-shells/quoter-4.1"
-BDEPEND="meson? (
- >=dev-util/meson-0.41.0
- >=dev-util/ninja-1.7.2
- strong-optimization? ( >=sys-devel/gcc-config-1.9.1 )
- nls? ( sys-devel/gettext )
- )
- !meson? ( ${AUTOTOOLS_DEPEND} >=sys-devel/gettext-0.19.6 )
- protobuf? ( dev-libs/protobuf )"
-
-pkg_setup() {
- # remove stale cache file to prevent collisions
- local old_cache="${EROOT}var/cache/${PN}"
- test -f "${old_cache}" && rm -f -- "${old_cache}"
-}
-
-src_prepare() {
- sed -i -e "s'/'${EPREFIX}/'" -- "${S}"/tmpfiles.d/eix.conf || die
- default
- use meson || {
- eautopoint
- eautoreconf
- }
-}
-
-src_configure() {
- local i
- export LINGUAS=
- for i in ${PLOCALES}; do
- use l10n_${i} && LINGUAS+=${LINGUAS:+ }${i}
- done
- if use meson; then
- local emesonargs=(
- -Ddocdir="${EPREFIX}/usr/share/doc/${P}"
- -Dhtmldir="${EPREFIX}/usr/share/doc/${P}/html"
- $(meson_use jumbo-build)
- $(meson_use sqlite)
- $(meson_use protobuf)
- $(meson_use doc extra-doc)
- $(meson_use nls)
- $(meson_use tools separate-tools)
- $(meson_use security)
- $(meson_use optimization normal-optimization)
- $(meson_use strong-security)
- $(meson_use strong-optimization)
- $(meson_use debug debugging)
- $(meson_use swap-remote)
- $(meson_use prefix always-accept-keywords)
- $(meson_use dep dep-default)
- $(meson_use required-use required-use-default)
- $(meson_use src-uri src-uri-default)
- $(usex usr-portage -Dportdir-default=/usr/portage '')
- -Dzsh-completion="${EPREFIX}/usr/share/zsh/site-functions"
- -Dportage-rootpath="${ROOTPATH}"
- -Deprefix-default="${EPREFIX}"
- )
- if use prefix; then
- emesonarge+=(
- -Deix-user=
- -Deix-uid=-1
- )
- fi
- meson_src_configure
- else
- local myconf=(
- $(use_enable jumbo-build)
- $(use_with sqlite)
- $(use_with protobuf)
- $(use_with doc extra-doc)
- $(use_enable nls)
- $(use_enable tools separate-tools)
- $(use_enable security)
- $(use_enable optimization)
- $(use_enable strong-security)
- $(use_enable strong-optimization)
- $(use_enable debug debugging)
- $(use_enable swap-remote)
- $(use_with prefix always-accept-keywords)
- $(use_with dep dep-default)
- $(use_with required-use required-use-default)
- $(use_with src-uri src-uri-default)
- $(use_with usr-portage portdir-default /usr/portage)
- --with-zsh-completion
- --with-portage-rootpath="${ROOTPATH}"
- --with-eprefix-default="${EPREFIX}"
- )
- if use prefix; then
- myconf+=(
- --with-eix-user=
- --with-eix-uid=-1
- )
- fi
- econf "${myconf[@]}"
- fi
-}
-
-src_compile() {
- if use meson; then
- meson_src_compile
- else
- default
- fi
-}
-
-src_test() {
- if use meson; then
- meson_src_test
- else
- default
- fi
-}
-
-src_install() {
- if use meson; then
- meson_src_install
- else
- default
- fi
- dobashcomp bash/eix
- dotmpfiles tmpfiles.d/eix.conf
- use doc && dodoc src/output/eix.proto
-}
-
-pkg_postinst() {
- local obs="${EROOT}var/cache/eix.previous"
- if test -f "${obs}"; then
- ewarn "Found obsolete ${obs}, please remove it"
- fi
- tmpfiles_process eix.conf
-}
-
-pkg_postrm() {
- if [ -z "${REPLACED_BY_VERSION}" ]; then
- rm -rf -- "${EROOT}var/cache/${PN}"
- fi
-}
diff --git a/metadata/pkg_desc_index b/metadata/pkg_desc_index
index e1c631f7..c4b4db54 100644
--- a/metadata/pkg_desc_index
+++ b/metadata/pkg_desc_index
@@ -24,7 +24,7 @@ app-misc/machine-learning-mv 1.3: Some machine learning experiments
app-misc/resolve-march-native 0.9.4: Resolve GCC flag -march=native
app-mobilephone/adb-sync 0_p20181127-r1: Synchronize files between a PC and an Android device using ADB
app-portage/changelog-gitrepo 1.1: Create ChangeLog data for gentoo repositories from git
-app-portage/eix 0.34.4 0.34.5_alpha200906 99999999: Search and query ebuilds
+app-portage/eix 0.34.5 99999999: Search and query ebuilds
app-portage/etcat 1.0.2 99999999: Updated version of an old Portage information extractor
app-portage/find_cruft 5.2: find cruft files not managed by portage
app-portage/getdelta 0.7.9-r2: dynamic deltup client