summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-shells/push/Manifest1
-rw-r--r--app-shells/push/metadata.xml25
-rw-r--r--app-shells/push/push-1.9.ebuild21
3 files changed, 47 insertions, 0 deletions
diff --git a/app-shells/push/Manifest b/app-shells/push/Manifest
new file mode 100644
index 00000000..225e5efc
--- /dev/null
+++ b/app-shells/push/Manifest
@@ -0,0 +1 @@
+DIST push-1.9.tar.gz 1984 SHA256 e3e6cc55bf739fd4245df292ef6ada7525d9ccf216772b6fa222c82b206b448a
diff --git a/app-shells/push/metadata.xml b/app-shells/push/metadata.xml
new file mode 100644
index 00000000..7cb20450
--- /dev/null
+++ b/app-shells/push/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ <description>Upstream developer, assign bugs</description>
+ </maintainer>
+ <maintainer type="person">
+ <email>axs@gentoo.org</email>
+ <description>Proxy committer, CC bugs</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ </maintainer>
+ <bugs-to>mailto:martin@mvath.de</bugs-to>
+ <remote-id type="github">vaeth/push</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-shells/push/push-1.9.ebuild b/app-shells/push/push-1.9.ebuild
new file mode 100644
index 00000000..9258397b
--- /dev/null
+++ b/app-shells/push/push-1.9.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit vcs-snapshot
+
+DESCRIPTION="A POSIX shell function to treat a variable like an array, quoting args"
+HOMEPAGE="https://github.com/vaeth/push/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+IUSE=""
+
+src_install() {
+ insinto /usr/bin
+ doins push.sh
+ dodoc README
+}