summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--metadata/pkg_desc_index1
-rw-r--r--profiles/use.local.desc2
-rw-r--r--sys-fs/squashfuse/Manifest1
-rw-r--r--sys-fs/squashfuse/metadata.xml23
-rw-r--r--sys-fs/squashfuse/squashfuse-0.1.101_alpha20170917.ebuild44
5 files changed, 71 insertions, 0 deletions
diff --git a/metadata/pkg_desc_index b/metadata/pkg_desc_index
index d95a4ec1..3eb26f91 100644
--- a/metadata/pkg_desc_index
+++ b/metadata/pkg_desc_index
@@ -108,6 +108,7 @@ sys-fs/aufs-util 99999999: Userspace tools for aufs
sys-fs/emount 3.0.4: mount/unmount create/remove dm-crypt filesystems according to your /etc/fstab
sys-fs/squash_dir 13.13: Keep directories compressed with squashfs. Useful for portage tree, texmf-dist
sys-fs/squashfs-tools 4.3.1_alpha20171114 99999999: Tool for creating compressed filesystem type squashfs
+sys-fs/squashfuse 0.1.101_alpha20170917: FUSE filesystem to mount squashfs archives
sys-fs/squashmount 16.0.0_p2: Keep directories compressed with squashfs. Useful for portage tree, texmf-dist
sys-kernel/kccmp 0.3-r1: A simple tool for comparing two linux kernel .config files
sys-kernel/kernel 4.3: A POSIX shell script to compile the kernel with user permissions
diff --git a/profiles/use.local.desc b/profiles/use.local.desc
index 108d4c3d..af52265a 100644
--- a/profiles/use.local.desc
+++ b/profiles/use.local.desc
@@ -245,6 +245,8 @@ sys-fs/squash_dir:unionfs-fuse - Prefer unionfs-fuse
sys-fs/squashfs-tools:lz4 - Enable support for LZ4 compression using app-arch/lz4
sys-fs/squashfs-tools:xz - Enable support for XZ ("LZMA2") compression using app-arch/xz-utils
sys-fs/squashfs-tools:zstd - Enable support for ZSTD compression using app-arch/zstd (requires >=linux-4.14 or >=sys-fs/squashfuse-0.1.101_alpha20170917)
+sys-fs/squashfuse:lz4 - Enable support for lz4 compression
+sys-fs/squashfuse:zstd - Enable support for zstd compression
sys-power/nut:ipmi - Support IPMI-based UPSes.
sys-power/nut:ups_drivers_al175 - Driver for Eltek UPS models with AL175 alarm module
sys-power/nut:ups_drivers_apcsmart - Driver for American Power Conversion Smart Protocol UPS equipment
diff --git a/sys-fs/squashfuse/Manifest b/sys-fs/squashfuse/Manifest
new file mode 100644
index 00000000..69a7183a
--- /dev/null
+++ b/sys-fs/squashfuse/Manifest
@@ -0,0 +1 @@
+DIST squashfuse-0.1.101_alpha20170917.tar.gz 57581 SHA512 2921f572eb35058459f35d49844786c1ebba84c38e407ca4fb30c6f589cacbd4cd7e2175cfc7caf5a36c284f4693499b560009da0bac2ce56ad6c51dce1cd548
diff --git a/sys-fs/squashfuse/metadata.xml b/sys-fs/squashfuse/metadata.xml
new file mode 100644
index 00000000..9a59f7af
--- /dev/null
+++ b/sys-fs/squashfuse/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <bugs-to>mailto:dave@vasilevsky.ca</bugs-to>
+ <changelog>https://github.com/vasi/squashfuse/commits/master</changelog>
+ <doc>https://raw.github.com/vasi/squashfuse/master/README</doc>
+ <remote-id type="github">vasi/squashfuse</remote-id>
+ </upstream>
+ <maintainer type="person">
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ <description>maintainer of the updates in the mv overlay</description>
+ </maintainer>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ <name>Zac Medico</name>
+ </maintainer>
+ <use>
+ <flag name="lz4">Enable support for lz4 compression</flag>
+ <flag name="zstd">Enable support for zstd compression</flag>
+ </use>
+</pkgmetadata>
diff --git a/sys-fs/squashfuse/squashfuse-0.1.101_alpha20170917.ebuild b/sys-fs/squashfuse/squashfuse-0.1.101_alpha20170917.ebuild
new file mode 100644
index 00000000..2a75ad5b
--- /dev/null
+++ b/sys-fs/squashfuse/squashfuse-0.1.101_alpha20170917.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools flag-o-matic
+
+DESCRIPTION="FUSE filesystem to mount squashfs archives"
+HOMEPAGE="https://github.com/vasi/squashfuse"
+EGIT_COMMIT="e275db06955d3dc455d55d25c015a6b64b1e4756"
+SRC_URI="https://github.com/vasi/squashfuse/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="lz4 lzma lzo +zlib zstd"
+REQUIRED_USE="|| ( lz4 lzma lzo zlib zstd )"
+
+COMMON_DEPEND="
+ >=sys-fs/fuse-2.8.6:=
+ lzma? ( >=app-arch/xz-utils-5.0.4:= )
+ zlib? ( >=sys-libs/zlib-1.2.5-r2:= )
+ lzo? ( >=dev-libs/lzo-2.06:= )
+ lz4? ( >=app-arch/lz4-0_p106:= )
+ zstd? ( >=app-arch/zstd-1.0:= )
+"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+S=${WORKDIR}/${PN}-${EGIT_COMMIT}
+
+src_prepare() {
+ sed -i -e '1s:\[0\.1\.100\]:['"${PV}"']:' configure.ac || die
+ AT_M4DIR=${S}/m4 eautoreconf
+ default
+}
+
+src_configure() {
+ filter-flags -flto* -fwhole-program -fno-common
+ econf \
+ $(use lz4 || echo --without-lz4) \
+ $(use lzma || echo --without-xz) \
+ $(use lzo || echo --without-lzo) \
+ $(use zlib || echo --without-zlib)
+ $(use zstd || echo --without-zstd)
+}