summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-accessibility/gespeaker/gespeaker-0.8.6-r2.ebuild')
-rw-r--r--app-accessibility/gespeaker/gespeaker-0.8.6-r2.ebuild16
1 files changed, 12 insertions, 4 deletions
diff --git a/app-accessibility/gespeaker/gespeaker-0.8.6-r2.ebuild b/app-accessibility/gespeaker/gespeaker-0.8.6-r2.ebuild
index 81b6bcdb..16580ce1 100644
--- a/app-accessibility/gespeaker/gespeaker-0.8.6-r2.ebuild
+++ b/app-accessibility/gespeaker/gespeaker-0.8.6-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2017 Gentoo Foundation
+# Copyright 2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -14,8 +14,11 @@ SRC_URI="https://github.com/muflone/gespeaker/releases/download/${PV}/${P}.tar.g
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
-
-IUSE="linguas_ar linguas_bg linguas_de linguas_en linguas_es linguas_fo linguas_fr linguas_it linguas_pl linguas_tr linguas_vi"
+PLOCALES="ar bg de en es fo fr it pl tr vi"
+IUSE=
+for i in ${PLOCALES}; do
+ IUSE+=${IUSE:+\ }"l10n_${i}"
+done
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="app-accessibility/espeak
@@ -26,6 +29,11 @@ RDEPEND="app-accessibility/espeak
${PYTHON_DEPS}"
src_prepare() {
+ local i
+ export LINGUAS=
+ for i in ${PLOCALES}; do
+ use l10n_${i} && LINGUAS+=${LINGUAS:+ }${i}
+ done
distutils-r1_python_prepare_all
use prefix || sed -i \
-e '1s"^#!/usr/bin/env python$"#!'"${EPREFIX}/usr/bin/python"'"' \
@@ -39,5 +47,5 @@ src_prepare() {
sed -i \
-e 's!env python gespeaker\.py!./gespeaker.py!' \
-- "${S}/gespeaker" || die
- eapply_user
+ default
}