summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/sudox/sudox-3.15.ebuild')
-rw-r--r--app-admin/sudox/sudox-3.15.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-admin/sudox/sudox-3.15.ebuild b/app-admin/sudox/sudox-3.15.ebuild
new file mode 100644
index 00000000..baafb449
--- /dev/null
+++ b/app-admin/sudox/sudox-3.15.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+RESTRICT="mirror"
+inherit eutils vcs-snapshot
+
+DESCRIPTION="sudox is a wrapper for sudo which can pass X authority data and deal with screen and tmux"
+HOMEPAGE="https://github.com/vaeth/sudox/"
+SRC_URI="https://github.com/vaeth/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RDEPEND="app-admin/sudo
+ app-shells/push"
+DEPEND=""
+
+src_prepare() {
+ epatch_user
+}
+
+src_install() {
+ dobin "${PN}"
+ insinto /usr/share/zsh/site-functions
+ doins "_${PN}"
+}