summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/bzwc/bzwc-2.7.ebuild')
-rw-r--r--app-arch/bzwc/bzwc-2.7.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-arch/bzwc/bzwc-2.7.ebuild b/app-arch/bzwc/bzwc-2.7.ebuild
new file mode 100644
index 00000000..1ffc66ee
--- /dev/null
+++ b/app-arch/bzwc/bzwc-2.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header $
+
+EAPI="4"
+RESTRICT="mirror"
+
+DESCRIPTION="A POSIX shell wrapper for wc, supporting compressed files (xz, lzma, bz2, gz)"
+HOMEPAGE="https://github.com/vaeth/${PN}"
+SRC_URI="http://github.com/vaeth/${PN}/tarball/release-${PV} -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="zsh-completion"
+
+src_unpack() {
+ default
+ cd *"${PN}"-*
+ S="${PWD}"
+}
+
+src_install() {
+ local i
+ insinto /usr/bin
+ for i in bin/*
+ do if test -h "${i}" || ! test -x "${i}"
+ then doins "${i}"
+ else dobin "${i}"
+ fi
+ done
+ if use zsh-completion
+ then insinto /usr/share/zsh/site-functions
+ doins zsh/*
+ fi
+ dodoc README
+}