summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/archwrap/Manifest2
-rw-r--r--app-arch/archwrap/archwrap-8.0.ebuild (renamed from app-arch/archwrap/archwrap-7.0.ebuild)3
-rw-r--r--app-arch/brotli/Manifest1
-rw-r--r--app-arch/brotli/brotli-1.0.1.ebuild65
-rw-r--r--app-arch/brotli/files/brotli-1.0.1-no-rpath.patch19
-rw-r--r--app-arch/brotli/files/brotli-1.0.1-no-static.patch16
-rw-r--r--app-arch/brotli/metadata.xml22
7 files changed, 126 insertions, 2 deletions
diff --git a/app-arch/archwrap/Manifest b/app-arch/archwrap/Manifest
index a0473c9b..4c28223f 100644
--- a/app-arch/archwrap/Manifest
+++ b/app-arch/archwrap/Manifest
@@ -1 +1 @@
-DIST archwrap-7.0.tar.gz 18649 SHA256 0437fc36d65fb30762bf6b31d2e4619063ce24decf934988264fd82eb5ce357b SHA512 0a710dae34995a50e956eebe01669c239a45e59d8adf6507feae1de75c96e9c42203c8c08f24209a4773736cac3b0cefb88dba6a5223f27e3fe10bb9d9d38963
+DIST archwrap-8.0.tar.gz 16854 SHA256 1dc298cb10ca5423336d1f5e5f8773d5156b864ef5ea747a6c8c5641ad38ee0a SHA512 4bbf79c1a675b7db77c23700ac29cfba9066ec52c0b7c955ba0ba256beba2cc5f93d6355ebf6334fbc4040b1e83f411f0b49a8ae88d9fe48c5ac2a96fcef3751
diff --git a/app-arch/archwrap/archwrap-7.0.ebuild b/app-arch/archwrap/archwrap-8.0.ebuild
index 61234c2c..28613abe 100644
--- a/app-arch/archwrap/archwrap-7.0.ebuild
+++ b/app-arch/archwrap/archwrap-8.0.ebuild
@@ -12,7 +12,8 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-RDEPEND=">=app-shells/push-2.0-r2"
+RDEPEND=">=app-shells/push-2.0-r2
+ !<app-arch/brotli-1"
DEPEND=""
src_prepare() {
diff --git a/app-arch/brotli/Manifest b/app-arch/brotli/Manifest
new file mode 100644
index 00000000..44b77894
--- /dev/null
+++ b/app-arch/brotli/Manifest
@@ -0,0 +1 @@
+DIST brotli-1.0.1.tar.gz 23731694 SHA256 6870f9c2c63ef58d7da36e5212a3e1358427572f6ac5a8b5a73a815cf3e0c4a6 SHA512 de6f787012243fdc5eafa559ffc765e1d69bf78cf337efdd743bb422706b5ae86b4966f07a8410165044b988b7ca2999065efc4693bda7111e53fe64917e24c0
diff --git a/app-arch/brotli/brotli-1.0.1.ebuild b/app-arch/brotli/brotli-1.0.1.ebuild
new file mode 100644
index 00000000..e94d15c0
--- /dev/null
+++ b/app-arch/brotli/brotli-1.0.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+RESTRICT="mirror"
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+DISTUTILS_OPTIONAL="1"
+
+inherit cmake-utils distutils-r1
+
+DESCRIPTION="Generic-purpose lossless compression algorithm"
+HOMEPAGE="https://github.com/google/brotli"
+SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}"
+
+IUSE="doc python static-libs test"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+LICENSE="MIT python? ( Apache-2.0 )"
+
+DOCS=( README.md CONTRIBUTING.md )
+
+PATCHES=( "${FILESDIR}"/${PN}-1.0.1-no-rpath.patch )
+
+src_prepare() {
+ use static-libs || eapply "${FILESDIR}"/${PN}-1.0.1-no-static.patch
+ cmake-utils_src_prepare
+ use python && distutils-r1_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=ON
+ -DBUILD_TESTING="$(usex test)"
+ )
+ cmake-utils_src_configure
+ use python && distutils-r1_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ use python && distutils-r1_src_compile
+}
+
+python_test(){
+ esetup.py test || die
+}
+
+src_test() {
+ cmake-utils_src_test
+ use python && distutils-r1_src_test
+}
+
+src_install() {
+ cmake-utils_src_install
+ use python && distutils-r1_src_install
+ use doc && dodoc docs/*.pdf
+ doman docs/*.[0-9n]
+}
diff --git a/app-arch/brotli/files/brotli-1.0.1-no-rpath.patch b/app-arch/brotli/files/brotli-1.0.1-no-rpath.patch
new file mode 100644
index 00000000..2a9f62c5
--- /dev/null
+++ b/app-arch/brotli/files/brotli-1.0.1-no-rpath.patch
@@ -0,0 +1,19 @@
+--- 1/CMakeLists.txt
++++ 1/CMakeLists.txt
+@@ -24,16 +24,6 @@
+
+ include(GNUInstallDirs)
+
+-# When building shared libraries it is important to set the correct rpath.
+-# See https://cmake.org/Wiki/CMake_RPATH_handling#Always_full_RPATH
+-set(CMAKE_SKIP_BUILD_RPATH FALSE)
+-set(CMAKE_BUILD_WITH_INSTALL_RPATH FALSE)
+-set(CMAKE_INSTALL_RPATH_USE_LINK_PATH TRUE)
+-list(FIND CMAKE_PLATFORM_IMPLICIT_LINK_DIRECTORIES "${CMAKE_INSTALL_LIBDIR}" isSystemDir)
+-if ("${isSystemDir}" STREQUAL "-1")
+- set(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_LIBDIR}")
+-endif()
+-
+ # Parse version information from common/version.h. Normally we would
+ # define these values here and write them out to configuration file(s)
+ # (i.e., config.h), but in this case we parse them from
diff --git a/app-arch/brotli/files/brotli-1.0.1-no-static.patch b/app-arch/brotli/files/brotli-1.0.1-no-static.patch
new file mode 100644
index 00000000..ff2bd1bd
--- /dev/null
+++ b/app-arch/brotli/files/brotli-1.0.1-no-static.patch
@@ -0,0 +1,16 @@
+--- 1/CMakeLists.txt
++++ 1/CMakeLists.txt
+@@ -204,13 +204,6 @@
+ )
+
+ install(
+- TARGETS ${BROTLI_LIBRARIES_CORE_STATIC}
+- ARCHIVE DESTINATION "${CMAKE_INSTALL_LIBDIR}"
+- LIBRARY DESTINATION "${CMAKE_INSTALL_LIBDIR}"
+- RUNTIME DESTINATION "${CMAKE_INSTALL_BINDIR}"
+- )
+-
+- install(
+ DIRECTORY ${BROTLI_INCLUDE_DIRS}/brotli
+ DESTINATION "${CMAKE_INSTALL_INCLUDEDIR}"
+ )
diff --git a/app-arch/brotli/metadata.xml b/app-arch/brotli/metadata.xml
new file mode 100644
index 00000000..2a38b9ad
--- /dev/null
+++ b/app-arch/brotli/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>bicatali@gentoo.org</email>
+ <name>Sébastien Fabbro</name>
+ </maintainer>
+ <longdescription>
+ Brotli is a generic-purpose lossless compression algorithm that
+ compresses data using a combination of a modern variant of the
+ LZ77 algorithm, Huffman coding and 2nd order context modeling,
+ with a hight compression ratio. It is similar in speed with
+ deflate but offers denser compression.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">google/brotli</remote-id>
+ </upstream>
+</pkgmetadata>