summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/knapsack/knapsack-1.0.ebuild')
-rw-r--r--app-misc/knapsack/knapsack-1.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-misc/knapsack/knapsack-1.0.ebuild b/app-misc/knapsack/knapsack-1.0.ebuild
new file mode 100644
index 00000000..9a78d41d
--- /dev/null
+++ b/app-misc/knapsack/knapsack-1.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+RESTRICT="mirror"
+inherit toolchain-funcs
+
+DESCRIPTION="A solver for the bound and unbound 0/1-knapsack problem with integer weights"
+HOMEPAGE="https://github.com/vaeth/knapsack/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+IUSE=""
+
+src_compile() {
+ "$(tc-getCXX)" $CPPFLAGS $CXXFLAGS $LDFLAGS knapsack.cc -o knapsack
+}
+
+src_install () {
+ default
+ dobin knapsack
+}