summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/eix/eix-0.32.5_beta10.ebuild')
-rw-r--r--app-portage/eix/eix-0.32.5_beta10.ebuild90
1 files changed, 0 insertions, 90 deletions
diff --git a/app-portage/eix/eix-0.32.5_beta10.ebuild b/app-portage/eix/eix-0.32.5_beta10.ebuild
deleted file mode 100644
index c583d040..00000000
--- a/app-portage/eix/eix-0.32.5_beta10.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-RESTRICT="mirror"
-WANT_LIBTOOL=none
-PLOCALES="de ru"
-inherit autotools bash-completion-r1 l10n tmpfiles
-
-case ${PV} in
-99999999*)
- EGIT_REPO_URI="git://github.com/vaeth/${PN}.git"
- inherit git-r3
- SRC_URI=""
- PROPERTIES="live";;
-*)
- RESTRICT="mirror"
- EGIT_COMMIT="77f4a205eb4612044e332d95da96b0eef25547a2"
- SRC_URI="https://github.com/vaeth/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/${PN}-${EGIT_COMMIT}";;
-esac
-
-DESCRIPTION="Search and query ebuilds"
-HOMEPAGE="https://github.com/vaeth/eix/"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS=""
-IUSE="debug +dep doc nls optimization +required-use security strong-optimization strong-security sqlite swap-remote tools"
-
-BOTHDEPEND="nls? ( virtual/libintl )
- sqlite? ( >=dev-db/sqlite-3:= )"
-RDEPEND="${BOTHDEPEND}
- >=app-shells/push-2.0
- >=app-shells/quoter-3.0"
-DEPEND="${BOTHDEPEND}
- >=sys-devel/gettext-0.19.6"
-
-pkg_setup() {
- # remove stale cache file to prevent collisions
- local old_cache="${EROOT}var/cache/${PN}"
- test -f "${old_cache}" && rm -f -- "${old_cache}"
-}
-
-src_prepare() {
- sed -i -e "s'/'${EPREFIX}/'" -- "${S}"/tmpfiles.d/eix.conf || die
- eapply_user
- eautopoint
- eautoreconf
-}
-
-src_configure() {
- econf \
- $(use_with sqlite) \
- $(use_with doc extra-doc) \
- $(use_enable nls) \
- $(use_enable tools separate-tools) \
- $(use_enable security) \
- $(use_enable optimization) \
- $(use_enable strong-security) \
- $(use_enable strong-optimization) \
- $(use_enable debug debugging) \
- $(use_enable swap-remote) \
- $(use_with prefix always-accept-keywords) \
- $(use_with dep dep-default) \
- $(use_with required-use required-use-default) \
- --with-zsh-completion \
- --with-portage-rootpath="${ROOTPATH}" \
- --with-eprefix-default="${EPREFIX}"
-}
-
-src_install() {
- default
- dobashcomp bash/eix
- dotmpfiles tmpfiles.d/eix.conf
-}
-
-pkg_postinst() {
- local obs="${EROOT}var/cache/eix.previous"
- if test -f "${obs}"; then
- ewarn "Found obsolete ${obs}, please remove it"
- fi
- tmpfiles_process eix.conf
-}
-
-pkg_postrm() {
- if [ -z "${REPLACED_BY_VERSION}" ]; then
- rm -rf -- "${EROOT}var/cache/${PN}"
- fi
-}