summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/eix/eix-99999999.ebuild')
-rw-r--r--app-portage/eix/eix-99999999.ebuild30
1 files changed, 18 insertions, 12 deletions
diff --git a/app-portage/eix/eix-99999999.ebuild b/app-portage/eix/eix-99999999.ebuild
index 531b470c..cb812f13 100644
--- a/app-portage/eix/eix-99999999.ebuild
+++ b/app-portage/eix/eix-99999999.ebuild
@@ -2,16 +2,26 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-
-EGIT_REPO_URI="git://github.com/vaeth/${PN}.git"
+RESTRICT="mirror"
WANT_LIBTOOL=none
PLOCALES="de ru"
-inherit autotools bash-completion-r1 git-r3 l10n systemd
+inherit autotools bash-completion-r1 l10n tmpfiles
+
+case ${PV} in
+99999999*)
+ EGIT_REPO_URI="git://github.com/vaeth/${PN}.git"
+ inherit git-r3
+ SRC_URI=""
+ PROPERTIES="live";;
+*)
+ RESTRICT="mirror"
+ EGIT_COMMIT="792fec8088bc78ea916aa73c2692d4987c8142be"
+ SRC_URI="https://github.com/vaeth/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${EGIT_COMMIT}";;
+esac
-DESCRIPTION="Search and query ebuilds, portage incl. local settings, ext. overlays and more"
+DESCRIPTION="Search and query ebuilds"
HOMEPAGE="https://github.com/vaeth/eix/"
-SRC_URI=""
-PROPERTIES="live"
LICENSE="GPL-2"
SLOT="0"
@@ -62,19 +72,15 @@ src_configure() {
src_install() {
default
dobashcomp bash/eix
- systemd_dotmpfilesd tmpfiles.d/eix.conf
+ dotmpfiles tmpfiles.d/eix.conf
}
pkg_postinst() {
- if ! use prefix && ! test -d "${EROOT}var/cache/${PN}"; then
- # note: if this is done in src_install(), portage:portage
- # ownership may be reset to root
- fowners portage:portage "${EROOT%/}"/var/cache/eix
- fi
local obs="${EROOT}var/cache/eix.previous"
if test -f "${obs}"; then
ewarn "Found obsolete ${obs}, please remove it"
fi
+ tmpfiles_process eix.conf
}
pkg_postrm() {