summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/eix')
-rw-r--r--app-portage/eix/Manifest3
-rw-r--r--app-portage/eix/eix-0.33.5_alpha20180919.ebuild171
-rw-r--r--app-portage/eix/eix-0.33.6.ebuild (renamed from app-portage/eix/eix-0.33.4.ebuild)8
-rw-r--r--app-portage/eix/eix-99999999.ebuild4
4 files changed, 8 insertions, 178 deletions
diff --git a/app-portage/eix/Manifest b/app-portage/eix/Manifest
index 3486a651..a3ba0d87 100644
--- a/app-portage/eix/Manifest
+++ b/app-portage/eix/Manifest
@@ -1,2 +1 @@
-DIST eix-0.33.4.tar.xz 622844 SHA512 bc031a8751d2b20eba5d05375250bcbd163847d4fad9c0994b01cd01304e00db745b0111127f752599d182350b4aa6de7a211fc5cd011de8d0aab0c4a539418e
-DIST eix-0.33.5_alpha20180919.tar.gz 679606 SHA512 73363a0dd86c1679b4e5c373268f928c9b7d9b8a3f0796e3384aec9a64f2dd3b50254c1b251a43c3b3d56decc5fa58f88451a421d232bff64a5aa9575a8fc0c4
+DIST eix-0.33.6.tar.xz 625512 SHA512 3f04f06533d4e7a0acd5b6e85d1194c8f9b013595ebe75c3dda06cce42e7721a57393aed17e9dd6437780b48378691d84b6e595999ce4321ad114b239313c7cf
diff --git a/app-portage/eix/eix-0.33.5_alpha20180919.ebuild b/app-portage/eix/eix-0.33.5_alpha20180919.ebuild
deleted file mode 100644
index 1a70e427..00000000
--- a/app-portage/eix/eix-0.33.5_alpha20180919.ebuild
+++ /dev/null
@@ -1,171 +0,0 @@
-# Copyright 1999-2018 Martin V\"ath and others
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-WANT_LIBTOOL=none
-AUTOTOOLS_AUTO_DEPEND=no
-MESON_AUTO_DEPEND=no
-inherit autotools bash-completion-r1 meson tmpfiles
-
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-case ${PV} in
-99999999*)
- EGIT_REPO_URI="https://github.com/vaeth/${PN}.git"
- inherit git-r3
- SRC_URI=""
- KEYWORDS=""
- PROPERTIES="live";;
-*)
- RESTRICT="mirror"
- EGIT_COMMIT="470c9d35ed91bfac3f808c5e8625c61a04234b8f"
- SRC_URI="https://github.com/vaeth/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/${PN}-${EGIT_COMMIT}";;
-esac
-
-DESCRIPTION="Search and query ebuilds"
-HOMEPAGE="https://github.com/vaeth/eix/"
-
-LICENSE="GPL-2"
-SLOT="0"
-PLOCALES="de ru"
-IUSE="debug +dep doc +jumbo-build"
-for i in ${PLOCALES}; do
- IUSE+=" l10n_${i}"
-done
-IUSE+=" +meson nls optimization +required-use security +src-uri strong-optimization strong-security sqlite swap-remote tools"
-
-BOTHDEPEND="nls? ( virtual/libintl )
- sqlite? ( >=dev-db/sqlite-3:= )"
-RDEPEND="${BOTHDEPEND}
- >=app-shells/push-3.1
- >=app-shells/quoter-4.1"
-DEPEND="${BOTHDEPEND}
- meson? (
- >=dev-util/meson-0.41.0
- >=dev-util/ninja-1.7.2
- strong-optimization? ( >=sys-devel/gcc-config-1.9.1 )
- nls? ( sys-devel/gettext )
- )
- !meson? ( ${AUTOTOOLS_DEPEND} >=sys-devel/gettext-0.19.6 )"
-
-pkg_setup() {
- # remove stale cache file to prevent collisions
- local old_cache="${EROOT}var/cache/${PN}"
- test -f "${old_cache}" && rm -f -- "${old_cache}"
-}
-
-src_prepare() {
- sed -i -e "s'/'${EPREFIX}/'" -- "${S}"/tmpfiles.d/eix.conf || die
- default
- use meson || {
- eautopoint
- eautoreconf
- }
-}
-
-src_configure() {
- local i
- export LINGUAS=
- for i in ${PLOCALES}; do
- use l10n_${i} && LINGUAS+=${LINGUAS:+ }${i}
- done
- if use meson; then
- local emesonargs=(
- -Ddocdir="${EPREFIX}/usr/share/doc/${P}"
- -Dhtmldir="${EPREFIX}/usr/share/doc/${P}/html"
- $(meson_use jumbo-build)
- $(meson_use sqlite)
- $(meson_use doc extra-doc)
- $(meson_use nls)
- $(meson_use tools separate-tools)
- $(meson_use security)
- $(meson_use optimization)
- $(meson_use strong-security)
- $(meson_use strong-optimization)
- $(meson_use debug debugging)
- $(meson_use swap-remote)
- $(meson_use prefix always-accept-keywords)
- $(meson_use dep dep-default)
- $(meson_use required-use required-use-default)
- $(meson_use src-uri src-uri-default)
- -Dzsh-completion="${EPREFIX}/usr/share/zsh/site-functions"
- -Dportage-rootpath="${ROOTPATH}"
- -Deprefix-default="${EPREFIX}"
- )
- if use prefix; then
- emesonarge+=(
- -Deix-user=
- -Deix-uid=-1
- )
- fi
- meson_src_configure
- else
- local myconf=(
- $(use_with jumbo-build)
- $(use_with sqlite)
- $(use_with doc extra-doc)
- $(use_enable nls)
- $(use_enable tools separate-tools)
- $(use_enable security)
- $(use_enable optimization)
- $(use_enable strong-security)
- $(use_enable strong-optimization)
- $(use_enable debug debugging)
- $(use_enable swap-remote)
- $(use_with prefix always-accept-keywords)
- $(use_with dep dep-default)
- $(use_with required-use required-use-default)
- $(use_with src-uri src-uri-default)
- --with-zsh-completion
- --with-portage-rootpath="${ROOTPATH}"
- --with-eprefix-default="${EPREFIX}"
- )
- if use prefix; then
- myconf+=(
- --with-eix-user=
- --with-eix-uid=-1
- )
- fi
- econf "${myconf[@]}"
- fi
-}
-
-src_compile() {
- if use meson; then
- meson_src_compile
- else
- default
- fi
-}
-
-src_test() {
- if use meson; then
- meson_src_test
- else
- default
- fi
-}
-
-src_install() {
- if use meson; then
- meson_src_install
- else
- default
- fi
- dobashcomp bash/eix
- dotmpfiles tmpfiles.d/eix.conf
-}
-
-pkg_postinst() {
- local obs="${EROOT}var/cache/eix.previous"
- if test -f "${obs}"; then
- ewarn "Found obsolete ${obs}, please remove it"
- fi
- tmpfiles_process eix.conf
-}
-
-pkg_postrm() {
- if [ -z "${REPLACED_BY_VERSION}" ]; then
- rm -rf -- "${EROOT}var/cache/${PN}"
- fi
-}
diff --git a/app-portage/eix/eix-0.33.4.ebuild b/app-portage/eix/eix-0.33.6.ebuild
index 633e488c..e8c6557d 100644
--- a/app-portage/eix/eix-0.33.4.ebuild
+++ b/app-portage/eix/eix-0.33.6.ebuild
@@ -18,7 +18,7 @@ IUSE="debug +dep doc +jumbo-build"
for i in ${PLOCALES}; do
IUSE+=" l10n_${i}"
done
-IUSE+=" +meson nls optimization +required-use security strong-optimization strong-security sqlite swap-remote tools"
+IUSE+=" +meson nls optimization +required-use security +src-uri strong-optimization strong-security sqlite swap-remote tools"
BOTHDEPEND="nls? ( virtual/libintl )
sqlite? ( >=dev-db/sqlite-3:= )"
@@ -61,7 +61,7 @@ src_configure() {
$(meson_use nls)
$(meson_use tools separate-tools)
$(meson_use security)
- $(meson_use optimization)
+ $(meson_use optimization normal-optimization)
$(meson_use strong-security)
$(meson_use strong-optimization)
$(meson_use debug debugging)
@@ -69,6 +69,7 @@ src_configure() {
$(meson_use prefix always-accept-keywords)
$(meson_use dep dep-default)
$(meson_use required-use required-use-default)
+ $(meson_use src-uri src-uri-default)
-Dzsh-completion="${EPREFIX}/usr/share/zsh/site-functions"
-Dportage-rootpath="${ROOTPATH}"
-Deprefix-default="${EPREFIX}"
@@ -82,7 +83,7 @@ src_configure() {
meson_src_configure
else
local myconf=(
- $(use_with jumbo-build)
+ $(use_enable jumbo-build)
$(use_with sqlite)
$(use_with doc extra-doc)
$(use_enable nls)
@@ -96,6 +97,7 @@ src_configure() {
$(use_with prefix always-accept-keywords)
$(use_with dep dep-default)
$(use_with required-use required-use-default)
+ $(use_with src-uri src-uri-default)
--with-zsh-completion
--with-portage-rootpath="${ROOTPATH}"
--with-eprefix-default="${EPREFIX}"
diff --git a/app-portage/eix/eix-99999999.ebuild b/app-portage/eix/eix-99999999.ebuild
index 1a70e427..d6e90b48 100644
--- a/app-portage/eix/eix-99999999.ebuild
+++ b/app-portage/eix/eix-99999999.ebuild
@@ -79,7 +79,7 @@ src_configure() {
$(meson_use nls)
$(meson_use tools separate-tools)
$(meson_use security)
- $(meson_use optimization)
+ $(meson_use optimization normal-optimization)
$(meson_use strong-security)
$(meson_use strong-optimization)
$(meson_use debug debugging)
@@ -101,7 +101,7 @@ src_configure() {
meson_src_configure
else
local myconf=(
- $(use_with jumbo-build)
+ $(use_enable jumbo-build)
$(use_with sqlite)
$(use_with doc extra-doc)
$(use_enable nls)