summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/find_cruft/find_cruft-2.3.ebuild')
-rw-r--r--app-portage/find_cruft/find_cruft-2.3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-portage/find_cruft/find_cruft-2.3.ebuild b/app-portage/find_cruft/find_cruft-2.3.ebuild
new file mode 100644
index 00000000..07ca8ca5
--- /dev/null
+++ b/app-portage/find_cruft/find_cruft-2.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+RESTRICT="mirror"
+inherit eutils vcs-snapshot
+
+DESCRIPTION="find cruft files not managed by portage"
+HOMEPAGE="https://github.com/vaeth/find_cruft/"
+SRC_URI="http://github.com/vaeth/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ virtual/perl-Getopt-Long"
+
+src_prepare() {
+ use prefix || sed -i \
+ -e '1s"^#!/usr/bin/env perl$"#!'"$(command -v perl)"'"' \
+ -- bin/* || die
+ epatch_user
+}
+
+src_install() {
+ dobin bin/*
+ dodoc README
+ insinto /etc
+ doins etc/*
+ dodir /etc/find_cruft.d
+ insinto /usr/share/zsh/site-functions
+ doins zsh/_*
+}
+
+pkg_postinst() {
+ has_version app-portage/eix || \
+ elog "Installing app-portage/eix will speed up ${PN}"
+}