summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/logclean/logclean-8.3.ebuild')
-rw-r--r--app-portage/logclean/logclean-8.3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-portage/logclean/logclean-8.3.ebuild b/app-portage/logclean/logclean-8.3.ebuild
new file mode 100644
index 00000000..8f7704de
--- /dev/null
+++ b/app-portage/logclean/logclean-8.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+RESTRICT="mirror"
+inherit eutils vcs-snapshot
+
+DESCRIPTION="Keep only (compressed) logs of installed packages"
+HOMEPAGE="https://github.com/vaeth/logclean/"
+SRC_URI="http://github.com/vaeth/${PN}/tarball/release-${PV} -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="zsh-completion"
+
+RDEPEND="dev-lang/perl
+ virtual/perl-Getopt-Long"
+
+src_prepare() {
+ epatch_user
+}
+
+src_install() {
+ dobin "${PN}"
+ insinto /etc
+ doins "${PN}.conf"
+ if use zsh-completion
+ then insinto /usr/share/zsh/site-functions
+ doins "_${PN}"
+ fi
+}
+
+pkg_postinst() {
+ has_version app-portage/eix || \
+ elog "Installing app-portage/eix will speed up execution time"
+}