summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/portage-bashrc-mv/portage-bashrc-mv-12.5.ebuild')
-rw-r--r--app-portage/portage-bashrc-mv/portage-bashrc-mv-12.5.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-portage/portage-bashrc-mv/portage-bashrc-mv-12.5.ebuild b/app-portage/portage-bashrc-mv/portage-bashrc-mv-12.5.ebuild
new file mode 100644
index 00000000..d81d4a49
--- /dev/null
+++ b/app-portage/portage-bashrc-mv/portage-bashrc-mv-12.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+RESTRICT="mirror"
+inherit eutils vcs-snapshot
+
+DESCRIPTION="Provide support for /etc/portage/bashrc.d and /etc/portage/package.cflags"
+HOMEPAGE="https://github.com/vaeth/portage-bashrc-mv/"
+SRC_URI="http://github.com/vaeth/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch_user
+}
+
+src_install() {
+ insinto /etc/portage
+ doins -r bashrc bashrc.d
+ docompress /etc/portage/bashrc.d/README
+}
+
+pkg_postinst() {
+ has_version app-portage/eix || \
+ elog "Installing app-portage/eix will improve mask handling"
+ ! test -d /var/cache/gpo || \
+ ewarn 'Obsolete /var/cache/gpo found. Please remove'
+}