summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/useflags/useflags-3.0.ebuild')
-rw-r--r--app-portage/useflags/useflags-3.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-portage/useflags/useflags-3.0.ebuild b/app-portage/useflags/useflags-3.0.ebuild
new file mode 100644
index 00000000..411a79c6
--- /dev/null
+++ b/app-portage/useflags/useflags-3.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+RESTRICT="mirror"
+inherit eutils vcs-snapshot
+
+DESCRIPTION="Print or save the current USE-flag state and compare with older versions"
+HOMEPAGE="https://github.com/vaeth/useflags/"
+SRC_URI="http://github.com/vaeth/${PN}/tarball/release-${PV} -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="zsh-completion"
+
+RDEPEND="dev-lang/perl
+ virtual/perl-Getopt-Long"
+
+src_prepare() {
+ epatch_user
+}
+
+src_install() {
+ dobin "${PN}"
+ if use zsh-completion
+ then insinto /usr/share/zsh/site-functions
+ doins "_${PN}"
+ fi
+}
+
+pkg_postinst() {
+ if ! has_version 'app-portage/eix'
+ then elog "Install app-portage/eix for faster execution time."
+ elog "With >=app-portage/eix-0.27.7 also security is increased."
+ elif has_version '<app-portage/eix-0.27.7'
+ then elog "Upgrade to >=app-portage/eix-0.27.7 to increase security."
+ fi
+}