summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/world-mv/world-mv-3.19.ebuild')
-rw-r--r--app-portage/world-mv/world-mv-3.19.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-portage/world-mv/world-mv-3.19.ebuild b/app-portage/world-mv/world-mv-3.19.ebuild
new file mode 100644
index 00000000..801c7727
--- /dev/null
+++ b/app-portage/world-mv/world-mv-3.19.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+RESTRICT="mirror"
+
+mPN="${PN%-*}"
+DESCRIPTION="Organize your world file and find installed packages or differences to @world"
+HOMEPAGE="https://github.com/vaeth/world/"
+SRC_URI="https://github.com/vaeth/${mPN}/archive/v${PV}.tar.gz -> ${mPN}-${PV}.tar.gz"
+S="${WORKDIR}/${mPN}-${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+S="${WORKDIR}/${mPN}-${PV}"
+
+src_prepare() {
+ if use prefix
+ then sed -i \
+ -e "s'\${EPREFIX}'\\'${EPREFIX}\\''" \
+ -- bin/* || die
+ else sed -i \
+ -e '1s"^#!/usr/bin/env sh$"#!'"${EPREFIX}/bin/sh"'"' \
+ -- bin/* || die
+ fi
+ eapply_user
+}
+
+src_install() {
+ dobin bin/*
+ insinto /usr/share/zsh/site-functions
+ doins zsh/*
+}