summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/eix/Manifest2
-rw-r--r--app-portage/eix/eix-0.32.11_alpha3.ebuild (renamed from app-portage/eix/eix-0.32.11_alpha2.ebuild)10
-rw-r--r--app-portage/eix/eix-99999999.ebuild10
3 files changed, 15 insertions, 7 deletions
diff --git a/app-portage/eix/Manifest b/app-portage/eix/Manifest
index 2da03637..32354b9c 100644
--- a/app-portage/eix/Manifest
+++ b/app-portage/eix/Manifest
@@ -1,2 +1,2 @@
DIST eix-0.32.10.tar.xz 600120 SHA256 4ecd6ed7e5bb8859c5e5548265e622bffd19800c889d49e75c0bad556830c5da
-DIST eix-0.32.11_alpha2.tar.gz 665406 SHA256 878619eb616dffcd48dbf17b9d60a8073765336cbeff0238dea5c2a1ec961077
+DIST eix-0.32.11_alpha3.tar.gz 666015 SHA256 a671a8ff838826363f5f0b22a3777859cb1230ea39fb05ad5d4f91b120955058
diff --git a/app-portage/eix/eix-0.32.11_alpha2.ebuild b/app-portage/eix/eix-0.32.11_alpha3.ebuild
index 54a7ef24..90d5ce98 100644
--- a/app-portage/eix/eix-0.32.11_alpha2.ebuild
+++ b/app-portage/eix/eix-0.32.11_alpha3.ebuild
@@ -5,8 +5,9 @@ EAPI=6
RESTRICT="mirror"
WANT_LIBTOOL=none
AUTOTOOLS_AUTO_DEPEND=no
+MESON_AUTO_DEPEND=no
PLOCALES="de ru"
-inherit autotools bash-completion-r1 l10n meson tmpfiles
+inherit autotools bash-completion-r1 l10n meson_optional tmpfiles
case ${PV} in
99999999*)
@@ -16,7 +17,7 @@ case ${PV} in
PROPERTIES="live";;
*)
RESTRICT="mirror"
- EGIT_COMMIT="a0ce147d0da7587ba560ed2994abc045faabab77"
+ EGIT_COMMIT="cea240dce2e8566714b9eec88ff50cc1b7374249"
SRC_URI="https://github.com/vaeth/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-${EGIT_COMMIT}";;
esac
@@ -35,7 +36,10 @@ RDEPEND="${BOTHDEPEND}
>=app-shells/push-2.0-r2
>=app-shells/quoter-3.0-r2"
DEPEND="${BOTHDEPEND}
- meson? ( >=dev-util/meson-0.41.0 )
+ meson? (
+ >=dev-util/meson-0.41.0
+ >=dev-util/ninja-1.7.2
+ )
!meson? ( ${AUTOTOOLS_DEPEND} )
>=sys-devel/gettext-0.19.6"
diff --git a/app-portage/eix/eix-99999999.ebuild b/app-portage/eix/eix-99999999.ebuild
index 54a7ef24..90d5ce98 100644
--- a/app-portage/eix/eix-99999999.ebuild
+++ b/app-portage/eix/eix-99999999.ebuild
@@ -5,8 +5,9 @@ EAPI=6
RESTRICT="mirror"
WANT_LIBTOOL=none
AUTOTOOLS_AUTO_DEPEND=no
+MESON_AUTO_DEPEND=no
PLOCALES="de ru"
-inherit autotools bash-completion-r1 l10n meson tmpfiles
+inherit autotools bash-completion-r1 l10n meson_optional tmpfiles
case ${PV} in
99999999*)
@@ -16,7 +17,7 @@ case ${PV} in
PROPERTIES="live";;
*)
RESTRICT="mirror"
- EGIT_COMMIT="a0ce147d0da7587ba560ed2994abc045faabab77"
+ EGIT_COMMIT="cea240dce2e8566714b9eec88ff50cc1b7374249"
SRC_URI="https://github.com/vaeth/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-${EGIT_COMMIT}";;
esac
@@ -35,7 +36,10 @@ RDEPEND="${BOTHDEPEND}
>=app-shells/push-2.0-r2
>=app-shells/quoter-3.0-r2"
DEPEND="${BOTHDEPEND}
- meson? ( >=dev-util/meson-0.41.0 )
+ meson? (
+ >=dev-util/meson-0.41.0
+ >=dev-util/ninja-1.7.2
+ )
!meson? ( ${AUTOTOOLS_DEPEND} )
>=sys-devel/gettext-0.19.6"