summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/auto-fu-zsh/auto-fu-zsh-0.0.1.12-r4.ebuild')
-rw-r--r--app-shells/auto-fu-zsh/auto-fu-zsh-0.0.1.12-r4.ebuild30
1 files changed, 13 insertions, 17 deletions
diff --git a/app-shells/auto-fu-zsh/auto-fu-zsh-0.0.1.12-r4.ebuild b/app-shells/auto-fu-zsh/auto-fu-zsh-0.0.1.12-r4.ebuild
index aad9a8a6..feb8d9bb 100644
--- a/app-shells/auto-fu-zsh/auto-fu-zsh-0.0.1.12-r4.ebuild
+++ b/app-shells/auto-fu-zsh/auto-fu-zsh-0.0.1.12-r4.ebuild
@@ -1,31 +1,27 @@
-# Copyright 2012-2018 Martin V\"ath
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
+# $Id$
-EAPI=7
+EAPI=5
+inherit eutils
pPN=${PN%-zsh}
mPN="${pPN}.zsh"
-NEED_PATCHES=false
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
case ${PV} in
99999999*)
- EGIT_REPO_URI="https://github.com/hchbaw/${mPN}.git"
+ LIVE=:
+ EGIT_REPO_URI="git://github.com/hchbaw/${mPN}.git"
EGIT_BRANCH="pu"
inherit git-r3
PROPERTIES="live"
SRC_URI=""
KEYWORDS="";;
-0.0.1.12_p0)
- RESTRICT="mirror"
- EGIT_COMMIT="42dbef5da89360f132cce010004d4c674a13c951"
- SRC_URI="https://github.com/hchbaw/${mPN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/${mPN}-${EGIT_COMMIT}"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris";;
*)
+ LIVE=false
RESTRICT="mirror"
SRC_URI="https://github.com/hchbaw/${mPN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${mPN}-${PV}"
- NEED_PATCHES=:;;
+ KEYWORDS="~amd64 ~x86";;
esac
DESCRIPTION="zsh automatic complete-word and list-choices: incremental completion"
@@ -106,16 +102,16 @@ src_prepare() {
umask 022
generate_example >"${S}"/zshrc-example
)
- if ${NEED_PATCHES}
+ if ! ${LIVE}
then
# Make Ctrl-D return correctly.
- eapply "${FILESDIR}"/exit.patch
+ epatch "${FILESDIR}"/exit.patch
# Reset color with "return":
- eapply "${FILESDIR}"/reset-color.patch
+ epatch "${FILESDIR}"/reset-color.patch
# Make it work with older zsh versions:
- eapply "${FILESDIR}"/zsh-compatibility.patch
+ epatch "${FILESDIR}"/zsh-compatibility.patch
fi
- default
+ epatch_user
}
src_compile() {