summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/auto-fu-zsh')
-rw-r--r--app-shells/auto-fu-zsh/ChangeLog8
-rw-r--r--app-shells/auto-fu-zsh/Manifest1
-rw-r--r--app-shells/auto-fu-zsh/auto-fu-zsh-0.0.1.12.ebuild60
-rw-r--r--app-shells/auto-fu-zsh/metadata.xml18
4 files changed, 87 insertions, 0 deletions
diff --git a/app-shells/auto-fu-zsh/ChangeLog b/app-shells/auto-fu-zsh/ChangeLog
new file mode 100644
index 00000000..7f059b61
--- /dev/null
+++ b/app-shells/auto-fu-zsh/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-shells/auto-fu-zsh
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*auto-fu-zsh-0.0.1.12 (12 Aug 2012)
+
+ 12 Aug 2012; Martin Väth <martin@mvath.de>
+ Write ebuild from scratch.
diff --git a/app-shells/auto-fu-zsh/Manifest b/app-shells/auto-fu-zsh/Manifest
new file mode 100644
index 00000000..994e7576
--- /dev/null
+++ b/app-shells/auto-fu-zsh/Manifest
@@ -0,0 +1 @@
+DIST auto-fu-zsh-0.0.1.12.tar.gz 9420 SHA256 e1e4ccf1a45d52f4a6e54075f66ce04d8f7804f3b4eedba529c85b99fcc77870 SHA512 032cf7c5aeb77553c46f5f14dbdcd3e5aaedcc2c65f1f099c4ae654a8c86852c41fb8efa1b1563ac9e67e2fd54efcfb97a5a62a3b982604af61f873e10db12af WHIRLPOOL 47733afb7a83c088f66bee2fee9aba0c25bac4426d80ea694eec10add30dd0303245c43b490a3fc6347ef53893fb57985f18af0efdccebe37b931147be552ffe
diff --git a/app-shells/auto-fu-zsh/auto-fu-zsh-0.0.1.12.ebuild b/app-shells/auto-fu-zsh/auto-fu-zsh-0.0.1.12.ebuild
new file mode 100644
index 00000000..7113e629
--- /dev/null
+++ b/app-shells/auto-fu-zsh/auto-fu-zsh-0.0.1.12.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+RESTRICT="mirror"
+inherit eutils vcs-snapshot
+
+pPN=${PN%-zsh}
+mPN="${pPN}.zsh"
+DESCRIPTION="zsh automatic complete-word and list-choices: incremental completion"
+HOMEPAGE="https://github.com/hchbaw/auto-fu.zsh/"
+SRC_URI="http://github.com/hchbaw/${mPN}/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+compile"
+
+DEPEND="compile? ( app-shells/zsh )"
+
+DESTPATH="/usr/share/zsh/site-contrib/${pPN}"
+
+generate_example() {
+ echo "# Put something like this into your ~/.zshrc"
+ if use compile
+ then echo "source ${DESTPATH}/${pPN}
+auto-fu-install"
+ else echo "source ${DESTPATH}/${pPN}.zsh"
+ fi
+ echo "zstyle ':auto-fu:highlight' input bold
+zstyle ':auto-fu:highlight' completion fg=yellow
+zstyle ':auto-fu:highlight' completion/one fg=blue
+zstyle ':auto-fu:var' postdisplay # \$'\\n-azfu-'
+zstyle ':auto-fu:var' track-keymap-skip opp
+#zstyle ':auto-fu:var' disable magic-space
+zle-line-init() auto-fu-init
+zle -N zle-line-init
+zle -N zle-keymap-select auto-fu-zle-keymap-select
+zstyle ':completion:*' completer _oldlist _complete"
+}
+
+src_prepare() {
+ (
+ umask 022
+ generate_example >"${S}"/zshrc-example
+ )
+ epatch_user
+}
+
+src_compile() {
+ ! use compile || zsh -c "source ${mPN} && auto-fu-zcompile ${mPN} ." || die
+}
+
+src_install() {
+ insinto "${DESTPATH}"
+ doins "${mPN}"
+ ! use compile || doins "${pPN}" "${pPN}.zwc"
+ dodoc zshrc-example README*
+}
diff --git a/app-shells/auto-fu-zsh/metadata.xml b/app-shells/auto-fu-zsh/metadata.xml
new file mode 100644
index 00000000..9c7557cb
--- /dev/null
+++ b/app-shells/auto-fu-zsh/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>takebi@laafc.net</email>
+ <name>Takeshi Banse</name>
+ </maintainer>
+ <remote-id type="github">hchbaw/auto-fu.zsh</remote-id>
+ </upstream>
+ <use>
+ <flag name="compile">Byte-compile to speed up</flag>
+ </use>
+</pkgmetadata>