summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/push/push-3.3.ebuild')
-rw-r--r--app-shells/push/push-3.3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-shells/push/push-3.3.ebuild b/app-shells/push/push-3.3.ebuild
new file mode 100644
index 00000000..a16370d1
--- /dev/null
+++ b/app-shells/push/push-3.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2012-2020 Martin V\"ath
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A POSIX shell function to treat a variable like an array, quoting args"
+HOMEPAGE="https://github.com/vaeth/push/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+IUSE="split-usr"
+
+# Install into / to let sys-block/zram-init work with split /usr
+
+src_compile() {
+ emake PREFIX= EPREFIX="${EPREFIX}" BINDIR=$(get_usr)/bin DATADIR=$(get_usr)/lib/push
+}
+
+src_install() {
+ dodoc README.md
+ emake DESTDIR="${ED}" PREFIX= EPREFIX="${EPREFIX}" BINDIR=$(get_usr)/bin DATADIR=$(get_usr)/lib/push install
+}
+
+get_usr() {
+ use split-usr || echo /usr
+}