summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/runtitle/runtitle-2.7.ebuild')
-rw-r--r--app-shells/runtitle/runtitle-2.7.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-shells/runtitle/runtitle-2.7.ebuild b/app-shells/runtitle/runtitle-2.7.ebuild
new file mode 100644
index 00000000..71ebe8a4
--- /dev/null
+++ b/app-shells/runtitle/runtitle-2.7.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+RESTRICT="mirror"
+inherit eutils
+
+DESCRIPTION="Scripts to run commands and set the hard status line (windows title)"
+HOMEPAGE="https://github.com/vaeth/runtitle/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+src_prepare() {
+ use prefix || sed -i \
+ -e '1s"^#!/usr/bin/env sh$"#!'"${EPREFIX}/bin/sh"'"' \
+ -- bin/* || die
+ epatch_user
+}
+
+src_install() {
+ dobin bin/*
+ insinto /usr/share/zsh/site-functions
+ doins zsh/*
+ dodoc README
+}