summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/set_prompt/set_prompt-1.23.ebuild')
-rw-r--r--app-shells/set_prompt/set_prompt-1.23.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-shells/set_prompt/set_prompt-1.23.ebuild b/app-shells/set_prompt/set_prompt-1.23.ebuild
new file mode 100644
index 00000000..94a9288d
--- /dev/null
+++ b/app-shells/set_prompt/set_prompt-1.23.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+RESTRICT="mirror"
+inherit eutils
+
+DESCRIPTION="An intelligent prompt for zsh or bash with status line (window title) support"
+HOMEPAGE="https://github.com/vaeth/set_prompt/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ use prefix || sed -i \
+ -e '1s"^#!/usr/bin/env sh$"#!'"${EPREFIX}"'/bin/sh"' \
+ -e '1s"^#!/usr/bin/env zsh$"#!'"${EPREFIX}"'/bin/zsh"' \
+ -- * || die
+ epatch_user
+}
+
+src_install() {
+ insinto /etc
+ doins set_prompt.config
+ insinto /usr/bin
+ doins set_prompt.sh git_prompt.zsh
+ dobin set_prompt git_update
+ dodoc README
+}