summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/set_prompt/set_prompt-1.25.ebuild')
-rw-r--r--app-shells/set_prompt/set_prompt-1.25.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-shells/set_prompt/set_prompt-1.25.ebuild b/app-shells/set_prompt/set_prompt-1.25.ebuild
new file mode 100644
index 00000000..e62e00c9
--- /dev/null
+++ b/app-shells/set_prompt/set_prompt-1.25.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+RESTRICT="mirror"
+
+DESCRIPTION="An intelligent prompt for zsh or bash with status line (window title) support"
+HOMEPAGE="https://github.com/vaeth/set_prompt/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+src_prepare() {
+ use prefix || sed -i \
+ -e '1s"^#!/usr/bin/env sh$"#!'"${EPREFIX}"'/bin/sh"' \
+ -e '1s"^#!/usr/bin/env zsh$"#!'"${EPREFIX}"'/bin/zsh"' \
+ -- * || die
+ eapply_user
+}
+
+src_install() {
+ insinto /etc
+ doins set_prompt.config
+ insinto /usr/bin
+ doins set_prompt.sh git_prompt.zsh
+ dobin set_prompt git_update
+ dodoc README
+}