summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/termcolors-mv/termcolors-mv-3.0.ebuild')
-rw-r--r--app-shells/termcolors-mv/termcolors-mv-3.0.ebuild23
1 files changed, 9 insertions, 14 deletions
diff --git a/app-shells/termcolors-mv/termcolors-mv-3.0.ebuild b/app-shells/termcolors-mv/termcolors-mv-3.0.ebuild
index 73b99521..b2b91128 100644
--- a/app-shells/termcolors-mv/termcolors-mv-3.0.ebuild
+++ b/app-shells/termcolors-mv/termcolors-mv-3.0.ebuild
@@ -4,7 +4,7 @@
EAPI=5
RESTRICT="mirror"
-inherit eutils vcs-snapshot
+inherit eutils readme.gentoo vcs-snapshot
DESCRIPTION="256colors sample script and dircolors configuration for standard or 256 colors"
HOMEPAGE="https://github.com/vaeth/termcolors-mv/"
@@ -18,6 +18,13 @@ DEPEND="dev-lang/perl"
RDEPEND="create? ( dev-lang/perl )
perl? ( dev-lang/perl )"
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="To use the colorschemes of ${PN} call
+ eval \"\`dircolors-mv\`\"
+e.g. in your bashrc; make sure that SOLARIZED (if desired)
+and DEFAULTS is set appropriately, see the documentation.
+For zsh, this happens if you use zshrc-mv"
+
src_prepare() {
epatch_user
}
@@ -33,17 +40,5 @@ src_install() {
use perl && dobin bin/256colors
insinto /etc/dir_colors
doins DIR_COLORS*
-}
-
-pkg_postinst() {
- case "${REPLACING_VERSIONS:-1.1}" in
- 1.1)
- elog "To use the colorschemes of ${PN} call"
- elog " eval \"\`dircolors-mv\`\""
- elog "e.g. in your bashrc; make sure that SOLARIZED (if desired)"
- elog "and DEFAULTS is set appropriately, see the documentation."
- if ! has_version app-shells/zshrc-mv
- then elog "For zsh, this happens if you use zshrc-mv"
- fi;;
- esac
+ readme.gentoo_src_install
}