summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/zsh-syntax-highlighting')
-rw-r--r--app-shells/zsh-syntax-highlighting/Manifest1
-rw-r--r--app-shells/zsh-syntax-highlighting/metadata.xml12
-rw-r--r--app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.2.1.ebuild52
-rw-r--r--app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-99999999.ebuild52
4 files changed, 117 insertions, 0 deletions
diff --git a/app-shells/zsh-syntax-highlighting/Manifest b/app-shells/zsh-syntax-highlighting/Manifest
new file mode 100644
index 00000000..020adc4e
--- /dev/null
+++ b/app-shells/zsh-syntax-highlighting/Manifest
@@ -0,0 +1 @@
+DIST zsh-syntax-highlighting-0.2.1.tar.gz 12400 SHA256 3cdf47ee613ff748230e9666c0122eca22dc05352f266fe640019c982f3ef6db SHA512 40b04f45035081858d14d8044659db3e96e881e387c91564ff58314972207a47145f13ecdb604c0a7a5683c0a922811c4ee36e3d18558c6126db24b5da2d862c WHIRLPOOL 7707bd843d77bf53bd2aef4260a683fe8de6fb0529d9c58e7780b43131eda4541054165c3cd5e69f8d04721d2264a60233f4efda6958af819d1345e19dc715bb
diff --git a/app-shells/zsh-syntax-highlighting/metadata.xml b/app-shells/zsh-syntax-highlighting/metadata.xml
new file mode 100644
index 00000000..a1caaddd
--- /dev/null
+++ b/app-shells/zsh-syntax-highlighting/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/zsh-users/zsh-syntax-highlighting/issues</bugs-to>
+ <remote-id type="github">zsh-users/zsh-syntax-highlighting</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.2.1.ebuild b/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.2.1.ebuild
new file mode 100644
index 00000000..be2a231c
--- /dev/null
+++ b/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.2.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils readme.gentoo
+
+case ${PV} in
+99999999*)
+ EGIT_REPO_URI="git://github.com/zsh-users/${PN}.git"
+ inherit git-r3
+ PROPERTIES="live"
+ SRC_URI=""
+ KEYWORDS="";;
+*)
+ RESTRICT="mirror"
+ SRC_URI="https://github.com/zsh-users/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86";;
+esac
+
+DESCRIPTION="Fish shell like syntax highlighting for zsh"
+HOMEPAGE="https://github.com/zsh-users/zsh-syntax-highlighting"
+
+LICENSE="HPND"
+SLOT="0"
+IUSE=""
+
+RDEPEND="app-shells/zsh"
+DEPEND=""
+
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="In order to use ${CATEGORY}/${PN} add
+. /usr/share/zsh/site-contrib/${PN}/zsh-syntax-highlighting.zsh
+at the end of your ~/.zshrc
+For testing, you can also execute the above command in your zsh."
+
+src_prepare() {
+ grep -q 'local .*cdpath_dir' \
+ "${S}/highlighters/main/main-highlighter.zsh" >/dev/null 2>&1 || \
+ sed -i -e '/for cdpath_dir/ilocal cdpath_dir' \
+ -- "${S}/highlighters/main/main-highlighter.zsh" || die
+ epatch_user
+}
+
+src_install() {
+ dodoc *.md
+ insinto /usr/share/zsh/site-contrib/${PN}
+ doins *.zsh
+ doins -r highlighters
+ readme.gentoo_create_doc
+}
diff --git a/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-99999999.ebuild b/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-99999999.ebuild
new file mode 100644
index 00000000..be2a231c
--- /dev/null
+++ b/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-99999999.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils readme.gentoo
+
+case ${PV} in
+99999999*)
+ EGIT_REPO_URI="git://github.com/zsh-users/${PN}.git"
+ inherit git-r3
+ PROPERTIES="live"
+ SRC_URI=""
+ KEYWORDS="";;
+*)
+ RESTRICT="mirror"
+ SRC_URI="https://github.com/zsh-users/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86";;
+esac
+
+DESCRIPTION="Fish shell like syntax highlighting for zsh"
+HOMEPAGE="https://github.com/zsh-users/zsh-syntax-highlighting"
+
+LICENSE="HPND"
+SLOT="0"
+IUSE=""
+
+RDEPEND="app-shells/zsh"
+DEPEND=""
+
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="In order to use ${CATEGORY}/${PN} add
+. /usr/share/zsh/site-contrib/${PN}/zsh-syntax-highlighting.zsh
+at the end of your ~/.zshrc
+For testing, you can also execute the above command in your zsh."
+
+src_prepare() {
+ grep -q 'local .*cdpath_dir' \
+ "${S}/highlighters/main/main-highlighter.zsh" >/dev/null 2>&1 || \
+ sed -i -e '/for cdpath_dir/ilocal cdpath_dir' \
+ -- "${S}/highlighters/main/main-highlighter.zsh" || die
+ epatch_user
+}
+
+src_install() {
+ dodoc *.md
+ insinto /usr/share/zsh/site-contrib/${PN}
+ doins *.zsh
+ doins -r highlighters
+ readme.gentoo_create_doc
+}