summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/zsh/zsh-99999999.ebuild')
l---------[-rw-r--r--]app-shells/zsh/zsh-99999999.ebuild295
1 files changed, 1 insertions, 294 deletions
diff --git a/app-shells/zsh/zsh-99999999.ebuild b/app-shells/zsh/zsh-99999999.ebuild
index 9753ffb5..4e9fbb70 100644..120000
--- a/app-shells/zsh/zsh-99999999.ebuild
+++ b/app-shells/zsh/zsh-99999999.ebuild
@@ -1,294 +1 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=5
-
-# doc package for -dev version exists?
-doc_available=true
-
-# sourceforge mirror for non-git version exists?
-sourceforge_mirror=false
-
-inherit eutils flag-o-matic multilib prefix readme.gentoo
-
-MY_PV=${PV/_p/-dev-}
-S=${WORKDIR}/${PN}-${MY_PV}
-
-zsh_ftp="http://www.zsh.org/pub"
-
-if [[ ${PV} != "${MY_PV}" ]] ; then
- ZSH_URI="${zsh_ftp}/development/${PN}-${MY_PV}.tar.bz2"
- if ${doc_available} ; then
- ZSH_DOC_URI="${zsh_ftp}/development/${PN}-${MY_PV}-doc.tar.bz2"
- else
- ZSH_DOC_URI="${zsh_ftp}/${PN}-${PV%_*}-doc.tar.bz2"
- fi
-else
- ZSH_URI=""
- ${sourceforge_mirror} && ZSH_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
- ZSH_URI+="
- ${zsh_ftp}/${P}.tar.bz2"
- ZSH_DOC_URI="${zsh_ftp}/${PN}-${PV%_*}-doc.tar.bz2"
-fi
-
-DESCRIPTION="UNIX Shell similar to the Korn shell"
-HOMEPAGE="http://www.zsh.org/"
-case ${PV} in
-9999*)
- SRC_URI=""
- EGIT_REPO_URI="git://git.code.sf.net/p/zsh/code"
- inherit git-r3
- WANT_LIBTOOL="none"
- inherit autotools
- KEYWORDS=""
-# Creating help files needs util-linux for colcrt.
-# Please let me know if you have an arch where "colcrt" (or at least "col")
-# is provided by a different package.
- DEPEND="app-text/yodl
- dev-lang/perl
- sys-apps/man
- sys-apps/util-linux"
- PROPERTIES="live"
- LIVE=:;;
-*)
- SRC_URI="${ZSH_URI}
- doc? ( ${ZSH_DOC_URI} )"
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
- #KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
- DEPEND=""
- LIVE=false;;
-esac
-
-LICENSE="ZSH gdbm? ( GPL-2 )"
-SLOT="0"
-IUSE="caps compile"
-COMPLETIONS="AIX BSD Cygwin Darwin Debian +Linux Mandriva openSUSE Redhat Solaris +Unix +X"
-for curr in ${COMPLETIONS}
-do case ${curr} in
- [+-]*)
- IUSE+=" ${curr%%[!+-]*}completion_${curr#?}"
- continue;;
- esac
- IUSE+=" completion_${curr}"
-done
-IUSE+=" debug doc examples gdbm maildir pcre static unicode"
-
-RDEPEND="
- >=sys-libs/ncurses-5.1
- static? ( >=sys-libs/ncurses-5.7-r4[static-libs] )
- caps? ( sys-libs/libcap )
- pcre? ( >=dev-libs/libpcre-3.9
- static? ( >=dev-libs/libpcre-3.9[static-libs] ) )
- gdbm? ( sys-libs/gdbm )
-"
-DEPEND+="
- sys-apps/groff
- ${RDEPEND}"
-PDEPEND="
- examples? ( app-doc/zsh-lovers )
-"
-
-DISABLE_AUTOFORMATTING="true"
-DOC_CONTENTS="
-If you want to enable Portage completions and Gentoo prompt,
-emerge app-shells/zsh-completion and add
- autoload -U compinit promptinit
- compinit
- promptinit; prompt gentoo
-to your ~/.zshrc
-
-Also, if you want to enable cache for the completions, add
- zstyle ':completion::complete:*' use-cache 1
-to your ~/.zshrc
-
-If you want to use run-help add to your ~/.zshrc
- unalias run-help
- autoload -Uz run-help
-
-Note that a system zprofile startup file is installed. This will override
-PATH and possibly other variables that a user may set in ~/.zshenv.
-Custom PATH settings and similar overridden variables can be moved
-to ~/.zprofile or other user startup files that are sourced after the
-system zprofile.
-
-If PATH must be set in ~/.zshenv to affect things like non-login ssh shells,
-one method is to use a separate path-setting file that is conditionally sourced
-in ~/.zshenv and also sourced from ~/.zprofile. For more information, see the
-zshenv example in ${EROOT}/usr/share/doc/${PF}/StartupFiles/."
-
-src_prepare() {
- # fix zshall problem with soelim
- ln -s Doc man1 || die
- mv Doc/zshall.1 Doc/zshall.1.soelim || die
- soelim Doc/zshall.1.soelim > Doc/zshall.1 || die
-
- epatch "${FILESDIR}"/${PN}-init.d-gentoo-r1.diff
-
- cp "${FILESDIR}"/zprofile-1 "${T}"/zprofile || die
- eprefixify "${T}"/zprofile || die
- if use prefix ; then
- sed -i -e 's|@ZSH_PREFIX@||' -e '/@ZSH_NOPREFIX@/d' "${T}"/zprofile || die
- else
- sed -i -e 's|@ZSH_NOPREFIX@||' -e '/@ZSH_PREFIX@/d' -e 's|""||' "${T}"/zprofile || die
- fi
- set --
- file='Src/Zle/complete.mdd'
- for i in ${COMPLETIONS}
- do case ${i} in
- [+-]*)
- i=${i#?};;
- esac
- grep -q "Completion\/${i}" -- "${S}/${file}" \
- || die "${file} does not contain Completion/${i}"
- use completion_${i} || set -- "${@}" -e "s/Completion\/${i}[^ ']*//"
- done
- [ ${#} -eq 0 ] || sed -i "${@}" -- "${S}/${file}" \
- || die "patching ${file} failed"
- epatch_user
- ! ${LIVE} || eautoreconf
- PVPATH=$(. "${S}"/Config/version.mk && printf '%s' "${VERSION}") && \
- [ -n "${PVPATH}" ] || PVPATH=${PV}
-}
-
-src_configure() {
- local myconf=
-
- if use static ; then
- myconf+=" --disable-dynamic"
- append-ldflags -static
- fi
- if use debug ; then
- myconf+=" \
- --enable-zsh-debug \
- --enable-zsh-mem-debug \
- --enable-zsh-mem-warning \
- --enable-zsh-secure-free \
- --enable-zsh-hash-debug"
- fi
-
- if [[ ${CHOST} == *-darwin* ]]; then
- myconf+=" --enable-libs=-liconv"
- append-ldflags -Wl,-x
- fi
-
- econf \
- --bindir="${EPREFIX}"/bin \
- --libdir="${EPREFIX}"/usr/$(get_libdir) \
- --enable-etcdir="${EPREFIX}"/etc/zsh \
- --enable-runhelpdir="${EPREFIX}"/usr/share/zsh/${PVPATH}/help \
- --enable-fndir="${EPREFIX}"/usr/share/zsh/${PVPATH}/functions \
- --enable-site-fndir="${EPREFIX}"/usr/share/zsh/site-functions \
- --enable-function-subdirs \
- --with-tcsetpgrp \
- $(use_enable maildir maildir-support) \
- $(use_enable pcre) \
- $(use_enable caps cap) \
- $(use_enable unicode multibyte) \
- $(use_enable gdbm ) \
- ${myconf}
-
- if use static ; then
- # compile all modules statically, see Bug #27392
- # removed cap and curses because linking failes
- sed -i \
- -e "s,link=no,link=static,g" \
- -e "/^name=zsh\/cap/s,link=static,link=no," \
- -e "/^name=zsh\/curses/s,link=static,link=no," \
- "${S}"/config.modules || die
- if ! use gdbm ; then
- sed -i '/^name=zsh\/db\/gdbm/s,link=static,link=no,' \
- "${S}"/config.modules || die
- fi
- fi
-}
-
-src_compile() {
- default
- ! ${LIVE} || ! use doc || emake dvi pdf html
-}
-
-src_test() {
- addpredict /dev/ptmx
- local i
- for i in C02cond.ztst V08zpty.ztst X02zlevi.ztst Y01completion.ztst Y02compmatch.ztst Y03arguments.ztst ; do
- rm "${S}"/Test/${i} || die
- done
- emake check
-}
-
-zcompile_dirs() {
- use compile || return 0
- einfo "compiling modules"
- local i
- i="${S}/Src/zshpaths.h"
- test -f "${i}" || die "cannot find ${i}"
- # We need this directory also in pkg_postinst
- FPATH_DIR="$(sed -n -e \
- 's/^#define FPATH_DIR .*\"\(.*\)\".*$/\1/p' -- "${i}" 2>/dev/null)" \
- || FPATH_DIR=
- [ -n "${FPATH_DIR}" ] || die "cannot parse ${i}"
- pushd -- "${ED}" >/dev/null || die
- test -d ".${FPATH_DIR}" || die "parsing ${i} gave strange result ${FPATH_DIR}"
- find ".${FPATH_DIR}" -type d -exec "${ED}bin/zsh" -fc 'setopt nullglob
-for i
-do a=(${i}/*(.))
- [[ ${#a} -eq 0 ]] && continue
- echo "Compiling ${i#.}.zwc"
- zcompile -U -M ${i}.zwc ${a} || exit
-done' zsh '{}' '+' || die 'compiling failed. If you are cross-compiling set USE=-compile'
- popd >/dev/null
-}
-
-touch_zwc() {
- use compile || return 0
- einfo "touching *.zwc files"
- # Make a sanity check that variables are preserved after zcompile_dirs:
- # If the package mangler is not faulty, this *must* succeeed.
- [ -n "${FPATH_DIR}" ] && test -d "${FPATH_DIR}" || die "strange FPATH_DIR"
- # Now the actual action
- find "${EPREFIX}${FPATH_DIR}" -type f -name '*.zwc' \
- -exec "$(command -v touch)" -- '{}' '+'
-}
-
-src_install() {
- emake DESTDIR="${ED}" install install.info
-
- insinto /etc/zsh
- doins "${T}"/zprofile
-
- keepdir /usr/share/zsh/site-functions
- insinto /usr/share/zsh/"${PVPATH}"/functions/Prompts
- newins "${FILESDIR}"/prompt_gentoo_setup-1 prompt_gentoo_setup
-
- # install miscellaneous scripts; bug #54520
- local i
- sed -i -e "s:/usr/local/bin/perl:${EPREFIX}/usr/bin/perl:g" \
- -e "s:/usr/local/bin/zsh:${EPREFIX}/bin/zsh:g" "${S}"/{Util,Misc}/* || die
- for i in Util Misc ; do
- insinto /usr/share/zsh/"${PVPATH}"/${i}
- doins ${i}/*
- done
-
- dodoc ChangeLog* META-FAQ NEWS README config.modules
- readme.gentoo_create_doc
-
- if use doc ; then
- pushd "${WORKDIR}/${PN}-${PV%_*}" >/dev/null
- dohtml -r Doc/*
- dodoc Doc/zsh.{dvi,pdf}
- popd >/dev/null
- fi
-
- docinto StartupFiles
- dodoc StartupFiles/z*
-
- zcompile_dirs
-
- rm -vf -- "${ED}"/bin/zsh?*
-}
-
-pkg_postinst() {
- readme.gentoo_pkg_postinst
- touch_zwc
-}
+zsh-5.0.8.ebuild \ No newline at end of file