summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/zshrc-mv/zshrc-mv-3.10.ebuild')
-rw-r--r--app-shells/zshrc-mv/zshrc-mv-3.10.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-shells/zshrc-mv/zshrc-mv-3.10.ebuild b/app-shells/zshrc-mv/zshrc-mv-3.10.ebuild
new file mode 100644
index 00000000..a4085b34
--- /dev/null
+++ b/app-shells/zshrc-mv/zshrc-mv-3.10.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+RESTRICT="mirror"
+inherit eutils
+
+DESCRIPTION="A zshrc file initializing zsh specific interactive features"
+HOMEPAGE="https://github.com/vaeth/zshrc-mv/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+RDEPEND="!app-shells/auto-fu-zsh[kill-line(-)]"
+
+src_install() {
+ dodoc README
+ insinto /etc/zsh
+ doins zshrc
+}
+
+pkg_postinst() {
+ optfeature "automagic completion" '>=app-shells/auto-fu-zsh-0.0.1.12_p0'
+ optfeature "syntax highlighting" 'app-shells/zsh-syntax-highlighting'
+ optfeature "a nice prompt" '>=app-shells/set_prompt-3.0.0'
+ optfeature "nice directory colors" 'app-shells/termcolors-mv'
+}