summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/zsh/ChangeLog5
-rw-r--r--app-shells/zsh/files/zsh-5.1.0-gcc-5.patch16
-rw-r--r--app-shells/zsh/zsh-5.1.1-r1.ebuild (renamed from app-shells/zsh/zsh-5.1.1.ebuild)1
-rw-r--r--app-shells/zsh/zsh-99999999.ebuild1
4 files changed, 23 insertions, 0 deletions
diff --git a/app-shells/zsh/ChangeLog b/app-shells/zsh/ChangeLog
index 6f53ba40..1f1e1300 100644
--- a/app-shells/zsh/ChangeLog
+++ b/app-shells/zsh/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*zsh-5.1.1-r1 (02 Oct 2015)
+
+ 02 Oct 2015; Martin Väth <martin@mvath.de>:
+ Fix some problems with gcc-5, gentoo see bug 547950
+
*zsh-5.1.1 (20 Sep 2015)
20 Sep 2015; Martin Väth <martin@mvath.de>:
diff --git a/app-shells/zsh/files/zsh-5.1.0-gcc-5.patch b/app-shells/zsh/files/zsh-5.1.0-gcc-5.patch
new file mode 100644
index 00000000..74756d29
--- /dev/null
+++ b/app-shells/zsh/files/zsh-5.1.0-gcc-5.patch
@@ -0,0 +1,16 @@
+https://bugs.gentoo.org/547950
+http://www.zsh.org/mla/workers/2015/msg02660.html
+
+fix building w/gcc-5
+
+--- a/Src/Modules/system.mdd
++++ b/Src/Modules/system.mdd
+@@ -15,7 +15,7 @@
+ touch errtmp.out; \
+ else \
+ $(AWK) -f $(sdir)/errnames1.awk @ERRNO_H@ >errtmp.c; \
+- $(CPP) errtmp.c >errtmp.out; \
++ $(CPP) -P errtmp.c >errtmp.out; \
+ fi
+ $(AWK) -f $(sdir)/errnames2.awk errtmp.out > $@
+ rm -f errtmp.c errtmp.out
diff --git a/app-shells/zsh/zsh-5.1.1.ebuild b/app-shells/zsh/zsh-5.1.1-r1.ebuild
index 400200f2..d5a8bc8e 100644
--- a/app-shells/zsh/zsh-5.1.1.ebuild
+++ b/app-shells/zsh/zsh-5.1.1-r1.ebuild
@@ -116,6 +116,7 @@ src_prepare() {
soelim Doc/zshall.1.soelim > Doc/zshall.1 || die
epatch "${FILESDIR}"/${PN}-init.d-gentoo-r1.diff
+ epatch "${FILESDIR}"/${PN}-5.1.0-gcc-5.patch #547950
cp "${FILESDIR}"/zprofile-1 "${T}"/zprofile || die
eprefixify "${T}"/zprofile || die
diff --git a/app-shells/zsh/zsh-99999999.ebuild b/app-shells/zsh/zsh-99999999.ebuild
index 400200f2..d5a8bc8e 100644
--- a/app-shells/zsh/zsh-99999999.ebuild
+++ b/app-shells/zsh/zsh-99999999.ebuild
@@ -116,6 +116,7 @@ src_prepare() {
soelim Doc/zshall.1.soelim > Doc/zshall.1 || die
epatch "${FILESDIR}"/${PN}-init.d-gentoo-r1.diff
+ epatch "${FILESDIR}"/${PN}-5.1.0-gcc-5.patch #547950
cp "${FILESDIR}"/zprofile-1 "${T}"/zprofile || die
eprefixify "${T}"/zprofile || die