summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/ispell/ispell-3.4.00.ebuild')
-rw-r--r--app-text/ispell/ispell-3.4.00.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/app-text/ispell/ispell-3.4.00.ebuild b/app-text/ispell/ispell-3.4.00.ebuild
new file mode 100644
index 00000000..4916709b
--- /dev/null
+++ b/app-text/ispell/ispell-3.4.00.ebuild
@@ -0,0 +1,62 @@
+# Copyright 2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+RESTRICT="mirror"
+inherit toolchain-funcs
+
+DESCRIPTION="fast screen-oriented spelling checker"
+HOMEPAGE="http://fmg-www.cs.ucla.edu/geoff/ispell.html"
+SRC_URI="http://fmg-www.cs.ucla.edu/geoff/tars/${P}.tar.gz"
+
+LICENSE="HPND"
+SLOT="0/3.4.00"
+KEYWORDS="alpha amd64 ~arm hppa ~mips ppc sparc x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="
+ sys-apps/miscfiles
+ sys-libs/ncurses:0=
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e 's:/usr/local/man:'"${EPREFIX}"'/usr/share/man:' \
+ -e 's:/usr/local/lib:'"${EPREFIX}"'/usr/'"$(get_libdir)/${PN}:" \
+ -e 's:/usr/local:'"${EPREFIX}"'/usr:' \
+ -- "${S}"/local.h.* || die
+ sed -i \
+ -e 's:\(^#define CC\).*:\1 "'"$(tc-getCC)"'":' \
+ -e 's:\(^#define CFLAGS\).*:\1 "'"${CFLAGS}"'":' \
+ -- "${S}"/config.X || die
+ eapply_user
+}
+
+src_configure() {
+ # Prepare config.sh for installation phase to avoid twice rebuild
+ emake -j1 config.sh
+ sed \
+ -e "s:^\(BINDIR='\)${EPREFIX}\(/usr.*\):\1${ED}\2:" \
+ -e "s:^\(LIBDIR='\)${EPREFIX}\(/usr.*\):\1${ED}\2:" \
+ -e "s:^\(MAN1DIR='\)${EPREFIX}\(/usr.*\):\1${ED}\2:" \
+ -e "s:^\(MAN45DIR='\)${EPREFIX}\(/usr.*\):\1${ED}\2:" \
+ < config.sh > config.sh.install
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ mv config.sh.install config.sh
+ emake -j1 install
+ dodoc CHANGES Contributors README WISHES
+}
+
+pkg_postinst() {
+ echo
+ ewarn "If you just updated from an older version of ${PN} you *have* to re-emerge"
+ ewarn "all your dictionaries to avoid segmentation faults and other problems."
+ echo
+}