summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/python/files/curses_tinfo.patch')
-rw-r--r--dev-lang/python/files/curses_tinfo.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/dev-lang/python/files/curses_tinfo.patch b/dev-lang/python/files/curses_tinfo.patch
new file mode 100644
index 00000000..6048f8cf
--- /dev/null
+++ b/dev-lang/python/files/curses_tinfo.patch
@@ -0,0 +1,13 @@
+# https://bugs.gentoo.org/457530
+# https://bugs.gentoo.org/692128
+--- 1/setup.py
++++ 1/setup.py
+@@ -1396,7 +1396,7 @@
+ curses_defines.append(('_XOPEN_SOURCE_EXTENDED', '1'))
+
+ if curses_library.startswith('ncurses'):
+- curses_libs = [curses_library]
++ curses_libs = [curses_library, 'tinfo']
+ exts.append( Extension('_curses', ['_cursesmodule.c'],
+ include_dirs=curses_includes,
+ define_macros=curses_defines,