summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/osformat/osformat-999999999.ebuild')
-rw-r--r--dev-libs/osformat/osformat-999999999.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/osformat/osformat-999999999.ebuild b/dev-libs/osformat/osformat-999999999.ebuild
new file mode 100644
index 00000000..fe9ec08d
--- /dev/null
+++ b/dev-libs/osformat/osformat-999999999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils
+
+case ${PV} in
+99999999*)
+ EGIT_REPO_URI="git://github.com/vaeth/${PN}.git"
+ inherit git-r3
+ SRC_URI=""
+ PROPERTIES="live";;
+*)
+ RESTRICT="mirror"
+ EGIT_COMMIT="7ea6497698b11fa3289b223b2e2d487500dcaa10"
+ SRC_URI="https://github.com/vaeth/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${EGIT_COMMIT}";;
+esac
+
+DESCRIPTION="C++ library for a typesafe printf/sprintf based on << conversion"
+HOMEPAGE="https://github.com/vaeth/osformat/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+src_prepare() {
+ eapply_user
+ eautoreconf
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}