summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/ccache')
-rw-r--r--dev-util/ccache/ccache-99999999.ebuild (renamed from dev-util/ccache/ccache-99999999-r3.ebuild)11
-rw-r--r--dev-util/ccache/files/ccache-3.1.7-no-perl.patch15
2 files changed, 5 insertions, 21 deletions
diff --git a/dev-util/ccache/ccache-99999999-r3.ebuild b/dev-util/ccache/ccache-99999999.ebuild
index 0d9fed91..e4fbbe38 100644
--- a/dev-util/ccache/ccache-99999999-r3.ebuild
+++ b/dev-util/ccache/ccache-99999999.ebuild
@@ -2,11 +2,11 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
-
+EAPI=6
WANT_LIBTOOL=none
+EGIT_MIN_CLONE_TYPE=single
EGIT_REPO_URI="git://git.samba.org/ccache.git"
-inherit autotools eutils git-r3 readme.gentoo
+inherit autotools git-r3 readme.gentoo
DESCRIPTION="fast compiler cache"
HOMEPAGE="http://ccache.samba.org/"
@@ -25,12 +25,11 @@ RDEPEND="${DEPEND}
src_prepare() {
# make sure we always use system zlib
rm -rf zlib || die
- epatch "${FILESDIR}"/${PN}-3.1.7-no-perl.patch #421609
- epatch "${FILESDIR}"/${PN}-3.1.10-size-on-disk.patch #456178
+ eapply "${FILESDIR}"/${PN}-3.1.10-size-on-disk.patch #456178
sed \
-e "/^EPREFIX=/s:'':'${EPREFIX}':" \
"${FILESDIR}"/ccache-config-3 > ccache-config || die
- epatch_user
+ eapply_user
eautoreconf
}
diff --git a/dev-util/ccache/files/ccache-3.1.7-no-perl.patch b/dev-util/ccache/files/ccache-3.1.7-no-perl.patch
deleted file mode 100644
index 5abd15e1..00000000
--- a/dev-util/ccache/files/ccache-3.1.7-no-perl.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-avoid weak perl usage in tests
-
-https://bugs.gentoo.org/421609
-
---- a/test.sh
-+++ b/test.sh
-@@ -1466,7 +1466,7 @@
- mkdir -p $dir
- i=0
- while [ $i -lt 10 ]; do
-- perl -e 'print "A" x 4017' >$dir/result$i-4017.o
-+ printf '%4017s' '' | tr ' ' 'A' >$dir/result$i-4017.o
- touch $dir/result$i-4017.stderr
- touch $dir/result$i-4017.d
- if [ $i -gt 5 ]; then